Exchange Sync Issue

Discussion in 'ChevyNo1' started by hchucky, Mar 24, 2011.

  1. hchucky

    hchucky New Member

    Joined:
    Jul 18, 2010
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    I have several Exchange accounts setup against two different Exchange servers. When I set them up originally after a fresh flash to 5.1 everything seemed fine. Then shortly after setup I realized that non of the accounts were syncing (can not send or receive email). I ran Fix Permissions and rebooted and all of accounts began to sync. A few days later I noticed that all of them stopped syncing again. For grins I ran Fix Permissions again. This time no luck. I had the exact same problem running v5.01 only in that case I just lived without email until 5.1 arrived. Searching around I don't seem to see anybody else having this issue. I've setup Exchange accounts many times in the past without issue so I'm confident everything is setup correctly. When I click the sync button from within an account nothing happens (normally I see the sync symbol at the top of the window). Does anybody have any thoughts on how to resolve this? HC
     
  2. borq646

    borq646 Member

    Joined:
    Jun 9, 2010
    Messages:
    145
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Michigan
    Ratings:
    +0
  3. Gunslinger

    Gunslinger Member

    Joined:
    Jul 28, 2010
    Messages:
    168
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Rutherfordton, NC
    Ratings:
    +0
    The problem is more likely related to Chevy's task killer, which runs at boot, unless disabled. By default, it kills many processes and prevents them from being restarted. One of these is com.android.email, the Email process. You can edit /data/chevyno1/csm.lst, and remove that entry, and your email should come up properly.

    More details in the SS 5.1 release thread here. Give it a shot, but make a backup first, just in case :)
     
  4. borq646

    borq646 Member

    Joined:
    Jun 9, 2010
    Messages:
    145
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Michigan
    Ratings:
    +0
    I beg to differ. I disabled the task killer and still had my email processes killed hours after a boot. Once I changed the settings in the app mentioned and used Swapper2 I've had zero problems.

    Just throwing that out there.
     
  5. Gunslinger

    Gunslinger Member

    Joined:
    Jul 28, 2010
    Messages:
    168
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Rutherfordton, NC
    Ratings:
    +0
    I'll give you that it's possible that changing the task killer won't help, but after removing that entry, my Exchange never misses a beat. And since the OP didn't mention it, I thought it was worth pointing out. Chances are that it will make a difference.
     
  6. ChevyNo1

    ChevyNo1 Premium Member
    Premium Member Developer

    Joined:
    Dec 28, 2009
    Messages:
    5,354
    Likes Received:
    5
    Trophy Points:
    153
    Ratings:
    +5
    It was likely killed hours later by Android itself - my task killer simply makes it happen at bootup. Even if you disable my task killer completely - Android will kill stuff as it sees fit.

    With 5.2 you will be able to lock Email into memory ...
     
  7. borq646

    borq646 Member

    Joined:
    Jun 9, 2010
    Messages:
    145
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Michigan
    Ratings:
    +0
    woot woot 5.2. :heart:
     
  8. hchucky

    hchucky New Member

    Joined:
    Jul 18, 2010
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    I have edited /data/chevyno1/csm.lst and removed com.android.email. After a reboot I now see that the email SyncManager and Email (com.android.email) processes is running however my Exchange accounts still do not sync. borq646, you mentioned that you "...changed the settings in the app mentioned...". I did not see an app mentioned in this thread. Is there another tweak I should be making somewhere? HC
     
  9. borq646

    borq646 Member

    Joined:
    Jun 9, 2010
    Messages:
    145
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Michigan
    Ratings:
    +0
    Post #12 in the thread I linked:


    1) Install "AutoKiller Memory Optimizer" from Market.
    2) Open AutoKiller > Menu > Settings > Enable advanced mode
    3) Set the following values:
    Foreground app: 6
    Visible app: 10
    Secondary server: 20
    Hidden app: 24
    Content provider: 28
    Empty app: 28
    4) Apply new values
    5) Reboot device

    Use these settings for a while and report back..,It should fix your problem.

    If these values work good I may include them by default.
     
    #9 borq646, Mar 24, 2011
    Last edited: Mar 24, 2011
  10. hchucky

    hchucky New Member

    Joined:
    Jul 18, 2010
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Thx. I appear to be back in business for now. After the initial reboot email was still not syncing so I ran Fix Permissions again and after that reboot email\calendar updates started to flow in. Perhaps I just didn't wait long enough after the first reboot...in any case fixed for now. Thanks again for your help. HC
     
  11. hchucky

    hchucky New Member

    Joined:
    Jul 18, 2010
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Well that was short lived. Email has stopped syncing again. I've upgraded to 5.2 and still no luck. I've also locked my Exchange accounts in memory, no luck there either. I can see the SyncManager and Email are running. What else needs to be running in order to properly sync? HC
     
Search tags for this page

android 2.3.7 exchange 2010

,

android 2.3.7 sync corporate email where is calendar

,

exchange 2010 android 2.3.4

,

gingerbread 2.3.7 calendar exchange account