Exchange 2007 Calendar Sync?

Discussion in 'Android General Discussions' started by ev01, Nov 6, 2009.

  1. ev01
    Offline

    ev01 New Member

    Joined:
    Nov 6, 2009
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    0
    Anyone having problems with their calendar not syncing with the droid? I came from a windows mobile device that worked flawlessly.. with te droid I just get a message saying 'Sync Failed' when I try to sync the calendar. Email and contacts Sync fine. :icon_eek:
  2. cvondra
    Offline

    cvondra New Member

    Joined:
    Nov 3, 2009
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Midwest US
    Same issue here. Mail and Contacts sync flawlessly but calendar comes back sync failed.

    happens on both droid phones we have here. One came from BB Storm and one came from WinMo.

    Exchange 2007. Service pack is not installed anyone else who is running Exch. 2k7 with SP not installed and have calendar sync working let me know.

    Chad
  3. BigTex71
    Offline

    BigTex71 New Member

    Joined:
    Nov 5, 2009
    Messages:
    184
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Keller, TX
    We run Exchange2003 and it syncs fine. I know it doesn't answer your question, but just wanted to throw out that 2003 syncs the calendar.
  4. bguild
    Offline

    bguild New Member

    Joined:
    Nov 6, 2009
    Messages:
    36
    Likes Received:
    0
    Trophy Points:
    0
    Exchange Sync only syncs Calendar, no email or contacts

    Guys, first of all, I love this phone, but as a former Blackberry user, I am going to have to return it if I can't get the Exchange ActiveSync to work.

    I have instructions here from my IT Admins to connect to our Exchange Environment via ActiveSync. We have an externally available address for the OMA server, so no problem there.

    Also, Android accepts my settings, and is apparently able to connect, because I don't get any errors. Yet, Contacts and Email don't sync, and I can't send emails. I see all my Exchange Appointment in Corporate Calendar!!

    Are there any additional tips from the users here, or any way I can troubleshoot this? Any log files I can look at to see why the Droid isn't doing this correctly?

    Thanks,

    Brian
  5. smallprint
    Offline

    smallprint New Member

    Joined:
    Nov 6, 2009
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    0
    the problem is that your exchange server is most likely pushing a security policy to the phone. Droid does not accept it. I have been troubleshooting this all day and determined that is the answer. check out my others posts.

    Ask your admin is they remote wipe from exchange, if so that mean they push security policy to the phone = wont work on droid.
  6. bguild
    Offline

    bguild New Member

    Joined:
    Nov 6, 2009
    Messages:
    36
    Likes Received:
    0
    Trophy Points:
    0
    smallprint, you seem to be pretty knowledgeable on this issue - is there any way to disable the security for Windows Mobile devices at the Exchange Server level, or preferably, at the user level to do a test on my Droid?
  7. smallprint
    Offline

    smallprint New Member

    Joined:
    Nov 6, 2009
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    0
    I would first try to prove that a security policy does exist before goin to your exchange admin. This can be done my simply connecting to your ex hange serger with WindowsMobile phone or iPhone. Once you add your corporate email to it, it will tell you that you must apply a security policy and force you to create pin.

    How to disable from the server level. An admin can disable th entire security policy and no one will have to create a "device pin lock" on thier phones, or they can just tell exchange your account is an exception, and to not apply a secuirty policy.

    To ad your accont as an exception, log into the exchange server, open ESM ( exchange system mananger...it's the exchange admin tool). Expand the structure, and select global properties of of mobile devices. Right click mobile devices and select properties. There should be a security tab that says "exceptions". Brose ad and add your domain account.

    At this point remove an re add your account to the droid.


    Any luck? I explained the exhange from memory, bit I don't think I missed a step.
  8. smallprint
    Offline

    smallprint New Member

    Joined:
    Nov 6, 2009
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    0
    I'm replying I iPhone , ignore and typos ;)
  9. usererror
    Offline

    usererror New Member

    Joined:
    Nov 7, 2009
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    0
    Exchange 2003 here.

    I am in the same boat, however adding myself to the exchange server "exception" list for the PIN Security and Remote wipe DID NOT WORK. Sadly. I am extremely bummed at the moment. I also removed ALL SECURITY requirements from Exchange for mobile devices and that did not even help one bit.

    I can send email from exchange on the droid, it did pull my contacts, I can see my folders, but no email at all shows up.
  10. cvondra
    Offline

    cvondra New Member

    Joined:
    Nov 3, 2009
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Midwest US
    Back to Exchange 2007. We have success! Upgraded the exchange server to SP2.

    Remove the corporate account from your Droid.

    In Exchange, go into the user account and manage mobile devices. Remove all partnerships to that account.

    Re-Add your corporate exchange account on Droid.

    Let your mail sync.

    Go into your Calendar and you should have sync now.

    You may see "Calendar data my be reset and resynch" If this happens hit OK.

    If it still throws a failed error repeat the process. I have confirmed this to work on 2 Droids.

    WOOT!
    Last edited: Nov 7, 2009
  11. cvondra
    Offline

    cvondra New Member

    Joined:
    Nov 3, 2009
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Midwest US
    Another possible solution for Calendar sync. This came from from the Moto forum.

    Do these steps fix the calendar syncing issue for you?


    1. Go to Settings > Applications > Running Services
    2. Locate and Stop the SyncManager service
    3. Then restart the device...

    This has worked for two other DROID users who tried it...


    Not sure if they had SP2 on or not. Will ask.
  12. usererror
    Offline

    usererror New Member

    Joined:
    Nov 7, 2009
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    0
  13. loboblanco
    Offline

    loboblanco New Member

    Joined:
    Nov 6, 2009
    Messages:
    43
    Likes Received:
    0
    Trophy Points:
    0
    fixed it

    I had the same problem, email was synched but no calendar, it would say "authentication failed"

    Go into your corporate webmail (OWA) and select "Mobile Devices" and then remove Android from the list. Then quickly before it can reconnect, remove the account from the Droid. Have the screen on the droid ready to go so you can remove your account on the phone immediately after you remove the phone from the connection list on your OWA screen on your computer.

    Then recreate your exchange account on the droid and let it synch all of your email. After all of your email is current, then open the corporate calendar. It should synch your calendar then. (it did for me)
  14. usererror
    Offline

    usererror New Member

    Joined:
    Nov 7, 2009
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    0
    Lobo - Did your OWA Mobile Devices list one called Droid########## and one called Android############# ?? Mine has two listed.

    -Mark

  15. cvondra
    Offline

    cvondra New Member

    Joined:
    Nov 3, 2009
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Midwest US
    No its not.

    Follow my instructions on blowing away ALL partnerships to the user account. There is 2 yes.
  16. loboblanco
    Offline

    loboblanco New Member

    Joined:
    Nov 6, 2009
    Messages:
    43
    Likes Received:
    0
    Trophy Points:
    0
    Mine only had one listed, Android. But I would say if you have 2, delete both of them and start over.
  17. loboblanco
    Offline

    loboblanco New Member

    Joined:
    Nov 6, 2009
    Messages:
    43
    Likes Received:
    0
    Trophy Points:
    0
    Your method doesn't work for people who are receiving "authentication error" You have to remove the association from the OWA screen on the exchange server website, then delete the account on the Droid, then start over. I believe people with 2003 are getting "authentication error" and people with 2007 are getting "synch error"
  18. yrock
    Offline

    yrock New Member

    Joined:
    Nov 8, 2009
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    I could sync mail and contacts with the server set as server: "owa.mycompany.com/exchange"

    I deleted the account and tried again with a slightly different url for server: "owa.mycompany.com"

    This worked better! the calendar now works and sync'ed OK. :)
  19. lokiju
    Offline

    lokiju New Member

    Joined:
    Nov 7, 2009
    Messages:
    34
    Likes Received:
    0
    Trophy Points:
    0
    If it helps...

    I was having issues where I could get my calendar but not my emails to show up.

    In exchange 2007 the option for "allow non-provisionable devices" had to be checked.

    Took about 10 mins to start working after that.
Search tags for this page
add exchange account to android calendar
,
android sync calendar exchange 2007
,
calendar
,
droid razr exchange calendar sync issue list category
,

exchange 2007 calendar not syncing

,
exchange 2007 calendar on android
,
exchange 2007 calendar sync android
,
exchange 2007 only sync calendar
,
force calendar sync droid with exchange
,
galaxy s4 exchange calendar sync problem fix
,

sync only calendar from exchange

,
synchronize calendar android to exchange 2007