1. You want that $100.00 in your pocket or an Amazon Fire TV don't you? Well here's the deal. With our new updated look we are in desperate need of an updated logo. The 'old' one has certainly served us well, but it's time. Find all the details here: bit.ly/1q0k6Wa
  2. DroidForums.net is currently undergoing a major software upgrade. If you are experiencing any problems logging in please: Contact Us

error no sd card detected apps can't run normally..BUT THEY WORK FINE!!!!

Discussion in 'Android Tech Support' started by TuBitMittens, Apr 24, 2010.

  1. TuBitMittens
    Offline

    TuBitMittens Member

    Joined:
    Jan 6, 2010
    Messages:
    599
    Likes Received:
    3
    Trophy Points:
    18
    I don't know why I'm getting this error. EVERY time I start up my droid I'll get the error saying my sd card cant be detected and the apps wont work properly but everything is there and is working like it should. I'm not sure if maybe I did something to the card?? I remember in the past I'd do the procedure where you take out the card and battery for half a minute or so and then put it back in to make it work better. but I'd either have trouble getting the sd card out or how to put it back in(I know how to do that now)
    now ONCE IN AWHILE, I'd get the error I mentioned but now i'm getting it EVERY TIME I START UP THE PHONE! I tried turning off the phone and removing both the card and battery waiting for maybe 30 second or a minute, over and over again and I'm getting the same fcking erroe. sometimes my phone might freeze for a moment at start up and the background might be black..BUT ITS SMOOTH SAILING FROM THERE AND EVERYTHING IS FINE AFTER THAT!!
    so yea the phone's workingok but this error is unnerving to me. does anybody have any ideas? I hope I didn't screw up my phone..I tried unmounting the card as well BEFORE turning it off and still no luck...:icon_eek:
  2. jev
    Offline

    jev Member

    Joined:
    Nov 18, 2009
    Messages:
    413
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Clemmons, NC
    Mine's doing it too. It may be an app or maybe a ROM problem. Are you rooted and if so, what are you running? I'm using cyanogenmod 5.0.6.2. It doesn't really bother me enough to worry about it though.
  3. TuBitMittens
    Offline

    TuBitMittens Member

    Joined:
    Jan 6, 2010
    Messages:
    599
    Likes Received:
    3
    Trophy Points:
    18
    no i havnt hacked my phone. i did do the manual update to 2.1 though. somebody suggested in another thread to get a micro sd card adaptor? this problem is still occuring. i hope i didnt ruin the card when trying to remove it or insert it for the first time. i dont think i really used that much force. plus all my photos and apps appear in storage.
  4. Zippster
    Offline

    Zippster New Member

    Joined:
    Oct 28, 2009
    Messages:
    523
    Likes Received:
    1
    Trophy Points:
    0
    Location:
    Buffalo NY
    I am getting this too occasionally, the only thing that fixes it is rebooting my phone. It just started after the 2.1 update and I have had my Droid since opening day, full body glove on it and is taken care of flawlessly so would say it is a software issue on their side.
  5. jsh1120
    Offline

    jsh1120 New Member

    Joined:
    Dec 9, 2009
    Messages:
    2,462
    Likes Received:
    1
    Trophy Points:
    0
    Location:
    Seattle, Washington
    The problem likely stems from the order of and time consumed in the "housekeeping" tasks the o/s does when it boots. The error probably comes from an app that is trying to start before the o/s has finished mapping the SD card. Once that job is done, however, the app tries again and works fine.

    If you're using the Swype beta, you can see a similar phenomenon. Swype tries to start itself during the boot process. But when it does, the Android o/s has not finished its housekeeping tasks. Swype is coded to shut itself down when it encounters that problem (rather than to wait and try again.) Thus, Swype won't work until you enable another input method and then switch back to Swype. At that point the o/s is fully operational and Swype starts just fine.

    The bottom line is, don't worry about it. I believe it has become more common after the 2.1 update simply because the new version of the o/s takes longer to boot than the older version.
  6. TuBitMittens
    Offline

    TuBitMittens Member

    Joined:
    Jan 6, 2010
    Messages:
    599
    Likes Received:
    3
    Trophy Points:
    18
    been awhile since i posted on here. ive realized another problem, while the apps generally perform properly, while im connected to the pc this isnt the case, and it will give me the message that theres no sd card or whatever. i hope i didnt screw up my sd card by figuring out how to get it in and that this is just a bug that hopefully has a posibilityu of being fixed once android 2.2 rolls out. :/ anyway i am able to mount my phone so the sd card is working somewhat..still get this EVERY time i boot up my phone. sometimes if i wate like at least a minute before unlocking it, the message wont show up but it will still show on my pc, regardless.
Search tags for this page
android no sd card detected
,
cant run android apps on sd card
,
detect app on sd card
,
error message when trying to take pics on droid razr because
,
if no sd card can applications run?
,

no sd card detected

,
no sd card detected android
,

no sd card detected droid

,
troubleshoot no sd card detected on motorola droid razar hd
,
why does my samsung android say i dont have a sd card and ph