epic term emu permission denied

Discussion in 'Android Hacks and Help' started by Shmooze, Mar 25, 2010.

  1. Shmooze

    Shmooze Member

    Joined:
    Jan 24, 2010
    Messages:
    82
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Ohio
    Ratings:
    +0
    Well, for whatever reason I no longer have the ability the run BB's wonderful scripts due to the "permission denied" message. I'm rooted with super user, so is there any way of fixing without a pc? (I'm at work ;)
     
  2. baniels

    baniels Member

    Joined:
    Dec 19, 2009
    Messages:
    574
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    52556
    Ratings:
    +0
    You can use Root Explorer to change the permissions on the script files. I changed all of mine to RWXRWXRWX. May have been overkill, but it worked.
     
  3. BayouFlyFisher

    BayouFlyFisher Rescue Squad
    Rescue Squad

    Joined:
    Dec 10, 2009
    Messages:
    4,959
    Likes Received:
    17
    Trophy Points:
    168
    Location:
    Baton Rouge, LA
    Ratings:
    +17

    Open a terminal emulator and type the following:

    su

    mount -o remount,rw -t yaffs2 /dev/block/mtdblock4 /system



    chmod 777 /system/xbin/enablescripts



    mount -o ro,remount -t yaffs2 /dev/block/mtdblock4 /system


    exit


    Then run this and then the script that you want:
    [FONT=&quot]su
    enablescripts
    (it'll come up with "all scripts enabled" or something)

    Then run the scripts you want.

    [/FONT]
     
  4. Shmooze

    Shmooze Member

    Joined:
    Jan 24, 2010
    Messages:
    82
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Ohio
    Ratings:
    +0
    Rad, thanks guys
     
Search tags for this page

android term permission denied

,
hexxit.epicemu.com