Email addresses synced via Exchange ActiveSync have quote marks around them

Discussion in 'Android Tech Support' started by jeffreycowart, Sep 19, 2011.

  1. jeffreycowart
    Offline

    jeffreycowart New Member

    Joined:
    Sep 19, 2011
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    0
    Hello,
    I have searched around and have not seen any other people with this issue. (just my luck).

    Droid Bionic 2.3.4

    I have synced my contacts from Exchange 2003 using active sync. The sync appears to go perfectly with no errors. All my mail and contacts have come through. (Some cal appointments didn't sync, but thats another issue).

    All my e-mail address appear like this: "user@domain.com" <user@domain.com> in the stock contact list.
    It duplicates the e-mail address, putting the first one in quotation marks and brackets <> around the second one.

    I looked in my Outlook 2010 to see if it was the Display Name field, but it is not. The Stock contact list is making this change for some reason.

    The default client can handle this format, but the gmail app really gets screwed up and will put: User <"user@domain.com" <user@domain.com>> which is invalid and will not send.

    When the contacts are imported into Touchdown, they import correctly and only appear as user@domain.com.

    Is anyone else having this issuer where the stock contact list being synced with exchange saves e-mail addresses as "user@domain.com" <user@domain.com> ?

    I have removed the exchange sync and readded it. Could a complete wipe solve this issue?
    Gmail syncs fine. I cannot sync exchange contacts through g-mail because I will lose too much data (birthdays, long notes, categories, etc)

    Thanks for your time!

    Jeff
  2. jeffreycowart
    Offline

    jeffreycowart New Member

    Joined:
    Sep 19, 2011
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    0
    Bionic Contact List Handles Email Addresses Unexpectedly from Exchange Server

    Guess I am the only one having this issue..
    Motorola is also stumped, waiting for a call back from Level 3 support.

    Here is a more detailed explanation:

    I have an issue where the email address imported from Exchange are formatted in an unexpected way. The email address is listed twice, the first time surrounded with quotes and the second time with <>.
    I have attached some pictures of the issue.

    Attached are 4 pictures:
    1. Outlook Contact Listing: Shows how the Contact is listed in Outlook
      Outlook Contact listing.JPG
    2. Bionic Contact: Shows how the email address is formatted after being imported into the Motorola Bionic via Active-sync from Exchange 2003
      Bionic Contact.JPG
    3. Contact selected in Gmail: Shows how the email address is inserted into an e-mail when inside the G-mail application
      Contact selected in Gmail.JPG
    4. Gmail Error bad e-mail address: shows the returned email error, because the email address is not valid.
      Gmail error bad e-mail address.JPG
    Other important notes:
    • 1 other person in our office has a HTC Incredible, he does not have this issue and his contact email address display correctly.
    • When viewing a contact if I select to send that person an e-mail, it will compose a new e-mail using the address format: “user@domain.com” <user@domain.com>
      • The above format will send correctly from corporate email or Gmail
      • But when I am inside the gmail app, and select the contact from there, is when it formats it like the picture above: user <user@domain.com <user@domain.com>>
    • The app touchdown, will import the email address correctly: user@domain.com
      • Touchdown will also transfer the touchdown contact to the phone contacts and they are transferred correctly
    • Hotmail and Gmail import address correctly: user@domain.com
    Troubleshooting performed:
    • Removed and readded the exchange account
    • Tried 3[SUP]rd[/SUP] party email applications like Touchdown and RoadSync (they Worked 100% as expected and formatted the address correctly)
    • Factory reset the phone and added the exchange account before anything else (including my gmail account)
    Since other users in my company and 3[SUP]rd[/SUP] party apps handle the Exchange ActiveSync information correctly, I believe the issue is within the Bionic stock contact manager
  3. MNBV
    Offline

    MNBV New Member

    Joined:
    Sep 23, 2011
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    Contats with no phone number?

    Are these contacts with the quotes around them contacts that have no phone number?

    If so open your contacts, go to settings -> display options and check Only contacts with phones.

    This resolved this on mine.

    I think these are either contacts that have no phone number or contacts from the nk2 file.

    Let me know if that helps you out.

    -Brandon
  4. jeffreycowart
    Offline

    jeffreycowart New Member

    Joined:
    Sep 19, 2011
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    0
    Unfortunately, this is a separate issue. These are complete contacts with phone, address, email, etc.
    What you are talking about is when Exchange syncs the Suggested Contacts List. Those list in the address book as: 'user@domian.com'
    If you open the contact and view email address, it is listed the incorrect way: "user@domain.com" <user@domain.com>

    I ran across that issue when I first synced with Exchange, scared me... All you have to do is uncheck the Suggested Contacts, in display options under the correct account. (or as you suggested "only show contacts with phones", but I don't like that because some of my contacts are e-mail only.

    But you did give me a new idea, maybe there is an improperly formatted email address in my contact list that is "triggering" this problem. I am sure I have a few e-mail addresses that are not formatted correctly. I have 1,900 contacts so it will take me a while to validate my addresses.

    Any more suggestions?

    Thanks
  5. jeffreycowart
    Offline

    jeffreycowart New Member

    Joined:
    Sep 19, 2011
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    0
    Returned My Bionic: Blackberry Enterprise users, think twice before moving to Android

    Had too many issues with my Bionic, so I returned it to Verizon.
    If you are a Blackberry Enterprise user, think twice before moving over to the Android platform

    Issues I had:
    • ActivSync Exchange Contacts e-mail addresses were formatted wrong (see above)
    • Active Sync Calendar would not pull down all events. It randomly selected which events to pull sync.
    • Popping sound in ear piece when phone was ringing or the other party talked loud
    • No Vibrate then ring function (seems basic to me, so you can catch a call or message before it makes noise)
    • No sound profiles, only On or Vibrate. If you want to change something, you have to go to multiple apps.
    • No automatic changing of profile at night, or when plugged in. (yes you can get an app, but that is basic...)
    • No Auto Text. (i.e. type XX and get a signature or long word) I like to set up quick texts for standard signatures, words, etc. (Yes, you can get an app, but that eats memory and battery)
    • To get more that 7-8 hours of battery life (even when not using the device) you have to turn off "background data". Well then most of your mail, etc does not automatically sync (Isnt that the purpose of a smartphone??)
    • No default WAV file playback, for my work voicemail system, had to buy an app "wav Player" to handle playback
    • Music playback was screwed up. I had to play a song on Vcast, then go back to my library to be able to understand (sounded electronic and synthesized) the mp3 stored locally. (could have been an issue with the wav player app)
    I am a long time Blackberry user, and I wanted to make the move to Android, a supposedly more advanced and configurable OS, but I feel I took a huge step backwards.
    The internet, html mail, google maps, navigation was unbelievably good on this phone, unfortunately as a business phone mail, contacts, and calendar come before fun stuff...

    I guess in one sense it is great to be able to go buy and App that does or handles the information, just the way you want. But on the other hand, seems like the apps wore down the battery and didn't play nice with each other. Blackberry seems much more refined and just WORKS.

    Maybe someone can correct me that having lots of apps loading at startup will not affect battery life or performance, but then why do people root phones and "freeze" apps to prevent them from starting at bootup?

    I hope that Ice Cream Sandwich will address some of these issues, but doubt it, seems like they are just trying to make a tablet-phone compatible OS. Which to me is silly. A phone should/will have a completely different set of required functions than a tablet.

    Just my 2 cents.

    Jeff
  6. Moehusker
    Offline

    Moehusker New Member

    Joined:
    Jan 24, 2012
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    I have the same issue

    Have you heard of a solution for this issue? I ended up editing my contacts on my phone!

  7. jeffreycowart
    Offline

    jeffreycowart New Member

    Joined:
    Sep 19, 2011
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    0
    No. I never found a solution, so I returned the phone.

    I now have a Galaxy Nexus and do not have that issue.

    It must be a Motorola or motoblur issue, because we have HTC and Samsung phones in my company without that issue.

    Good luck!

    Sent from my Galaxy Nexus using Tapatalk
  8. kcorbett
    Offline

    kcorbett New Member

    Joined:
    Aug 31, 2010
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Richmond, VA
    I am also experiencing this issue. Has anyone figured this out yet? I sync my contacts with Exchange.
  9. alexfarris
    Offline

    alexfarris New Member

    Joined:
    Jun 21, 2012
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    I have the exact same issue

    It is frustrating. I can't find any other posts on the web describing the same problem. Any update on this issue would be appreciated. My Bionic performed a sw update a few days ago, but to no avail. I can't send emails with this incorrect format, ""user@domain.com" <user@domain.com>".
  10. vovers1
    Offline

    vovers1 New Member

    Joined:
    Jan 6, 2012
    Messages:
    23
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Al-Khobar Saudi
    I am having the same issue on the Droid Razr - Synching exchange server contacts to phone.
    The email address becomes
    [FONT=Verdana, Geneva, sans-serif] "text" <user@domain.com>, my stock corporate email app handles this address just fine.[/FONT]
    [FONT=Verdana, Geneva, sans-serif]It is GOOGLE Gmail app that seems to be screwed up and changes the address when composing an email from this address to
    [/FONT] text <"text" <user@domain.com>> which is invalid.
    I hope this is not some intentional thing from our big brother Google to upset the communication with MS Exchange.
    It looks like the
    [FONT=Verdana, Geneva, sans-serif]"text" <user@domain.com> format is exported from exchange whenever anything more than the email address
    [/FONT]user@domain.com[FONT=Verdana, Geneva, sans-serif] is listed in the email address field in exchange.[/FONT]


  11. irishlaxer
    Offline

    irishlaxer New Member

    Joined:
    Sep 7, 2010
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Philadelphia, PA
    Same issue on my MOTO Atrix, anyone figure out a solution on this? Frustrating
Search tags for this page
activesync adding quotes to email
,
activesync contact email in quotes
,
activesync how do i remove email addresses from contacts
,
android people exchange activesync wrong email format
,

do email addresses have single quote marks

,
email address outlook 2010 puts quotes
,
exchange 2010 - quotation marks on email
,
my company email address name changed to quotation marks
,

my email addresses appear in quotes

,
outlook 2010 puts quotes around addresses
,
outlook contacts have quote
,
outlook quotes around email address
,
quotation+marks+around+email+address outlook
,
quote marks around email addresses
,

quotes around email address