Droid2g Wont Root After REcent UPdate.

Discussion in 'Android Hacks and Help' started by cr0ck1, Sep 7, 2011.

  1. cr0ck1
    Offline

    cr0ck1 New Member

    Joined:
    Sep 7, 2011
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Ok guys ive been on the forum for a while and said hey let me register! Well heres the problem im having..


    Ok i have a droid2g and it was rooted fine using the z4root one click.. SOOO one morning i woke up and the phone did an automatic update and now i have new android version (Version 2.3.3) So i tried to teather and it said (not rooted) so i tried re rooting, Pulling the battery tying again, and all of the things you need to do.. I even Whiped the phone to origionl state and reinstalled all applications and tried again and it wont do it..




    Basically what happens is the z4root will start, aquire webshell then just shut down. WHen i go to reopen it, it says it quit unexpectedly. i do the re boot and so on and pull the battery and it just gets to that point and quits. I have super user installed and everything right.. ITs just something will not let it happen.


    BTW when i whiped the phone clean and did a full restart it started with the same dam software that screwed my droid up to begin with..


    Now i down loaded the root checker and this is the errors i get..


    --------------------------------------------------------------


    -Superuser.apk - com.noshufou.android.su - version 2.3.6.3 is installed!


    System Environment PATH: /sbin /vendor/bin /system/sbin /system/bin /system/xbin

    The adb binary is set to default shell user access as a standard non-root user

    Standard su binary location: ls -l /system/bin/su:
    -rwxr-xr-x root shell 26264 2011-08-10 19:25 su

    Standard su binary location: ls -l /system/xbin/su:

    /system/xbin/su: No such file or directory

    Alternate su binary location:
    /sbin/su: Permission denied

    Alternate su type binary location:
    /system/xbin/sudo: No such file or directory

    SU binary not found or not operating properly

    Results provided on your DROID2 GLOBAL device by Root Checker version 3.7 from joeykrim in the Android Market - http://goo.gl/GgWae

    Connected by DROID on Verizon Wireles-----------------------------------------------------------------------

    I went to the super user program and it said that i needed to reboot and update the su binary by flashing it.. Ok im good but not that good. I try to get the android into safe mode and it gets stuck.. Sooooo.. What can i do?



    I really need help.. I use my computer in the woods when im up at camp and have to do html and stuff its hard doing it on the droid phone due to it being so small.. Can anyone please help me!!?


    Thanks Ahead
    Carl.
     
  2. JSM9872
    Offline

    JSM9872 DF Super Moderator Staff Member Premium Member

    Joined:
    Dec 21, 2010
    Messages:
    12,923
    Likes Received:
    287
    Trophy Points:
    498
    Location:
    Pennsylvania...
    Ratings:
    +287
    Current Phone Model:
    Galaxy Note 3
    Sorry, I realize this thread is a couple days old. But the reason it wont root using z4 is because of the fact your phone is currently running 2.3.3, which z4 is not compatible with. You currently have 2 options. 1) To SBF (there is a great guide on how to do this in the Rescue Squad - Guides section) your phone back to 2.2 and then root with z4 or 2) Look up the "D3 One Click Method" which is capable of rooting your phone in its current state.