Droid X2 wifi sleep policy doesn't work

Discussion in 'Motorola Droid X2' started by jj1123, Oct 21, 2011.

  1. jj1123

    jj1123 New Member

    Joined:
    Sep 7, 2010
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    I like to keep wifi active all the time when at home. So, I set the wifi sleep policy to NEVER (advanced wifi option) but...when the screen goes dark, my wifi immediately disconnects. I confirmed this by pinging the ip address of my Droid x2 from a computer. When the screen is lit the wifi goes active and I get a reply to the pings. When the screen goes dark after the 30 sec screen timeout, the pings no longer work, and I am no longer connected via wifi or 3g. In fact, there is no data connection at all.

    I even tried the other wifi sleep policy settings, but they don't seem to change a thing. Bottom line is when I am connected to wifi and the screen goes dark, I loose all data connectivity & loose the ability to receive gmail and Touchdown email notifications.

    Is anyone else having this issue, or is it just me? Is it an issue with my hardware or the 2.3.4 software? Can someone please try and let me know? No matter how I set the wifi sleep policy in advanced wifi options, the connection is lost as soon as my screen times out.

    On my original Droid X, it used to go back to 3g when the screen timed out when the sleep policy was set to "when screen turns off" Ony my DX2 it doesn't revert to 3g, it completly disconnects from wifi and I am left with no data connection.

    On my original Droid X is used to stay connected to wifi when the screen timed out if the sleep policy was set to "never. On my DX2, it disconnects from wifi when the screen times out, and I am left with no data connection.


    I just recevice the X2, upgraded from the Droid X. I used to have a Droid X and the "never" sleep policy option worked just perfectly. Why is it not working on the X2? I am running 2.3.4.

    Is this happening to anyone else running 2.3.4, or is it just me????
     
  2. droidx2girl

    droidx2girl New Member

    Joined:
    Oct 21, 2011
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Alabama
    Ratings:
    +0
    I have the exact same problem and would like to know if there's any way to fix it. I have also downloaded alternative apps that are supposed to control the sleep policy, and they do not work as well.
     
  3. rbreyes

    rbreyes New Member

    Joined:
    Jun 3, 2011
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Are you guys running any battery saver apps? Those things will drop connectivity when the screen locks, totally ignoring the wifi policy. Try turning your battery savers off and see that makes any difference.
     
  4. jj1123

    jj1123 New Member

    Joined:
    Sep 7, 2010
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Nope.
     
  5. JohnnytheK

    JohnnytheK Senior Member

    Joined:
    Aug 5, 2010
    Messages:
    1,448
    Likes Received:
    54
    Trophy Points:
    48
    Ratings:
    +61
    Are you sure? Sounds like you have maxium battery savings checked in settings. I did the same and checked performance mode and all the problems went away. Good luck.

    Sent from my Droid using Tapatalk
     
  6. jj1123

    jj1123 New Member

    Joined:
    Sep 7, 2010
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Very interesting. Are you running Android version 2.3.4? How are you testing? I send myself an gmail from another computer to see if the notification LED blinks when the screen is off. It doesn't blink until several seconds or min after I turn on the screen. Also, I confirmed this issue by pinging the ip address of my x2. I only get replies when I turn on the screen.
     
  7. JohnnytheK

    JohnnytheK Senior Member

    Joined:
    Aug 5, 2010
    Messages:
    1,448
    Likes Received:
    54
    Trophy Points:
    48
    Ratings:
    +61
    I was but now I'm back with Froyo.

    I tested by sending an old e-mail that had a link I wanted on my phone. It only took a few seconds.
    Of course I can't check it to verify.


    Sent from my Droid using Tapatalk
     
  8. ELH

    ELH Member

    Joined:
    Jul 13, 2011
    Messages:
    83
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0
    I'm running 2.3.4 and using Gmail and do not have this issue. I always receive Gmail notifications within seconds. I can also ping mine after the screen times out. The only time my wifi seems to sleep, based on the battery usage graph, is while I'm away from an autoconnect wifi source, but even then I still get Gmail notifications.

    Do you have the background data setting enabled?
     
    #8 ELH, Oct 22, 2011
    Last edited: Oct 22, 2011
  9. jj1123

    jj1123 New Member

    Joined:
    Sep 7, 2010
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Wow, thanks for the info. Yes, I have background data enabled. I don't know what to think at this point. I did a factory reset, checked every setting, but wifi still sleeps. Hard to believe that this is a hardware issue with the device, but I don't know what else to think...
     
  10. ELH

    ELH Member

    Joined:
    Jul 13, 2011
    Messages:
    83
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0
    Yeah, not sure what else to say, if you did a factory reset that should have put it back to square one, and I'm using default settings for the most part, don't like to wander too far off the trail...

    Only other thing I can think of is if you're using the power widget to control these settings, I've noticed that if you turn off sync it kills the underlying background data setting, but when you turn sync back on the background data setting remains off, need to actually go in and check it.
     
  11. wendee2150

    wendee2150 Member

    Joined:
    Feb 4, 2011
    Messages:
    80
    Likes Received:
    2
    Trophy Points:
    8
    Ratings:
    +2
    I have the same issue and have whined about it for 4 months (as long as I've had my phone.) I'm on the 150MB plan by choice and every time my phone locks, the wifi shuts off and I use data just turning the phone back on. It also auto updates in the night, of course because the phone is turned off, so is the wifi. :(

    Sent from my DROID X2 using DroidForums
     
  12. ELH

    ELH Member

    Joined:
    Jul 13, 2011
    Messages:
    83
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0
    Didn't think about the data plan, guess it could make a difference, if it matters I'm on the elcheapo unlimited for $29.99

    Maybe VZ is killing wifi for those who are paying by the MB?
     
    #12 ELH, Oct 24, 2011
    Last edited: Oct 24, 2011
Search tags for this page

android wifi sleep policy not working

,

droid x2 keep wifi on

,
droid x2 wifi sleep
,
droid x2 wifi sleep policy
,
how to keep wifi on droid x2
,
how to set droid x2 wifi sleep policy to never
,
maintain wifi connection android sleep
,
why does my wifi keep turning on droid x2
,
wifi sleep policy fix
,

wifi sleep policy not working