Droid X WiFi fix....working so far

Discussion in 'Motorola Droid X' started by tomnationwide, Aug 26, 2010.

DroidForums.net is the premier Android Forum - Registered Users do not see these ads. Please Register - It's Free!
  1. tomnationwide
    Offline

    tomnationwide Member

    Joined:
    Aug 12, 2010
    Messages:
    64
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0
    So I figured to mess with all settings til it worked lightning fast and just right.

    1. TKIP Cipher instead of AES.
    2. Set router to wireless G only. Using B/G or B/G/N or G/N all caused disconnects.
    3. Change Sleep Mode to NEVER.

    After completing these I tried what caused my disconnects. I went to 4 different sites. I let the phone hibernate, and I unlocked and went back in. After a couple of sites I always diconnected. After hibernate I was always screwed.

    I am working fully with WiFi right now. Upon coming out of hibernate there seems to be a lag spike between pressing a web site and it loading but only the first page. After that it was lightning fast.

    Check online to see how to change these settings on your router and how to set your phone correctly.
  2. tomnationwide
    Offline

    tomnationwide Member

    Joined:
    Aug 12, 2010
    Messages:
    64
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0

    Scrap it all I went awya for 10 minutes and came back and it's all buggered again
  3. Technoman
    Offline

    Technoman Member

    Joined:
    Dec 5, 2009
    Messages:
    980
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Dallas TX
    Ratings:
    +0

    My WIFI never disconnects... must be a phone or router related issue. it is not a Droid X defect in my experience.
  4. tomnationwide
    Offline

    tomnationwide Member

    Joined:
    Aug 12, 2010
    Messages:
    64
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0
    Success! AES instead of TKIP and it's working perfect all night since the switch INCLUDING reconnecting after a 15minute hibernate cutoff!
  5. bigdog9586
    Offline

    bigdog9586 Member

    Joined:
    Jul 21, 2010
    Messages:
    105
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    I got a new router and had problems like you do with mine not connecting and if it did would be slow and then speed up according to speed test. I updated the firmware and messed with the different setting but nothing really seemed to help much until why I don't know I decided to pull the battery in the DX for a minute and then all my problems went away. Its been a couple weeks now and all is well and I didn't have to change the router from auto which uses a,b,g, and n.
  6. tomnationwide
    Offline

    tomnationwide Member

    Joined:
    Aug 12, 2010
    Messages:
    64
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0

    success it's worked like a charm since I switched to AES.
  7. avt123
    Offline

    avt123 Member

    Joined:
    Jan 28, 2010
    Messages:
    278
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    How do I know if I am connected to wireless N? Currently my link speed is 65Mbps. If I am correct, I believe that is in the N range, but can it go higher?
  8. tomnationwide
    Offline

    tomnationwide Member

    Joined:
    Aug 12, 2010
    Messages:
    64
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0
    The phone chooses the highest connection by default. If you want to try G or B then go into the router with the ip 192.168.0.1 or whatever your default router IP is and find your private network setting and change it to 802.11g or even b to try them out but many routers are ste to g/n at the same time so enable only b and see if it helps.
  9. avt123
    Offline

    avt123 Member

    Joined:
    Jan 28, 2010
    Messages:
    278
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    Oh I'm not having any problems though. I was just wondering if I was currently connected to N speeds, which I think I am. Thanks for the info though.
  10. tomnationwide
    Offline

    tomnationwide Member

    Joined:
    Aug 12, 2010
    Messages:
    64
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0
    To answer, max G speed is 54mbps so yes, you are using N.
  11. phatkat66
    Offline

    phatkat66 Member

    Joined:
    Nov 15, 2009
    Messages:
    521
    Likes Received:
    2
    Trophy Points:
    18
    Ratings:
    +2
    How do you switch to aes? I connected to my jobs wireless and when trying to connect from a diff phone it kept disconnecting so I erased the connection on my droid X just to see if it was the other phone now it wont connect back it just disconnects after authenticating all the time.
  12. Section Twelve
    Offline

    Section Twelve Member

    Joined:
    Aug 7, 2010
    Messages:
    311
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Right behind you...
    Ratings:
    +0
    All of these connection issues sound like router problems. Which routers are you guys all using?

    I'm running a Netgear WNDR3700 and I never lose wifi with my X. I am running WPA2 with AES/TKIP mix.
  13. Dr.Dad
    Offline

    Dr.Dad Member

    Joined:
    Aug 5, 2010
    Messages:
    230
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    I have netgear 2200 or something like that and I have tried all sorts of settings. Finally, I gave up and put my router back to AES + TPIK (WPA/WPA2) at 165 mbps which was what I had it on from the start.....
    then all of a sudden my phone's wifi started working w/o issue!
    BUT I couldn't help myself, and I updated to 2.2..... then it stopped working again. I have messed with all of the router settings, right now I'm on TPIK (which on the net seems to be the consensus fix and not AES) and it works some days and not some other days.

    maybe it is the router, bc after I switched from TPIK + AES to just TPIK my computer has not worked as well, internet cutting in and out.....

    but I ALWAYS blame the router, so maybe it's the phone this time.....
    i give up, and will just run on 3G and check internet once a week or so to see if "something" has fixed itself...
  14. Section Twelve
    Offline

    Section Twelve Member

    Joined:
    Aug 7, 2010
    Messages:
    311
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Right behind you...
    Ratings:
    +0
    On the DGN2200, you should go into the QoS settings in the router and disable WMM unless you REALLY need it or use it. If you do not know what it is or does, then you are more than likely not using it.

    Give that a try. If it helps, that's great. If not... we can brainstorm some more.
  15. Dr.Dad
    Offline

    Dr.Dad Member

    Joined:
    Aug 5, 2010
    Messages:
    230
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    Thanks...I'll give it a try. I don't know what it was doing, so I guess I wasn't using it!

    Hey, if it REALLY works, then maybe I can change my encryption back to TKIP + AES and fix whatever was going on with my computer.
    A boy can dream!
Search tags for this page
droid x fix wifi problems
,

droid x wifi fix

,
droid x wifi problem fix
,
how to fix droid x droped wifi