Droid X doesn't notify me of email

Discussion in 'Droid X Tech Support' started by np89123, Jul 17, 2010.

  1. np89123
    Offline

    np89123 New Member

    Joined:
    Jul 17, 2010
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    I have set up my college email using corporate mail on droid and it has synced perfectly and can send and receive emails BUT when I receive an email it will very rarely notify me if the screen is off. I have to physically hit refresh or turn the screen on before it will tell me I have received anything.

    This problem is fixed if I use IMAP instead of activesync but if I use IMAP I am unable to send any emails and just get the error: "Sending email error"

    Push is turned on but it is pretty much useless since I have to prompt it somehow to check for email.
     
  2. labphoto
    Offline

    labphoto Member

    Joined:
    Feb 28, 2010
    Messages:
    31
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Hotter than the Sun
    Ratings:
    +0
    If you go over to the Motorola forums, you will see this is somewhat of a widespread problem. Hopefully Motorola updates this soon.
     
  3. np89123
    Offline

    np89123 New Member

    Joined:
    Jul 17, 2010
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Yes but my phone won't even CHECK for email until I prompt it to, everyone elses just won't notify them.
     
  4. wlfpckgrl1
    Offline

    wlfpckgrl1 New Member

    Joined:
    Jul 18, 2010
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Are you sure this is on? Not to insult you, but I thought mine was on too.....I feel really dumb....

    Home--->Settings--->Data Manager--->Data Delivery--->Email and Corporate Sync--->Email Delivery--->Make sure "Data Push" is checked.

    Hope this helps.
     
  5. Inkog
    Offline

    Inkog New Member

    Joined:
    Jul 16, 2010
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Double check your battery smart mode options. It turns off data at night.

    settings -> battery manager -> Battery Profile Options-> Start & End times & Data Timeout.
     
  6. Mule65
    Offline

    Mule65 Member

    Joined:
    Apr 7, 2010
    Messages:
    430
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    I have notification issues too...

    Corp Sync (push): No notification; No blinking light
    Yahoo: Yes notification; No blinking light
    Google: Yes notification; Yes blinking light
    Text Message: Yes notification; Yes blinking light
     
  7. Mule65
    Offline

    Mule65 Member

    Joined:
    Apr 7, 2010
    Messages:
    430
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
  8. tam5070
    Offline

    tam5070 Member

    Joined:
    Jul 16, 2010
    Messages:
    53
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    State College, PA
    Ratings:
    +0
  9. Mule65
    Offline

    Mule65 Member

    Joined:
    Apr 7, 2010
    Messages:
    430
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    Got ota update and it seems to have fixed this issue!

    Edit: well, it worked once.
     
    Last edited: Jul 20, 2010
  10. JFDroid
    Offline

    JFDroid Member

    Joined:
    Oct 31, 2009
    Messages:
    226
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Ohio
    Ratings:
    +0
    I have the .604 update and I don't get notifications for corporate e-mail. In fact, it won't even check for corporate e-mail unless I manually click "refresh" within the application. Grr.
     
  11. lonestarcook
    Offline

    lonestarcook New Member

    Joined:
    Nov 17, 2010
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Your Corporate Email Won't Sync?

    All,

    I just purchased the X a few weeks ago. Switching over from Blackberry Storm. I have a GMail account (which had been notifying me of every email as soon as it hit my inbox). However, my corporate email (GMail based), wouldn't sync at all. I receive 30-50 emails a day, so this was a huge letdown for me. Almost thought about returning the phone because I have to have my emails.

    Here's how I corrected the problem, which I think most of you all are experiencing:


    Under the settings page, I scrolled down to battery manager. Clicked on Battery Mode and switched from Nighttime Battery Saver to Performance Mode.


    YOU HAVE TO REBOOT YOUR PHONE MANUALLY FOR THE NEW SETTINGS TO TAKE PLACE! After the reboot (I just removed the battery), emails are flowing in immediately now with an audible notification.


    Hope this helps everyone.
     
  12. droidXaddiction
    Offline

    droidXaddiction New Member

    Joined:
    Jan 5, 2011
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Gmail refresh issue

    Had the same problem, put the Android Power Management widget on your home screen and click to enable the Sync (two arrows). done.

     
  13. benelj89
    Offline

    benelj89 New Member

    Joined:
    Jan 19, 2011
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Droid X Stopped Notifiying me of emails

    I set up corporate email through my company and it worked fine for awhile. I got the phone in December and of course installed/unistalled lots of apps, especially ones for the system (battery widgets, RAM indicators, Task Killers). The way I fixed this issue was to start over. I factory wiped the phone and the SD card. Then I just installed the apps I really thought I would need, which for me wasn't too many. I suspect that my issue was with either a task killer or the LauncherPro I had installed. So far its been a few weeks now and it works really well. The phone doesn't look as cool as it did when I had LauncherPro, but i would rather it work than have a good looking POS.
     
  14. SpectrumBand
    Offline

    SpectrumBand New Member

    Joined:
    Jan 22, 2011
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Two similar topics for this thread:

    1) e-mail sync between Droid X and a POP3 server
    2) Deleting e-mail on the server via the phone

    Done a lot of reading and made some changes but still doesn't sync without me opening the mail app and doing a "refresh" to initiate a manual sync. Had a Blackberry Storm that worked great with my Earthlink POP3 account. Willing to pay for an app if it would solve this problem but hoping there's a simple fix. So far I've:

    Enabled the data push in the mail app
    Set the fetch schedule to 15 minutes (wish there was a shorter interval)
    Set the power to the "Performance Mode"

    I've had the phone for two days and I think it used to work and can't think of anything I've done to interrupt the sync operation.

    Any advice greatly appreciated before I trade this for another Blackberry. Really like this phone but e-mail is a deal killer for me since I use it as a tool rather than a toy.

    Also, my BB would allow me to delete mail from the phone in two modes:

    1) Delete from phone only
    2) Delete from phone and the POP3 server

    The Droid will only delete from the phone as far as I can tell. I liked the capability of deleting mail from the server since I would delete spam via the phone so that when I get home and download to PC via Outlook 2010 I don't have to deal with the spam. Any suggestions on that topic?

    Thanks in advance.
     
  15. ryan8720
    Offline

    ryan8720 New Member

    Joined:
    Feb 26, 2011
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    I had the same problem on my Droid X. My GMail was notifying just fine, but my corporate exchange account was not at all.

    Being inspired by benelj89's post, I uninstalled "Startup Auditor Free" and manually restarted the phone (hold the the power button and select Power Down, wait, then hold the power button until the M logo appears). Now it is syncing just fine, even using Nighttime Saver or a Custom batter saver. Also note that I have Advanced Task Killer installed and it doesn't interfere.
     
Search tags for this page
android phone won't notify me when i recive email
,
droid razor x will not refresh email
,
droid x alert when new email
,
droid x automatic email sync
,

droid x email notifications

,
droid x email won't update
,
droid x push email
,
droid x wont sync email
,
email notification droid x
,
why doesnt my droid phone alert me when i have an email