Droid wont turn on at all! Helpp

Discussion in 'Android General Discussions' started by tu3218, Oct 4, 2010.

  1. tu3218

    tu3218 Active Member

    Joined:
    Nov 17, 2009
    Messages:
    1,217
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    Baltimore, Maryland
    Ratings:
    +0
    So updated to the recent update of launcherpro and when I hit home my phone force closed and I could not go into a home screen. I then tried resetting my phone an the boot animation just kept going, and going. I took the battery out and tried to boot my phone an it wont even start. Please help anyone!! Is my phone done?
     
  2. everstar80

    everstar80 Member

    Joined:
    Aug 19, 2010
    Messages:
    356
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    the light of the moon
    Ratings:
    +0
    Im no expert, but it may be bricked. Corinacakes, tparker76, and hookbill know the steps to help you if that is the case. On their post they have links on how to fix things like this.
     
  3. cupfulloflol

    cupfulloflol Senior Member

    Joined:
    Dec 5, 2009
    Messages:
    1,898
    Likes Received:
    22
    Trophy Points:
    68
    Ratings:
    +23
    Battery charged? Plug it into a wall charger for a while (few hours).

    Are you rooted? Running a custom kernel?
     
  4. Abe21599

    Abe21599 DF Super Moderator Rescue Squad

    Joined:
    Dec 22, 2009
    Messages:
    6,334
    Likes Received:
    30
    Trophy Points:
    163
    Location:
    Ohio
    Ratings:
    +30
    yes were you rooted or anything? low battery might be the problem, also.

    more info on ur phone is needed.
     
  5. Tallica

    Tallica Premium Member Rescue Squad Premium Member

    Joined:
    Mar 17, 2010
    Messages:
    3,259
    Likes Received:
    1
    Trophy Points:
    101
    Location:
    Middleboro, MA
    Ratings:
    +1
    It's far from bricked, sounds like low battery to me. Put it on the wall charger for a couple hours

    Sent from a long time ago, in a galaxy far, far away
     
  6. tu3218

    tu3218 Active Member

    Joined:
    Nov 17, 2009
    Messages:
    1,217
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    Baltimore, Maryland
    Ratings:
    +0
    Okay I just took the battery out again and it started back up again. I was very worried so I just wanted to get the post up for any suggestions, reason being for lack of info lol. But yeah I have no idea why this happened. I had 60% battery left, rooted running UD8.0.
     
  7. Tallica

    Tallica Premium Member Rescue Squad Premium Member

    Joined:
    Mar 17, 2010
    Messages:
    3,259
    Likes Received:
    1
    Trophy Points:
    101
    Location:
    Middleboro, MA
    Ratings:
    +1
    Glad you got it working