Droid line of phones act weird on charger

Discussion in 'Droid 2 Tech Issues' started by Big Ry, Feb 23, 2011.

  1. Big Ry

    Big Ry Active Member

    Joined:
    Feb 4, 2010
    Messages:
    1,299
    Likes Received:
    10
    Trophy Points:
    38
    Location:
    Blacksburg, VA
    Ratings:
    +10
    Ive been meaning to ask you guys about this for quite some time...

    Sorry if this is old news too...why do these devices act differently when on the charger? I've owned 5 D1's and 1 D2. Every single one of them acts strange when charging. By strange, I mean the touch screen response goes haywire. The device seems to treat scrolling (swiping of the screen) like a one touch click. If I scroll through a webpage, it'll click on something on the page instead...such as a link. This gets VERY VERY annoying very quickly. Now, this issue is much MUCH more prevalent when the device is on the home dock, but its still noticeable on a standard charger nonetheless. On top of the myriad of devices I've owned, I also own 3 home chargers, one car charger, and only one home dock. All of these are VZW branded too. The issue has happened on every device I've owned using every charger I own. That said, it seems virtually impossible that this issue is NOT a global issue/glitch that affects all or most Droid branded moto phones...hence the thread title. Now before you refute my claims, please go spend at least 5 minutes with your D1 or D2 while its on the charger. And if you own a home dock, use that.

    Am I wrong here? Is this a known issue? Is it a moto issue, android issue? I'd love to figure out what's going on here. All input is appreciated. Thanks. :D

    Sent from my DROID2 using Tapatalk
     
  2. nemisis9

    nemisis9 Member

    Joined:
    Dec 4, 2010
    Messages:
    130
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    Don't know if its amy help to u but mine does just fine on and off the charger.

    Sent from my DROID2
     
  3. SethBiggs

    SethBiggs New Member

    Joined:
    Nov 24, 2010
    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Ohio
    Ratings:
    +0
    I've noticed that on my D2 a well. Doesn't matter what charger it just seems to go haywire sometimes. And then others it seems fine. Mine likes to zoom the page when I'm trying to scroll. Very annoying

    Sent from my DROID2 using DroidForums App
     
  4. LocoRon

    LocoRon Member

    Joined:
    Jan 7, 2011
    Messages:
    135
    Likes Received:
    3
    Trophy Points:
    18
    Ratings:
    +3
    Yeah, I had this when I got my D2, it was really annoying!

    I think someone said something about it being a grounding issue. And, indeed, when I plugged the charger into either a grounded power strip or into my USB hub (which draws power from that grounded power strip), it is fine.

    I haven't had this issue in ages now. I'm not sure if that's because of the current power plug set-up (it's not grounded though....), because I'm running a custom ROM (Liberty!), or because it's in the multimedia dock (I can't remember if I ever had this issue while it was docked or not, although I think I did... just not sure).

    Anyway, hope you can find some way of fixing it, because I know that when it was happening to me, it made the phone literally unusable. :/
     
  5. pool_shark

    pool_shark Active Member

    Joined:
    Mar 28, 2010
    Messages:
    1,395
    Likes Received:
    7
    Trophy Points:
    38
    Location:
    Ohio
    Ratings:
    +7
    For me it does depend on the charger.
    Using my USB cables, the car charger, and the charger at my GF's house (also USB but connected to the wall) everything is fine, but when using the regular wall charger, the screen registers differently.
     
  6. Ignot

    Ignot New Member

    Joined:
    Feb 24, 2011
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    I had the same issue with my D1. It turned out to be the charger passing the 60Hz noise to the phone. The original charger worked fine, but I wanted a longer cord so I bought a new charger and had the problem you are describing. I then tried several other brands, and found that the I-go charger (Radio Shack) worked fine.
     
  7. Big Ry

    Big Ry Active Member

    Joined:
    Feb 4, 2010
    Messages:
    1,299
    Likes Received:
    10
    Trophy Points:
    38
    Location:
    Blacksburg, VA
    Ratings:
    +10
    Well its good to know I'm not the only one with the issue. But its ridiculous that this has happened to me on all 6 devices on several different chargers.
     
  8. Dr. Phil

    Dr. Phil New Member

    Joined:
    Feb 28, 2011
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    My D2 does this as well, very annoying. Seems to happen less with the usb-wall charger adapter that came with the phone, and more with the wall charger that I had from my old blackberry. Either way it's intermittent...My solution has been to just let it be while it's charging.
     
  9. Big Ry

    Big Ry Active Member

    Joined:
    Feb 4, 2010
    Messages:
    1,299
    Likes Received:
    10
    Trophy Points:
    38
    Location:
    Blacksburg, VA
    Ratings:
    +10
    I typically do, but when I really need to use it its very annoying

    Sent from my DROID2 using Tapatalk
     
  10. Dr. Phil

    Dr. Phil New Member

    Joined:
    Feb 28, 2011
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Oh don't get me wrong, I hate it when I'm trying to set my alarm before bed or on the occasion I charge during the day. I guess the real solution is to stay away from certain brand chargers?

    Sent from my DROID2 using DroidForums App
     
  11. Big Ry

    Big Ry Active Member

    Joined:
    Feb 4, 2010
    Messages:
    1,299
    Likes Received:
    10
    Trophy Points:
    38
    Location:
    Blacksburg, VA
    Ratings:
    +10
    Mine are all VZW moto droid 2 chargers :/


    Sent from my DROID2 using Tapatalk
     
  12. Dr. Phil

    Dr. Phil New Member

    Joined:
    Feb 28, 2011
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0


    Sent from my DROID2 using DroidForums App
     
  13. sir2545

    sir2545 Member

    Joined:
    Nov 24, 2009
    Messages:
    249
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Charlotte, NC
    Ratings:
    +0
    Guys I dont think it's the chargers. It's something to do with the different ROMs. I have had Liquid Gingerbread, Project Elite and the stock FRG83G installed and it hasn't been an issue. But I just installed Cyanogenmod and now when it's charging it goes haywire. I'm thinking it has something to do with the voltage settings for the kernel maybe screwing it up. What ROMs are you guys running? I have a D1 BTW.

    Update: Installed Pete's 1Ghz LV kernel and no longer having issues so it must be an issue with voltages of the kernel
     
    Last edited: Mar 2, 2011
  14. ordinaryjoe4life

    ordinaryjoe4life New Member

    Joined:
    Mar 1, 2011
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    BKLYN, NY
    Ratings:
    +0
    I have that prob when I plug into my pc
     
  15. 252chevyboyz

    252chevyboyz Silver Member

    Joined:
    Nov 2, 2010
    Messages:
    2,036
    Likes Received:
    8
    Trophy Points:
    103
    Location:
    North Carolina
    Ratings:
    +8
    Hello Big Ry, Ich bin James. See you got some german in under your name "Droid zwei". My German skills are kinda rusty haha but i remember a lil bit.

    Anyways back to the chargers. I think it also could be a specific rom and how it plays with your phone. Maybe something in the build of the rom? or maybe if you have a custom kernal then maybe it could be how that kernal regulates power to certain parts of the phone? I use liberty v1.5 and the only is i dont have a charging light by my charging port on my D2 but thats no big deal. Kinda wish i could just toggle the charging light but i dont really miss it. I dont think it would be the charger unless it didnt supply enough power or supplied too much power and its making the system run wierd. I use my old Storm 1 charger and i dont have any problems with that. Also charge it by the comp usb, moto wall charger, and griffin wall charger. No problems yet (knock on wood) but i hope this issue gets worked out.

    Btw my normal profile is ULV 1.3ghz max and 400mhz min. If that makes a difference
     
Search tags for this page
can a charger make your phone glitch
,
charger makes phone glitch
,
my phone acts yp when the charger is in
,
phone acts up with certain chargers
,

phone acts weird when charging droid

,
screen act weird when connect to original charger
,
what is the strangest charge it while on
,
when i use my charger my phone acts glitchy
,

why do certain chargers make my phone act funny

,
why does my phone act glitchy with certain chargers