Droid changing caller id "from" number

Discussion in 'Android Tech Support' started by williamherbert, May 23, 2010.

  1. williamherbert
    Offline

    williamherbert New Member

    Joined:
    May 23, 2010
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    0
    Hi guys, I searched the forums but couldn't find this situation so if there is one existing, just drop the link to the thread in there for me.

    I had a contact in my phone at one point where i put "*67," before the number to block it on caller id. (Not stalking anyone, I swear!) So on the original contact, i had the phone number listed as "*67,xxx-xxx-xxxx."

    So I got a text message from the person whose number I had with the *67 in front of it, and when i tried to send a msg using my contact list, it put the *67 in front of the phone number, and therefore could not send the message.

    So ... I removed the *67 from the contact phone number and tried send it again. But when the "To:" number came up, it still had the *67 in the message. So I deleted the contact altogether and re-entered everything without the *67. It still is auto-entering the *67 in the number.

    So I completely removed the contact altogether and asked the person to call me so I could store the "From" number. When I tried to add the number to contacts, it came through with the *67 attached (which it would never come through with that attached).

    So the only way i can send a message is to manually enter the direct phone number every time i want to send a text. (The only way around this is to keep the thread open all the time, in which case it saves the manual info. But If I exit out of the thread and go back in, it has that [censored] *67 right back in there.)

    I have deleted all previous contacts for this person, but even now when I get a txt, it has the *67 in front of it. It's very strange. Anyone seen a similar situation? How can I get rid of it? Thanks!
  2. Shadez
    Offline

    Shadez Super Mod/News Team Staff Member Premium Member

    Joined:
    Jan 27, 2010
    Messages:
    8,456
    Likes Received:
    203
    Trophy Points:
    63
    Location:
    Lafayette Hill, Pa
    I think your phones haunted...

    bump
  3. darksiiide
    Offline

    darksiiide New Member

    Joined:
    Apr 29, 2010
    Messages:
    101
    Likes Received:
    0
    Trophy Points:
    0
    Remove the contact, and resync your gmail account. Its restoring the contact information from the cloud. I had this same issue before.

    Sent from my Droid using Tapatalk
  4. Vulcan1600
    Offline

    Vulcan1600 DF Super Moderator Staff Member Premium Member

    Joined:
    Nov 20, 2009
    Messages:
    5,710
    Likes Received:
    151
    Trophy Points:
    63
    Location:
    Pennsylvania
    Exactly what I was thinking, once it's deleted from the Droid, it's resynching with the Gmail contact.
  5. williamherbert
    Offline

    williamherbert New Member

    Joined:
    May 23, 2010
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    0
    I did try this and it still doesn't seem to work.

    I deleted the contact, and then I went into CONTACTS>ACCOUNTS>and tried to re-sync everything, and it's still coming up with the *67 number.

    Am I missing a step? Thanks again.

    EDIT: I should also mention that I entered the contact manually and didn't get it from Gmail or Twitter or Facebook. Don't know if that makes a difference or not. How do I get it "out of the cloud" so to speak so I can reset it as if it never existed in the first place and enter it from scratch? Gratsi.
    Last edited: May 23, 2010
  6. Bob Dammit
    Offline

    Bob Dammit DF Super Moderator

    Joined:
    Dec 11, 2009
    Messages:
    1,715
    Likes Received:
    17
    Trophy Points:
    0
    Location:
    N 42° 05.183 W 079° 10.914
    Delete the contact from your phone again. Log in to your gmail account, from your computer. Click contacts on the left side of the page. Find your "stalk-ee", err "friend's" name in your contacts. Click their name, then click edit. Change the number in your google account, click save, THEN resync.
  7. williamherbert
    Offline

    williamherbert New Member

    Joined:
    May 23, 2010
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    0
    Very strange. I tried all these steps (removing the contact from the phone, then removing and re-entering the contact info via Gmail, then re-syncing) and it's still showing that *67. I'm starting to wonder if the "it's haunted" theory isn't holding some weight. Even when I'm manually re-entering the email/phone number through Gmail, it keeps reverting when I put it into txt msg mode.

    (The infuriating thing to me is that it's actually DIALING without the *67, but still setting up text msgs WITH the *67: worst of both worlds.)

    Could it also have to do with the fact that I have the person as a contact via both Facebook and Twitter also? Could it be drawing the contact info in from one of those sources?

    I just did a manual "test" text message by entering the number manually and sending it. It worked and went through, but when I exited the txt msg thread and went back out of it to go to "all threads," it's showing up with the *67 number yet again ... and that was with a manual entry.

    Keep em comin' if you got em. I'm willing to try anything. Thanks.
  8. titans
    Offline

    titans Premium Member Rescue Squad Premium Member

    Joined:
    Dec 3, 2009
    Messages:
    2,664
    Likes Received:
    0
    Trophy Points:
    0
    You may want to wait to see if someone can suggest an easier method, but the most potent way method that could possibly fix this is an RSD Lite flash of the 2.0.1 sbf. Since you resynced, etc. I'm not so certain its a problem with Google. Be aware that if you do choose to flash the sbf, you will have to reactivate your phone by dialing *228, so make sure you are in an area with decent reception (also you want to call Verizon to make sure they aren't upgrading their system at the time you want to flash the sbf, otherwise you won't be able to activate). Along with having to reactivate, you will have to redownload all your apps, the phone will be just like it did when it first came out of the box. As long as you are in an area with decent reception when Verizon is upgrading the server, you should have no problem flashing the sbf and getting your phone to working order within ~20 min. I have flashed the sbf multiple times (I rooted/edit framework on my phone and messed it up) and have had no trouble. You can find the directions and downloads for the flashing of the sbf here http://www.droidforums.net/forum/hacking-faqs/39254-sbf-root-unroot.html
  9. Explosivpotato
    Offline

    Explosivpotato New Member

    Joined:
    Apr 22, 2010
    Messages:
    102
    Likes Received:
    0
    Trophy Points:
    0
    I have a feeling a factory reset would work, without the use and hassle of rsdlite.

    Just sayin.

    Sent from my Droid using Tapatalk
  10. titans
    Offline

    titans Premium Member Rescue Squad Premium Member

    Joined:
    Dec 3, 2009
    Messages:
    2,664
    Likes Received:
    0
    Trophy Points:
    0
    Very possible.
  11. williamherbert
    Offline

    williamherbert New Member

    Joined:
    May 23, 2010
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    0
    I know that this is several months old but I wanted to follow up on it.

    This issue was fixed when my Droid did its periodical purge of text messages (ie. erased all my threads). After that, the messages that had come through from the *86 number were coming through with the correct number (no *86) and it has been working fine ever since.

    A few things:

    1) I did go into my Gmail and create a new contact for the person in question, and though it did not work right away, it may have been needed for this change to happen.

    2) I'm not sure if manually deleting all threads would have worked for this, or if i had to be purged automatically. I would definitely try purging all messages manually first.

    Thanks for everyone's help.

    - Bill
Search tags for this page

android doesnt delete *67number

,

droid app to change caller id

,

droid change caller id

,

hide your mobile number for android

,

how to change the caller id on a droid

,

i send a text message the number has *67 in front of it