Solved Disable screen overlay?

Discussion in 'Droid Moto Z Force' started by k1ngr4t, Sep 26, 2016.

  1. k1ngr4t

    k1ngr4t Senior Member

    Joined:
    May 28, 2011
    Messages:
    1,487
    Likes Received:
    112
    Trophy Points:
    63
    Ratings:
    +114
    Current Phone Model:
    Z Force
    So I recently got my Force, and as I'm going through setting things up, I've gotten the message asking to allow or deny Google permission for the location, and occasionally when I hit allow it says I need to go to settings and disable screen overlay...but for every app it's said this, that app isn't actually listed anywhere in the list of apps with a screen overlay?

    For instance I tried making a new appointment with my calendar. I could enter in the date/time fine, but when I tried to enter the description, this message came up. So I tap the link it gives me to 'Settings,' but no sort of calendar anything is in there.

    Any ideas?
     
  2. Jonny Kansas

    Jonny Kansas Administrator
    Staff Member Rescue Squad

    Joined:
    Jan 21, 2010
    Messages:
    16,470
    Likes Received:
    7,049
    Trophy Points:
    1,278
    Location:
    Michigan's Upper Peninsula
    Ratings:
    +8,391
    Current Phone Model:
    Pixel XL
    Twitter:
    jonny_ks
    It's a weird bug that I've seen a few times on my Z & my wife's S7. I'm not sure what causes it.

    When Google Duo came out, we wanted to try it, but she was getting that message on her S7.

    After Allo came out, she decided to try Duo again & it didn't give her the Screen Overlay issue.

    I know that doesn't help you much, but at least you can know that you're not alone.

    Sent from my Moto Z
     
    • Like Like x 2
  3. k1ngr4t

    k1ngr4t Senior Member

    Joined:
    May 28, 2011
    Messages:
    1,487
    Likes Received:
    112
    Trophy Points:
    63
    Ratings:
    +114
    Current Phone Model:
    Z Force
    Actually it helps knowing I'm not alone! That's exactly the same as my case...there doesn't seem to be much rhyme or reason. I'll try it again later and it'll work fine, then another app does it.
     
    • Like Like x 2
  4. Jonny Kansas

    Jonny Kansas Administrator
    Staff Member Rescue Squad

    Joined:
    Jan 21, 2010
    Messages:
    16,470
    Likes Received:
    7,049
    Trophy Points:
    1,278
    Location:
    Michigan's Upper Peninsula
    Ratings:
    +8,391
    Current Phone Model:
    Pixel XL
    Twitter:
    jonny_ks
    Idk if it's a Google Play Services issue or an app by app thing, but your definitely not alone.

    I've seen others on the forum come across the same issue as well.

    Sent from my Moto Z
     
    • Like Like x 1
  5. omar908

    omar908 Member

    Joined:
    Jan 2, 2012
    Messages:
    115
    Likes Received:
    7
    Trophy Points:
    18
    Ratings:
    +7
    I had a similar experience as you are having. It continuously asked me to turn off the overlay of the app even if the app was just installed. Turns out it was another app that was causing the issue and they wanted it to be turned off. In my case I use "Nightly" which is an app that darkens the screen brightness for when used at night, when it was on the message kept coming back until I turned it off, only then would the message not come up.

    Sent from my VS986 using DroidForums
     
    • Like Like x 2
  6. rocknroller77

    rocknroller77 New Member

    Joined:
    Jun 3, 2010
    Messages:
    6
    Likes Received:
    2
    Trophy Points:
    3
    Ratings:
    +2
    Just had this problem... It was an app.

    For me it was an app that created a fake "edge" feature.

    Deleted

    Sent from my XT1650 using Tapatalk
     
    • Like Like x 2
  7. TisMyDroid

    TisMyDroid Super Moderator
    Staff Member

    Joined:
    Feb 16, 2011
    Messages:
    7,279
    Likes Received:
    3,011
    Trophy Points:
    578
    Location:
    Central New York
    Ratings:
    +3,307
    Current Phone Model:
    Samsung Note 3
    I went through the same exact thing. I could barely do anything because I kept getting that stupid screen overlay pop-up. Drove me crazy! Finally discovered the problem.

    What it is: an app that has an overlay (can sit on top of your screen or on top of other apps) that is interfering with you being able to allow permissions of all other apps.

    How to solve the problem: when you get to the overlay settings turn off any apps that have an overlay. I did one app at a time so I could discover which app was causing the problem. Once you have turned off the overlay of the app that is causing the problem, you will be able to change the settings (allow permissions) of the app you're trying to work in. You can then go back to turn the overlay back on.

    Sent from my SM-N920V using Tapatalk
     
    • Like Like x 3
    • Agree Agree x 1
  8. FoxKat

    FoxKat Premium Member
    Premium Member

    Joined:
    Apr 2, 2010
    Messages:
    14,806
    Likes Received:
    4,751
    Trophy Points:
    838
    Location:
    Pennsylvania
    Ratings:
    +5,290
    Current Phone Model:
    Droid Turbo 2 & Galaxy S7
    Excellent support, @TisMyDroid !
     
    • Like Like x 1
  9. k1ngr4t

    k1ngr4t Senior Member

    Joined:
    May 28, 2011
    Messages:
    1,487
    Likes Received:
    112
    Trophy Points:
    63
    Ratings:
    +114
    Current Phone Model:
    Z Force
    Sorry for the delayed response, but I'll just confirm that it was indeed an app! Honestly I have no idea which one, I just went through my list and deleted maybe 10-15 apps I thought could be a culprit...sure enough it hasn't happened since. Wish I could say which one specifically, or maybe it was multiple...but app cleanup did indeed help, thanks so much everyone!
     
    • Like Like x 1
  10. mountainbikermark

    mountainbikermark Super Moderator
    Staff Member Premium Member

    Joined:
    Sep 5, 2010
    Messages:
    7,455
    Likes Received:
    3,886
    Trophy Points:
    1,563
    Ratings:
    +4,348
    mine was Systemglow. Many apps I install "go there". I just follow the taps, scroll to turn it off, tap back, turn Systemglow back on when done.

    Support Our Troops!!!
    Beast Mode 4

    <><
     
    • Like Like x 1
  11. TisMyDroid

    TisMyDroid Super Moderator
    Staff Member

    Joined:
    Feb 16, 2011
    Messages:
    7,279
    Likes Received:
    3,011
    Trophy Points:
    578
    Location:
    Central New York
    Ratings:
    +3,307
    Current Phone Model:
    Samsung Note 3
    Mine was start. It's rather a pita, but I do the same; turn off screen overlay for the start app then turn it back on when done.

    Sent from my SM-N920V using Tapatalk
     
  12. mountainbikermark

    mountainbikermark Super Moderator
    Staff Member Premium Member

    Joined:
    Sep 5, 2010
    Messages:
    7,455
    Likes Received:
    3,886
    Trophy Points:
    1,563
    Ratings:
    +4,348
    It is a little faster than tapping accept permissions every time an app updates in the Play Store though for those like me that update them manually. 1 bugger of a thing than multiples. Blame it on the Russians, the Chinese, Taliban, nefarious developers, whoever is responsible for the need for better security on our devices. It's the new norm.

    Support Our Troops!!!
    Beast Mode 4

    <><
     
    • Like Like x 2
Search tags for this page

disable screen overlay android

,

droid turbo 2 screen overlay

,
droid turbo overlay message
,

droid turbo screen overlay

,

moto x2 screen overlay setting

,
moto z force droid screen overlay
,
moto z screen overlay
,

screen overlay moto z force

,

turn off screen overlay droid turbo 2

,
turn off screen overlay on moto droid paly