"Device not compatible" errors in Marketplace

Discussion in 'Liberty ROM DX' started by DMFA, Nov 21, 2011.

  1. DMFA

    DMFA Member

    Joined:
    Aug 6, 2010
    Messages:
    102
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    I've started having this problem, most notably with Netflix, which is trying to force me to update. However, I get a "your device is not compatible with this item" error when I try to download it. Odd, I know, especially when ROM Toolbox gives me the same error. What's going on here?

    DX .605 with Liberty 3 v1.0

    Sent from my DROIDX using DroidForums
     
  2. smiller7117

    smiller7117 Member

    Joined:
    Oct 25, 2011
    Messages:
    35
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0
    I got the same problem. Don't understand. Wish we could figure it out or get answers from someone out there. *Hint hint
     
  3. Nemo Aeternamn

    Nemo Aeternamn Droid X Rescue Squad
    Rescue Squad Premium Member

    Joined:
    Sep 10, 2011
    Messages:
    793
    Likes Received:
    13
    Trophy Points:
    18
    Location:
    Mo-ab
    Ratings:
    +13
    you didn't by chance change your screen density.... did you???
     
  4. smiller7117

    smiller7117 Member

    Joined:
    Oct 25, 2011
    Messages:
    35
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0
    Ya know, I thought that may have something to do with it. I did change it. But then, thinking it may affect it, I changed it back. No improvement though.
     
  5. aj8600

    aj8600 Member

    Joined:
    Aug 7, 2010
    Messages:
    263
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    This happened to me. I cleared all of the data in market and google services framework in the settings. That seemed to fix it

    Sent from my CushZero using DroidForums
     
  6. DMFA

    DMFA Member

    Joined:
    Aug 6, 2010
    Messages:
    102
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    Yeah, I really prefer it at 192. I didn't know that had any being on it.

    Didn't work for me. Too bad.
     
  7. tslovejoy1969

    tslovejoy1969 New Member

    Joined:
    Feb 17, 2011
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Just to be clear, you will need to change your screen density back to 240, then possibly clear market data (and maybe even reboot), then run the market app again. I generally find that just setting the density back to 240 fixes it, without the need to clear data or reboot, but others seem to need to do all of these steps.

    -TSL
     
  8. DroidXJoel

    DroidXJoel Member

    Joined:
    Nov 15, 2010
    Messages:
    137
    Likes Received:
    1
    Trophy Points:
    18
    Ratings:
    +1
    Where do I go to change screen density?

    Sent from my [P]URIFIED DROID BIONIC
     
  9. DroidXJoel

    DroidXJoel Member

    Joined:
    Nov 15, 2010
    Messages:
    137
    Likes Received:
    1
    Trophy Points:
    18
    Ratings:
    +1
    Nvm

    Sent from my [P]URIFIED DROID BIONIC
     
  10. DMFA

    DMFA Member

    Joined:
    Aug 6, 2010
    Messages:
    102
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    Yeah, the switch back to 240 and then re-checking the marketplace worked great. That must be a recent change with the marketplace because I never remembered LCD density being an obstacle to updating or installing applications, and I've had it at 192 for over a year...

    Any hacks/patches available to circumvent the issue?

    Sent from my DROIDX using DroidForums
     
  11. chris215

    chris215 Member

    Joined:
    Oct 3, 2010
    Messages:
    46
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0
    I had the same incompatible errors as well. Prior to realizing the change back to stock on the LCD would fix the problem. I even used the help option within the Market. Received the "some Developers chose to filter out certain devices and I should contact them directly".

    Sent from my DROID2 using DroidForums
     
Search tags for this page
android market error your device is not compatible
,
droid x device not compatible
,
droid x market place your device isnt compatible
,
netflix not compatible your device
,
netflix your device is not compatible
,
netflix your device is not compatible with this item
,

netflix your device is not compatible with this version

,
remove market error device is not compatible for this versio
,
the device is not compatible with this version netflix
,

your device is not compatible with this version