Dear Droid X: You are a terrible device for email.

Discussion in 'Motorola Droid X' started by ChadJ55, Jan 3, 2011.

  1. ChadJ55

    ChadJ55 Member

    Joined:
    Aug 27, 2010
    Messages:
    49
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0
    Argh!! Maybe my fuse is short today, but I am SO sick of the fact that email (including Yahoo and Corporate Synch) are ultra unreliable on the Droid X and that they STILL have not fixed this basic issue with any release since 2.1 when the phone came out. What the heck, Motorola?!?! Is it THAT difficult to cure this problem? A good friend of mine just got the Droid Pro. The phone deemed a BUSINESS USER phone. And guess what... it is just as bad!!!

    The problem: No notification of new mail until I open the email app and it synchs itself. Suddenly a bunch of new mail comes in that should have arrived earlier. And it is intermittent!! Some days it is good and notifies me timely of all emails... some days it is TERRIBLE like today, when I am getting a lot of mail that needs action. Yes, my email is set to push. Yes, I have recreated the account several times. No, nothing has fixed it.

    Aside from changing to a third party app like touchdown (which I did not like very much after trying it), does ANYONE have a fix for this stupid problem or know when the brainiacs at Motorola will be able to fix it? I am so losing my patience.
     
  2. maurilax

    maurilax New Member

    Joined:
    Oct 18, 2010
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    New York
    Ratings:
    +0
    Yea this happens to me on any non Gmail account. its really a pain in the neck to constantly be checking work email instead of getting the notification. Im not sure what the cause of this issue is, I dont see that many people complaining about it.
     
  3. maderschramm

    maderschramm Member

    Joined:
    Jul 2, 2010
    Messages:
    672
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Madison, WI
    Ratings:
    +0
    easy fix:

    forward work emails to gmail account that syncs to dx

    solved.
     
  4. Mont

    Mont Member

    Joined:
    Dec 18, 2010
    Messages:
    96
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0
    Funny as I'm typing this I got an email notification from yahoo. I had the same problem and finally found out what's went wrong. After 2 weeks my Rhapsody account stop syncing music and my mail, I searched for 2 weeks then I found the answer buried in another thread.

    Go to your home screen and do a hard press. Add the Motorola or Android widget power settings, can't remember which one but only one has that setting. That's the only way I found to access this.
    Click the icon that got the sync symbol.

    When I done this I immediately remembered me toggling this thinking its syncing all the time and draining my battery,which isnt the case. You can remove the widget after. If that don't work I don't know what will.

    Unfortunately my Rhapsody still isn't syncing music.....
     
    #4 Mont, Jan 3, 2011
    Last edited: Jan 3, 2011
  5. ChadJ55

    ChadJ55 Member

    Joined:
    Aug 27, 2010
    Messages:
    49
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0
    Pushing my work emails to a gmail account is not a logical fix, if you ask me. So then when I reply to the email it comes from my gmail, right? That's not going to work for corporate users.

    Mont, thanks for the suggestion but I checked and my synch is, and has been, on. I don't use Rhapsody either. My synch issues, like others', is intermittent... and annoying!
     
  6. hookbill

    hookbill Premium Member
    Premium Member

    Joined:
    Nov 30, 2009
    Messages:
    19,502
    Likes Received:
    8
    Trophy Points:
    168
    Location:
    N.E. Ohio
    Ratings:
    +8
    My understanding is the way the sync apps works with other emails is that it "learns" how often to sync according to the amount of mail you get. Apparently that's not your experience.

    I also see something in Gmail settings where they charge for Corporate email. Even works with Blackberry's Enterprise Mail.
     
  7. Mont

    Mont Member

    Joined:
    Dec 18, 2010
    Messages:
    96
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0
    My sync under the regular settings always been on too with a fetch schedule of 15 minutes. The power widget sync must be different from that because once I turned that on its been working like I dreamed of.

    Its weird and annoying I had to use a widget to get it to work the way it suppose to.

    The Rhapsody has nothing to do with it, I was just hoping I was killing 2 birds with 1 stone.
     
    #7 Mont, Jan 3, 2011
    Last edited: Jan 3, 2011
  8. DroidXDawg

    DroidXDawg New Member

    Joined:
    Jan 3, 2011
    Messages:
    28
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    I have had the same problems twice now, both times was after I used wifi. The most recent time a power cycle remedied it. I have no issues with sync.

    In order to avoid email notification in the middle of the night I put it on vibrate in a separate room, but while on vacation I needed to have it on and with me so I set emailing to manual...every morning when I set it back to push and fetch every 15 mins several emails come in immediately.

    I have yahoo email and corporate sync set up. Culprit for my issues has been wifi. Just my $.02!

    Sent from my DROIDX using DroidForums App
     
  9. maderschramm

    maderschramm Member

    Joined:
    Jul 2, 2010
    Messages:
    672
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Madison, WI
    Ratings:
    +0
    You could receive the gmail that's forwarded then use an SMTP mail client to send out with your work mail...this could all be accomplished with k-9

     
  10. ChadJ55

    ChadJ55 Member

    Joined:
    Aug 27, 2010
    Messages:
    49
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0
    Thanks for the clarification, Mont. I am glad that widget solution worked for you.

    DroidXDawg, my use of wi-fi is very limted. I leave it off with the exception of occasions when I am traevlling out of country or accessing wi-fi on an airplane. Other than that, it stays turned off. I have, however, found that cycling the power and/or pulling the battery tends to make the synch work better... for a while. But then it somehow reverts to its annoying inconsistent behavior.

    Hookbill, if I were to use the Google exchange option, is my assumption correct that my replies would come from my gmail account rather than my work email? I also fear that the annoying "confidential info" footer that my company drops into every external email would start showing up in my internal emails since the email would be leaving the network.

    As far as the Droid learning the frequency of my email, I am fairly certain that is not the case. It appears to be completely random. And I always receive a lot of emails just about every day.

    And not that this is a really big deal, but my Yahoo mail notification icon is still missing since one of the updates in November. Notification light comes on, and the mail is in my notifications menu when I pull it down, but no icon. Humph...
     
  11. Jordan8

    Jordan8 Member

    Joined:
    Nov 16, 2010
    Messages:
    536
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Kentucky
    Ratings:
    +0
    Guess its were I use gmail & have my other accounts forward to it, but I don't have any problems with it.

    Sent from my DROIDX using DroidForums App
     
  12. MrKleen

    MrKleen Senior Member

    Joined:
    Jan 21, 2010
    Messages:
    1,602
    Likes Received:
    5
    Trophy Points:
    68
    Ratings:
    +5
    I would have hoped these email issues would have been resolved by now. This needs to be addressed if they want the business community to take them seriously.
     
Search tags for this page

dear driod