Data issue NOT related to existing 4G problem

Discussion in 'Droid 4 ROMS' started by Shein0327, Apr 4, 2012.

  1. Shein0327
    Offline

    Shein0327 Member

    Joined:
    Mar 26, 2012
    Messages:
    56
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0
    Hey everyone, I'm running gummy .9 but this issue is driving me so crazy I'm ready to try a different ROM.

    Ok, here is what I'm dealing with:

    Can't send or receive picture messages AT ALL. not on 3g, 4g, or even on wifi... I do however get data on 3g and wifi, I know this because I can access the internet through my browser, form apps, app store, etc.

    So the issue is SPECIFIC to sending and receiving data thru texts, SMS or MMS.

    I've tried reflashing, I've tried handcent and other texting apps, I'm at a complete loss. A friend of mine runs gummy .9 and he has no issues like this...

    Does anyone have any ideas??
  2. Shein0327
    Offline

    Shein0327 Member

    Joined:
    Mar 26, 2012
    Messages:
    56
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0
    Also: restarting the phone SOMETIMES makes 3g or wifi able to send/receive, but its shoddy at best.
  3. Kack
    Offline

    Kack Member

    Joined:
    Feb 10, 2010
    Messages:
    762
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Riverside, CA SO-CAL
    Ratings:
    +0
    have you tried flashing a stock rom and seeing if you are having the same issues?
  4. Shein0327
    Offline

    Shein0327 Member

    Joined:
    Mar 26, 2012
    Messages:
    56
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0
    Yep, stock rom is just fine
  5. Shein0327
    Offline

    Shein0327 Member

    Joined:
    Mar 26, 2012
    Messages:
    56
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0
    I installed CM9 and it appears to have fixed the problem... however, its too early to tell. I'll report back tomorrow
  6. Shein0327
    Offline

    Shein0327 Member

    Joined:
    Mar 26, 2012
    Messages:
    56
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0
    ok CM9 doesnt appear to have the issue, but now wifi KILLS my battery at an alarming rate (30% battery used by the wifi in an hour) and my camera no longer works -____- man I just cant win...
  7. anjunafreek03
    Offline

    anjunafreek03 New Member

    Joined:
    Aug 5, 2010
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    I, too have experienced this loss of signal or tower hopping. If you used either the AOKP, Gummy, or the CM9 from Hashcode Ihave new for you! After 3 frustrating days and 28 recharges later and 3 walls to repair (from the head banging) Idiscovered something odd. It seems that as soon as you turn off wifi (connected or not) it starts to search for signal. Leave the wifi on, even with nothing connected, Ihave FULL bars for 4G LTE! Give it a try and see what you can find out. Its like turning off wifi turns off part of the code or hardware for the 4G modem. I've been running amazing for 2 days now without airplane mode being touched or the phone being restarted!
  8. Shein0327
    Offline

    Shein0327 Member

    Joined:
    Mar 26, 2012
    Messages:
    56
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0
    That is odd.
    But my issue is wifi not allowing me to get MMS's. The issue persisted thru CM9, gummy, and AOKP. Wifi will give me data, but still not allow MMS service.

    Wouldn't leaving wifi on even if not connected kill the battery??
  9. anjunafreek03
    Offline

    anjunafreek03 New Member

    Joined:
    Aug 5, 2010
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    I agree. I'm not happy either, but I'm very glad to at least keep data! Its so frustrating when it keeps wanting to connect to a GSM tower even though you're close to a verizon 4G tower! I had to reflash in order to get data to connect again. Once it came up, I declined the wifi option and left it alone after that! 3rd day still 4G LTE strong! Do you have unlimited data? That's why I am not worried about usage.

    Sent from my XT894 using DroidForums