Corporate Sync -- Cannot connect to server

Discussion in 'Motorola Droid 3' started by snootalope, Jul 12, 2011.

  1. Csquared2429
    Offline

    Csquared2429 New Member

    Joined:
    Jul 19, 2011
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Austin, Texas
    Email Cert

    Thanks Aconway, I will get someone to mail me the SSL Cert. I will let you know.

    C
  2. aconway
    Offline

    aconway New Member

    Joined:
    Dec 22, 2010
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    0
  3. Peirogirl
    Offline

    Peirogirl New Member

    Joined:
    Jul 22, 2011
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    0
    Solution to Corporate sync Unable to connect to server error and Droid 3

    Just purchased the Droid 3 today. I am an avid Droid owner as I had the original Droid and Droid 2 previously. I did not have issues with corporate sync until the Droid 3. After reading the forums on the net, I finally figured I would call Motorola directly as no one was having any luck. The issue is with the Gingerbread release that is loaded on the Droid X and Droid 3.

    Here is the solution that works!

    1. Set up corporate sync with your gmail account first using the following....
    (Username) enter your gmail email
    (Email) enter your gmail email
    (server) enter m.google.com

    2. Accept and save the account.

    3. open Settings ~ Accounts ~ and the account you just created.

    4. Modify all of the account settings to reflect your actual corporate account.

    5. Save....

    Viola!

    I spent over an hour on the phone with Motorola and it was well worth it! Please try this solution and enjoy!
  4. Peirogirl
    Offline

    Peirogirl New Member

    Joined:
    Jul 22, 2011
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    0
    PS... Again, it is not an SSL certificate issue, but rather an issue with the Gingerbread release.
  5. bonesjones
    Offline

    bonesjones New Member

    Joined:
    Dec 24, 2009
    Messages:
    76
    Likes Received:
    0
    Trophy Points:
    0
  6. Csquared2429
    Offline

    Csquared2429 New Member

    Joined:
    Jul 19, 2011
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Austin, Texas
    Genius! This works like a charm!

    This got mine working in 2.2 seconds - thanks so much PeiroGirl!
  7. Peirogirl
    Offline

    Peirogirl New Member

    Joined:
    Jul 22, 2011
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    0
    I am glad that I could help!!
  8. ekyle
    Offline

    ekyle New Member

    Joined:
    Oct 18, 2010
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Central NY
    Thank you for this! I've been going back and forth with Novell for two days. We even bought a cheap cert from GoDaddy (only $13 so whatever). This worked like a charm.
  9. snootalope
    Offline

    snootalope New Member

    Joined:
    Jul 12, 2011
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    0

    If anyone else hits this, a much easier way to go about this is to just have your IT guys open up port 80 to your Exchange server for just the amount of time it takes you to sync the first time (be sure to tell it NOT to use ssl when setting it up). After it syncs the first time, close port 80 on your firewall and go into the account settings and disable certificate verification.

    I agree with others here that a CA signed cert from godaddy or whatever is the way to go. It's cheap and saves ya a bunch of BS. However, in my case, I have a number of windows mobile devices out there still that have our self-signed root cert installed and our godaddy cert is a wildcard, which windows mobile doesn't support. That's the only reason we have a self-signed cert right now.. Once those people finally upgrade we're going to the third party cert and not looking back.
  10. cala833
    Offline

    cala833 New Member

    Joined:
    Aug 2, 2011
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    I've set up corporate sync with my gmail account and still can't get it work. Once I try to edit the existing account I'm receiving an error: 'Could not connect to server' !?
  11. pcpimp
    Offline

    pcpimp New Member

    Joined:
    Apr 7, 2011
    Messages:
    151
    Likes Received:
    1
    Trophy Points:
    0
    Location:
    CBUS
    Thanks it worked!!!!! My wife is happy :) Also got it rooted now waiting on some custom rom goodness....lol!
  12. shanon2023
    Offline

    shanon2023 New Member

    Joined:
    Sep 20, 2011
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    I am having the same issue - went through all of the above steps and still nothing is working - any more suggestions?
  13. killianss
    Offline

    killianss New Member

    Joined:
    Jul 21, 2010
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    0
    Im in the same boat nothing works for me, still get the server not found; this is pretty infuriating especially since I can configure the gfs droid incredible no problem at all. So the issue is definitely this moto phone(x2), i really think im done with moto this is s a persistant issue and it seems that they don't care.
  14. azr71
    Offline

    azr71 New Member

    Joined:
    Jan 12, 2012
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    I got it to work.. thanks.. this is my 6th Droid (droid x, droid x, droid x2, droid 2, droid x2, droid x2 [current]).. in the past 1.25 yrs. Have had most of the phones in the past 4months. Worked with VZ, Corporate and Motorola helpdesk.. guess what resolved it... This posting!! What a pain!! Have spent close to 12hours on the phone since Jan 2. even went to the stores. anyway.. got it to work..


    Got the GMAIL accound on the phone with corporate sync first. {not sure if you need to remove the gmail account first if you have it from the activation - but i used another gmail account so i had both when the gmail was linked to the corporate sync}.
    Once I got that.. i went to modify. at first it did not work..
    I did forget one thing - the domain name for the exchange server.
    In the "Update Account" screen it does not ask for a domain name so i had to add it to the user id... so for example if my user id is johns1125 and my domain is "namsales"
    I had to input "namsales\johns1125" [with the back slash]. that seemed to work.

    hope this helps.

    AZ
  15. goodvaluecenter
    Offline

    goodvaluecenter New Member

    Joined:
    Jan 27, 2012
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    Droid X2 - adding a new phone to Exchange 2007 Error on phone "Can't connect to serve

    Just solved this problem.

    Exchange 2007 – Can’t add a new Droid X2 corporate synch account to phone. Exchange 2007. When creating new account I get the following Error “Can’t connect to server” or Can’t add a non-provisioned device”

    Solution:

    On SBS2008 Server running Exchange 2007, go to exchange management consule and Create a new active sync policy (just name it leave defaults) apply it to their account under their account properties then go back and reapply the old one.
  16. izilladotcom
    Offline

    izilladotcom New Member

    Joined:
    Feb 29, 2012
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    Thank you!!

    I just got the Droid 4 after finally upgrading from the Droid1 and was getting really frustrated with how difficult it was to set this up. Thank you SOO much for figuring this out.

    **Note to other people having problems. This will not work if you try and enter a duplicate email into the Corporate Sync set up. I had to use a different gmail account I had, and it worked just fine once I did that. You should also have youremail@gmail.com in both the Domain and Username fields, as they're called in the Droid 4 set up. Hope this helps!
  17. leighpea57
    Offline

    leighpea57 New Member

    Joined:
    May 1, 2012
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Orlando, FL
    It works!! Thank you!


    Thanks so much for sharing this! I have a Motorola Droid X2 and this worked perfect to solve my problem with connecting to the server. This has to be a glitch in the software but if it works, I don't care how. This should be posted on the Verizon website troubleshooting!
  18. aamaya83
    Offline

    aamaya83 New Member

    Joined:
    Aug 16, 2012
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    It could be your Exchange settings too...

    I was having the same issue, cept slightly different message. Kept on saying login failure. The problem ended up being in the Exchange server. On the user's Properties, there is a tab called "Mailbox Features." The Exchange Activesync option was disabled. I re-enabled the option and after a few minutes, the phone synced up and everything is working. Hope this helps.
Search tags for this page

android exchange cannot connect to server

,
connect android email to corporate gmail
,

couldn't open connection to server due to an invalid server

,
droid 4 corporate email couldn't connect to server
,
droid 4 exchange could not connect to server
,
droid can't connect to server
,
droid razr m cant connect to server error
,
droid razr unable to connect to server
,

droid x2 cannot connect to exchange

,

droid x2 could not connect to server

,

enter your existing corporate sync account

,
unable to open connection server gmail android corporate account