Corporate Sync -- Cannot connect to server

Discussion in 'Motorola Droid 3' started by snootalope, Jul 12, 2011.

  1. snootalope
    Offline

    snootalope New Member

    Joined:
    Jul 12, 2011
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    0
    Our business got our first Droid3 today, and it's not been good. Everything on the phone is awesome, other than the fact the corporate sync doesn't work.

    We've got a million Droid2's hooked up to our Exchange 2010 server and I've never once had an issue with them syncing.

    Setting up the Droid3 is just like setting up the Droid2 as far as the corporate sync goes, however once entering the mail server manually and hitting next to establish the connection, it immediately says "Error. Could not connect to the server" and that's as far as I get.

    I spent the morning on the phone with tech support and the data application developers or whoever they are beyond basic tech support and they said there is a known issue with the Droid3 and the corporate sync and they're working on a service pack or an update. No timeline on the update, nothing beyond "they're working on it."

    How in the %&$# do you release a smartphone when you KNOW it has a bug and can't sync with Exchange 2010 and enhanced security.
  2. snootalope
    Offline

    snootalope New Member

    Joined:
    Jul 12, 2011
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    0
    Just an update, incase anyone else runs into this which I'm guessing there'll be plenty.

    I found this post: Exchange activesync problem with Android 2.3.3. - Google Mobile Help

    Apparently this has been a known issue for quite sometime and goes back to 2.3.3. It was supposed to be fixed apparently in 2.3.4, but I it's been confirmed that its definitely not fixed.

    I've loved the Droid's for years now. But, this is the first BS move I've seen them make and it's a HUGE deal breaker.
  3. mattbooty
    Offline

    mattbooty New Member

    Joined:
    Jan 28, 2011
    Messages:
    112
    Likes Received:
    0
    Trophy Points:
    0
    I'm guessing this must have something to do with the settings on your exchange server or possibly your SSL certificate (if your exchange box is requiring one). My activesync is working fine. I did read elsewhere that the D3 no longer allows you to "accept all certificates", which would then break your connection if you are using a self-signed cert. Otherwise its possible that a specific active-sync policy on your exchange box is blocking access or the droid doesn't like.

    I can help compare active sync policy settings with what I'm running if you need assistance.
  4. snootalope
    Offline

    snootalope New Member

    Joined:
    Jul 12, 2011
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    0
    another update. A work around on this is to setup the account while connected to the local LAN of the exchange server and disable the secure connection, or open up 80 to your exchange server on your firewall. Setup the account, then manage the account, and disable certificate checking.
  5. snootalope
    Offline

    snootalope New Member

    Joined:
    Jul 12, 2011
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    0
    It's definitely a certificate issue. However, since they removed the option to just accept all certificates its complicated things.
  6. aconway
    Offline

    aconway New Member

    Joined:
    Dec 22, 2010
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    0
    I use Touchdown Exchange.. it's infinitely better than the built in mail app for Exchange Servers... it has a feature to "fetch and trust certificate", which is very useful... although, in a perfect world, you shouldn't have to use it if your cert is set up correctly.. .. but yeah, dealing with cert issues is probably the #1 pain for remote Exchange connectivity... I hear ya. It's $20, with a 1 month full demo, BTW and no I don't work for them, I just really like the app!
  7. mattbooty
    Offline

    mattbooty New Member

    Joined:
    Jan 28, 2011
    Messages:
    112
    Likes Received:
    0
    Trophy Points:
    0
    I liked touchdown better than the OG droid exchange client, but if you haven't already give the D3 exchange client a try, i like it a lot.
  8. mattbooty
    Offline

    mattbooty New Member

    Joined:
    Jan 28, 2011
    Messages:
    112
    Likes Received:
    0
    Trophy Points:
    0
    Are you using a self-signed cert or is it a paid cert?

    I agree, I'm not sure why they removed that option, we have a paid cert on ours so it works fine, but I know a lot of companies don't want to shell out $50 a year when you can self-sign one for free.
  9. ocdtrekkie
    Offline

    ocdtrekkie New Member

    Joined:
    Aug 24, 2010
    Messages:
    46
    Likes Received:
    0
    Trophy Points:
    0
    I'm also having trouble with my DROID3 Corporate Sync. We have DROID2s that work, and our mail server uses a self-signed certificate.
  10. goober0122
    Offline

    goober0122 New Member

    Joined:
    Jan 6, 2011
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    0
    I had this same exact issue with my Droid 3 yesterday. Corporate Sync worked for a few days and then I couldn't connect. I made the mistake of deleting the account, turns out our SSL cert expired yesterday. On the other Droid 3s I was able to disable certificate verification under the account settings and they worked fine. Mine was not able to re-create the account. The cert was renewed this morning and all is well in the world. If you are using a self-signed cert you will need to either have your Droid 3 on the lan when creating the account or get a paid cert.
  11. ocdtrekkie
    Offline

    ocdtrekkie New Member

    Joined:
    Aug 24, 2010
    Messages:
    46
    Likes Received:
    0
    Trophy Points:
    0
    I'm on the secured LAN with it, but it's not working with SSL, and I think our mail server refuses any connection, even internally, that isn't SSL.
  12. goober0122
    Offline

    goober0122 New Member

    Joined:
    Jan 6, 2011
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    0
    If you can go to your webmail (Outlook Web Access) in Firefox. To the left of the address there will be a button for the cert. Click on that and view the cert and see when the expiration date is and see if it was signed by a CA.
  13. ocdtrekkie
    Offline

    ocdtrekkie New Member

    Joined:
    Aug 24, 2010
    Messages:
    46
    Likes Received:
    0
    Trophy Points:
    0
    As I said, it's self-signed, not by a CA.
  14. goober0122
    Offline

    goober0122 New Member

    Joined:
    Jan 6, 2011
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    0
    Sorry didn't see that. The newer droid phones (D2) and above do not like self-signed. I know Touchdown works like a champ, google free touchdown license Motorola. I know for us Droid X users they gave us free licenses because of corporate sync issues. They should be able to hook you up if you get to the right department.
  15. bw13
    Offline

    bw13 New Member

    Joined:
    Jul 15, 2011
    Messages:
    14
    Likes Received:
    1
    Trophy Points:
    0
    Mine synced perfectly, although I do use touchdown because I like that it will use the voice to tell me who I have an email from.
  16. ocdtrekkie
    Offline

    ocdtrekkie New Member

    Joined:
    Aug 24, 2010
    Messages:
    46
    Likes Received:
    0
    Trophy Points:
    0
    Thanks, the big thing that got me, was the level 3 support email address, from the looks of it. I was trying to get a hold of them earlier.

    They need a special phone line or code word that will inform them that you're either IT or a programmer, and wish to speak to someone higher up immediately, because you wouldn't be calling for something a level 1 or level 2 support rep could help with.

    xkcd: Tech Support
  17. spruleme
    Offline

    spruleme New Member

    Joined:
    Apr 25, 2010
    Messages:
    24
    Likes Received:
    0
    Trophy Points:
    0

    Good find about this, I had opened up http activesync to work around the self signed issue but didn't realize I could disable verify certs afterwards. Kudos to you, sir.dancedroid
  18. Csquared2429
    Offline

    Csquared2429 New Member

    Joined:
    Jul 19, 2011
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Austin, Texas
    LAN not accessible - still having trouble

    So I'm trying to complete the workarounds that you all posted, thanks for doing that.

    Problem is I'm in a remote office and won't be able to get on LAN to get the certificate.

    Anyone have a workaround? I'd like to get corporate sync up and running but can't find a workaround. Any thoughts would be greatly appreciated.

    Csquared
  19. aconway
    Offline

    aconway New Member

    Joined:
    Dec 22, 2010
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    0
    Have your IT person email you the Cert file (to your gmail or something you can pickup on your Droid), then you can install it locally on your Droid, then set up the Corporate sync. This is the process I always used for older PDA's and phones using self-signed certs with ActiveSync and it seemed to work... I could just tap the .cer file from the email and it would prompt to install it, although it will be 'untrusted', just accept/yes and install it anyways..

    Also.. could try setting up a VPN (if your network provides that), connect to it first, then configure corporate sync...
  20. brent817
    Offline

    brent817 New Member

    Joined:
    Jul 20, 2011
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    0
    I had this issue as well with my Droid 3 at work but got it working. My account settings are:

    Username: domain/user
    server: mail.domain.org

    i am using a secure connection and have verify certificate checked (we are using a self cert)

    >having http:// in front of the server stops it from working
    >removing the domain\ from before the user stops it from working

    I set up the connection using wifi, not 3g. And it only worked using the SSID that had LAN access.
Search tags for this page
account sync cannot connect toserver
,

android exchange cannot connect to server

,
connect android email to corporate gmail
,

couldn't open connection to server due to an invalid server

,
droid 4 corporate email couldn't connect to server
,
droid 4 exchange could not connect to server
,
droid can't connect to server
,
droid razr m cant connect to server error
,
droid razr unable to connect to server
,

droid x2 cannot connect to exchange

,

droid x2 could not connect to server

,

enter your existing corporate sync account

,
motox corporate sync error
,
samsung charge cannot connect to corporate email
,
unable to open connection server gmail android corporate account