contacts do not show "phone" contacts, only google contacts.

Discussion in 'Android Tech Support' started by oldandroid, Apr 27, 2015.

  1. oldandroid

    oldandroid New Member

    Joined:
    Apr 27, 2015
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Current Phone Model:
    LG vm670
    I just fired up my old backup android 2.2 because my phone got run over.
    I took some internet advise and erased all contacts before restoring the backups from my old phone. The way IL used was to go to app manager, and delete all data from the "contacts" and "contacts storage" apps.
    When I tried to restore the contacts, it went thgouth the process but no contacts apeared. I went to contacts menu>choose contacts to display but the only option is google contacts.
    So I tried synching google contacts and that did create some contacts. Then I restored the vcf file from my old phone again and this time they were added. But still the phone only allows displaying goolge contacts so I guess they were added to my google contacts. I don't want to have to synch with google and want to have normal phone-based contacts available. I'm afraid the erasing process I used messed up the phone contacts facility.
     
  2. leeshor

    leeshor Gold Member

    Joined:
    Jan 30, 2012
    Messages:
    4,363
    Likes Received:
    1,437
    Trophy Points:
    358
    Location:
    Norcross, GA - USA
    Ratings:
    +1,676
    Welcome to the forum

    Is a part of the problem the phone (dialer) contacts? You didn't mention how you backed them up. I have 2 apps that back up all the contacts, including the phone contacts, as opposed to, (just), the mail contacts
     
    • Like Like x 1
  3. oldandroid

    oldandroid New Member

    Joined:
    Apr 27, 2015
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Current Phone Model:
    LG vm670
    I used the android backup facility, backing them up as a vcf file.
    They did back up once I had connected to google contacts, but only were added as part of google contacts. There is no access to phone contacts. I think the advise post gave me wrong info. I think I should have just deleted data in the "contracts storage" app and not in the "contacts" app. Now contacts storage is running, but contacts is not listed as running (in the apps manager). but when I open contacts app in the app manager in settings, it has the option to "force stop" which suggests it is running. so it seems to be messed up.

    Edit: I force closed contacts app, and opened contacts. Now app manager does report contacts app as running,but contacts still does not list phone based contacts, only google.
     
  4. KaosMaster

    KaosMaster Senior Member

    Joined:
    Jan 24, 2011
    Messages:
    699
    Likes Received:
    164
    Trophy Points:
    58
    Location:
    Garden Grove, CA.
    Ratings:
    +186
    Current Phone Model:
    SCH-I545 Galaxy S4 (Verizon)
    I remember on my old Droid device...It did not have a phone based contacts storage, only Google. Maybe this is the issue your experiencing @oldandroid. Attempt to create a new contact on the device and not Google, and see if the option is even present.
     
  5. oldandroid

    oldandroid New Member

    Joined:
    Apr 27, 2015
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Current Phone Model:
    LG vm670
    I'm pretty sure that on all my old androids, you could see your phone contacts even when the phone did not have a current phone number and account. Maybe yours was super old like android 1 or something, or maybe your phoen had the same problem or maybe my memory is wrong.
     
  6. Jonny Kansas

    Jonny Kansas Administrator
    Staff Member Rescue Squad

    Joined:
    Jan 21, 2010
    Messages:
    16,470
    Likes Received:
    7,049
    Trophy Points:
    1,278
    Location:
    Michigan's Upper Peninsula
    Ratings:
    +8,391
    Current Phone Model:
    Pixel XL
    Twitter:
    jonny_ks
    Moto Droid X wouldn't default to saving my contacts to Google, no matter how many times I told it to, so I had to manually copy a few from the device to my next one when I upgraded. Personally, I ALWAYS sync my contacts to google. Less setup when I get a new device and I can access and manage them from my web browser with a full keyboard if I have a lot to edit. Not to mention, if I lose my phone, I only need access to my google account to still have access to my contacts...Thank God, because I don't remember anyone's number these days.
     
Search tags for this page

my phone does not show contacts or log