Configuring Do Not Disturb

Discussion in 'Samsung Galaxy S6, S6 Edge and S6 Edge Plus' started by SallyC, Oct 6, 2015.

  1. SallyC

    SallyC Senior Member

    Joined:
    Dec 1, 2011
    Messages:
    1,247
    Likes Received:
    102
    Trophy Points:
    63
    Location:
    Michigan
    Ratings:
    +103
    I have Do Not Disturb set up to allow exceptions from Calls or Alarms, but not Messages. I also have the calls/messages set to Favorites only. What I was hoping was that only calls from my Favorites would come though, along with any Alarms I'd set, but last night I also got two texts so I can see I did that wrong.

    How can I set it so only any wakeup alarms, and also only calls from Favorites are exceptions?

    Thanks.

    Sent from my SM-T900 using Tapatalk
     
  2. Jonny Kansas

    Jonny Kansas Administrator
    Staff Member Rescue Squad

    Joined:
    Jan 21, 2010
    Messages:
    16,547
    Likes Received:
    7,107
    Trophy Points:
    1,278
    Location:
    Michigan's Upper Peninsula
    Ratings:
    +8,455
    Current Phone Model:
    Pixel XL
    Twitter:
    jonny_ks
    DND has been such a pain to figure out. I'm still not convinced that I understand it. I allow alarms and all calls and texts from anyone in my contacts, so I'm afraid I can't be much help in narrowing it down.

    Good luck though!
     
    • Like Like x 1
  3. bkdodger

    bkdodger Super Moderator
    Staff Member

    Joined:
    Dec 13, 2011
    Messages:
    7,770
    Likes Received:
    4,123
    Trophy Points:
    1,563
    Location:
    Staten Island, New York
    Ratings:
    +4,408
    Current Phone Model:
    Nexus 6
    I only like text and calls from my favorites.. But what happens if you unchecked messages [​IMG]

    S6E+ tapatalk
     
    • Like Like x 1
  4. SallyC

    SallyC Senior Member

    Joined:
    Dec 1, 2011
    Messages:
    1,247
    Likes Received:
    102
    Trophy Points:
    63
    Location:
    Michigan
    Ratings:
    +103
    This is what I have. [​IMG]

    Sent from my SM-G928V using Tapatalk
     
  5. TisMyDroid

    TisMyDroid Super Moderator
    Staff Member

    Joined:
    Feb 16, 2011
    Messages:
    7,332
    Likes Received:
    3,065
    Trophy Points:
    578
    Location:
    Central New York
    Ratings:
    +3,363
    Current Phone Model:
    Samsung Note 3
    I wonder if you have to turn the notifications off from within the text messaging app also.

    Sent from my SM-N920V using Tapatalk
     
    • Like Like x 1
  6. Jonny Kansas

    Jonny Kansas Administrator
    Staff Member Rescue Squad

    Joined:
    Jan 21, 2010
    Messages:
    16,547
    Likes Received:
    7,107
    Trophy Points:
    1,278
    Location:
    Michigan's Upper Peninsula
    Ratings:
    +8,455
    Current Phone Model:
    Pixel XL
    Twitter:
    jonny_ks
    Are you using the stock messaging app for texts, or a third-party app? I know, at least at one point, while using Google Hangouts as my texting app, I had it set to allow texts, but I missed an important one because apparently it didn't recognize it or something. Kind of the opposite of your problem, but I'm wondering if that's a factor.
     
    • Like Like x 1
  7. SallyC

    SallyC Senior Member

    Joined:
    Dec 1, 2011
    Messages:
    1,247
    Likes Received:
    102
    Trophy Points:
    63
    Location:
    Michigan
    Ratings:
    +103
    Hmmm. I'm using Message+ 5.6.8 I think that's stock, but I'm not sure. I do see in the settings on the app I have a reminder notification set up. And the sound is different than the sound I have on my phone's settings for messages. The sound that woke me up both times last night was not the sound set in my phone setting, but the one that was on the message app. So you may be onto something there.

    I turned it off. It's kind of nice because it's a repeat reminder in case I don't hear it the first time. But if its found a way around do not disturb, then I guess it's not really worth it.

    Thanks for all the good ideas! I will turn off reminders in the app, and hopefully that will solve the problem.

    Sent from my SM-G928V using Tapatalk
     
    • Like Like x 1
  8. Jonny Kansas

    Jonny Kansas Administrator
    Staff Member Rescue Squad

    Joined:
    Jan 21, 2010
    Messages:
    16,547
    Likes Received:
    7,107
    Trophy Points:
    1,278
    Location:
    Michigan's Upper Peninsula
    Ratings:
    +8,455
    Current Phone Model:
    Pixel XL
    Twitter:
    jonny_ks
    I'm assuming you're referring to the "Default notification sound" (or similar) in your main sound settings? That's the sound it will play for an app's notification if they don't let you choose the notification sound and/or by default a lot of times if they do let you choose your own sound within the app.

    If you set a notification sound within Message+, that's what you'll hear when you get texts. So, if the sound you heard came from Message+ and wasn't the one you've got set as the Default Notification sound, that makes plenty of sense.

    Just make sure you're only turning the reminder off and not the notification itself. Otherwise, you won't get notified of ANY texts all day. Quite the opposite of what you're going for...
     
    • Like Like x 1
  9. TisMyDroid

    TisMyDroid Super Moderator
    Staff Member

    Joined:
    Feb 16, 2011
    Messages:
    7,332
    Likes Received:
    3,065
    Trophy Points:
    578
    Location:
    Central New York
    Ratings:
    +3,363
    Current Phone Model:
    Samsung Note 3
    I hope that works. That is the one thing that drives me crazy; that there is phone notification settings and then each app has their own notification settings. Then trying to figure out which is causing it to not work like you want, the phone's or the apps setting.

    Sent from my SM-N920V using Tapatalk
     
    • Like Like x 1
  10. Jonny Kansas

    Jonny Kansas Administrator
    Staff Member Rescue Squad

    Joined:
    Jan 21, 2010
    Messages:
    16,547
    Likes Received:
    7,107
    Trophy Points:
    1,278
    Location:
    Michigan's Upper Peninsula
    Ratings:
    +8,455
    Current Phone Model:
    Pixel XL
    Twitter:
    jonny_ks
    I have to disagree. I set my default notification sound to silent. Most apps don't bother me that way, unless I change their individual settings on purpose.
     
    • Like Like x 2
  11. SallyC

    SallyC Senior Member

    Joined:
    Dec 1, 2011
    Messages:
    1,247
    Likes Received:
    102
    Trophy Points:
    63
    Location:
    Michigan
    Ratings:
    +103
    You know what? I think I made a mistake in my reply. There is no place in messages+ to set up a notification sound. Only to turn on reminders.

    In my phone setting under sound I have a default notification sound. Then under messages in the sound area of the phone app I have the place where I can set a particular sound for messages. I have a sound set there for messages, but it is different than the default notification sound.

    In the Message+ app is where I can set up if I want repeat notifications. What is happening is that my message notification sound sounds once, and then the repeat notification sound is my default notification sound.

    So I turned off reminders in the message app since the sound that I heard in the early morning hours was the default notification sound and not the sound I set for my messages app.

    It appears that somehow the reminder notification, which is using the default notification sounds, is bypassing the Do Not Disturb function.

    Sent from my SM-G928V using Tapatalk
     
    • Like Like x 2
  12. TisMyDroid

    TisMyDroid Super Moderator
    Staff Member

    Joined:
    Feb 16, 2011
    Messages:
    7,332
    Likes Received:
    3,065
    Trophy Points:
    578
    Location:
    Central New York
    Ratings:
    +3,363
    Current Phone Model:
    Samsung Note 3
    Yes! That is exactly what I do... now! But I tell ya, it took me forever to figure out that the reason my notifications were not acting how I set them up was because the phone's settings had their own idea. If I want a notification (which is for almost nothing), I'll set it up through the app myself.

    Sent from my SM-N920V using Tapatalk
     
    • Like Like x 2