CM7.0.2 on D1- no USB SD mounting?

Discussion in 'Cyanogenmod' started by phonetool, Apr 25, 2011.

  1. phonetool
    Offline

    phonetool New Member

    Joined:
    Mar 22, 2011
    Messages:
    337
    Likes Received:
    0
    Trophy Points:
    0
    I upgraded from RC4 to CM7.0.2 last night and USB SD mounting is not working.

    On RC4, I was using ChevyNo1's LV1GHz kernel (known to have issues with USB)
    On 7.0.2 I'm just with the kernel delivered with the ROM (2.6.32.9-cm-stk)

    I've read that it's the kernel that is causing issues, but you'd think the stock kernel would at least work.
    [REQUEST] Phone to PC via USB has stopped working !! - CyanogenMod Forum

    Anyone know of a kernel to try?
    I wanted to try Prime's Deprimed, but I don't see it as an option in ROM Manager. Maybe I'm not looking in the right place? (Advanced/Pro activated)

    TIA

    *edit*
    Ak!
    http://www.droidforums.net/forum/motorola-droid/70326-usb-connected-notification-not-showing-up.html
    *epic facepalm*
    >>uncheck USB DeBugging
    Last edited: Apr 25, 2011
  2. Maverick0984
    Offline

    Maverick0984 New Member

    Joined:
    Dec 26, 2009
    Messages:
    405
    Likes Received:
    3
    Trophy Points:
    0
    Don't rely on ROM Manager for all your downloading sources...that is just the surface. There is a thread in this very section of the forums that is prime's with all of his kernel info.

    It is so easy to find...
  3. phonetool
    Offline

    phonetool New Member

    Joined:
    Mar 22, 2011
    Messages:
    337
    Likes Received:
    0
    Trophy Points:
    0
    Understood. Thanks!
  4. Maverick0984
    Offline

    Maverick0984 New Member

    Joined:
    Dec 26, 2009
    Messages:
    405
    Likes Received:
    3
    Trophy Points:
    0
    ;-) you're welcome
    Last edited: Apr 25, 2011
  5. winner00
    Offline

    winner00 Premium Member Premium Member Developer

    Joined:
    Nov 15, 2009
    Messages:
    1,112
    Likes Received:
    10
    Trophy Points:
    0
    Location:
    Utah
    It should still work with USB Debugging checked running the stock kernel and deprimed kernel.
  6. dberthia
    Offline

    dberthia New Member

    Joined:
    Nov 12, 2009
    Messages:
    106
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Minnesota
    Both CM7's stock kernel and prime's work for me on my D1. I can mount the SD card using either kernel. (Using 7.0.2)
  7. phonetool
    Offline

    phonetool New Member

    Joined:
    Mar 22, 2011
    Messages:
    337
    Likes Received:
    0
    Trophy Points:
    0
    Weird.
    It wasn't working that way before. Now I can connect up USB with Debugging checked or unchecked.

    /stumped
  8. phonetool
    Offline

    phonetool New Member

    Joined:
    Mar 22, 2011
    Messages:
    337
    Likes Received:
    0
    Trophy Points:
    0
    Hmm.. Ok, just flashed Prime's Deprimed kernel and the same thing happened as last night/this morning.

    *fresh ROM
    *USB debugging checked
    *plug in USB
    *no droid pop-up
    *home/settings/applications/development/uncheck USB debugging
    *up pops the droid USB notification- all works fine

    Seems that, after a fresh ROM, I have to go through this one time.
    After doing it once, USB connection will work no matter what USB Debugging is set to.
  9. crdnilfan
    Offline

    crdnilfan New Member

    Joined:
    Dec 22, 2009
    Messages:
    207
    Likes Received:
    0
    Trophy Points:
    0
    I had the exact same issue, i thought it was a ROM issue, definitely a kernel thing. I went from a RZR-smartMoD kernel (which wouldn't allow me to mount) to deprimed #19 (which did allow me to mount).
  10. Timberwolf
    Offline

    Timberwolf New Member

    Joined:
    Jul 23, 2010
    Messages:
    70
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Ohio!
    I am appearing to have the USB mount problem. I have toggled debug on/off several times. When I plug my Droid into my computer the debugging icon will pop up but not the USB connected one... I flashed my kernel that I've always used and its always let me mount.
  11. Ozzie
    Offline

    Ozzie Member

    Joined:
    Aug 6, 2010
    Messages:
    824
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Minnesota
    I was having this issue recently...out of the blue...different roms, even Froyo roms too. I put in my original sd card and did a fresh install and everyone is happy again. Just sayin'...
  12. EnJoY
    Offline

    EnJoY New Member

    Joined:
    Jul 9, 2010
    Messages:
    93
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Massachusetts, USA
    Was having the same issue. I ran the update_deprimed script in terminal, let it reboot/install and when it rebooted I tried it again and it worked fine.
  13. TemplesOfSyrinx
    Offline

    TemplesOfSyrinx New Member

    Joined:
    Jan 19, 2010
    Messages:
    136
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    NJ
    I was on PE4.2 up until this week. I was so happy with the smartmod kernel that I immediately changed to it after installing Cyanogenmod7.02. It works flawlessly with exception of the USB connection not recognizing. Rather than switching kernels, I purchased Multi-Mount SD in the market for a buck.

    Now everything works great and I have my rMod SmartMod kernel.
Search tags for this page
cm7 mount usb
,
cm7 no usb notification
,
cm7 sd card not mounted
,

cyanogen mount usb

,
cyanogen no usb
,
cyanogenmod 7 usb automount
,
cyanogenmod cm7 usb debug
,
cyanogenmod cm7 usb debugging
,

cyanogenmod mount usb

,
cyanogenmod usb mounting
,
galaxy nexus on cyanogen usb stopped working
,
motorola d1 cyanogenmod
,
no usb with cyanogen mod
,
usb sd card mount cyanogen
,
wht there is no usb debugging on cyanogenmod