Changing default browser action

Discussion in 'Samsung Galaxy S6, S6 Edge and S6 Edge Plus' started by IIGood, Sep 4, 2016.

  1. IIGood

    IIGood Silver Member

    Joined:
    Jul 13, 2010
    Messages:
    699
    Likes Received:
    246
    Trophy Points:
    143
    Location:
    Arnold, MD
    Ratings:
    +276
    Current Phone Model:
    Galaxy S6
    Sorry if I'm not very clear in this, but it's tricky to describe...

    I do have Chrome installed on my phone and when I go into the phone settings, under Default Applications, Chrome is set as my default browser. However, if I receive a link via email or text message and I tap the link, it opens in the "other" browser that seems to be a native Samsung browser (this is also the same browser that opens if I tap a link from the Google searchbar).

    Up until yesterday or so, that was working fine. But now when I tap a link from email or text, it opens that other browser but nothing loads. I have to tap the 3 vertical dots in the upper right and then tap "Open in Browser" and then it loads fine in Chrome.

    Hopefully I'm making sense. I'm not crazy about that other browser and would like for the phone to not use it at all. I think it came around with Marshmallow...any ideas how I can turn that off, or at least fix it?
     
  2. makaiguy

    makaiguy New Member

    Joined:
    Jun 26, 2013
    Messages:
    14
    Likes Received:
    12
    Trophy Points:
    3
    Ratings:
    +15
    Current Phone Model:
    Sammy Galaxy S7 on Verizon
    I think that other browser is just labelled "Internet"?

    Drag notifications down from top of screen.
    Click on the gear icon to load Settings.
    Click Applications.
    Click Application Manager.
    Scroll down to Internet and click.
    If under Set as Default it tells you it is set as default, click on it, then "Clear defaults".
    Return to previous Internet page. If you wish you can completely disable the app. If this was something you installed rather than the default app from the manufacturer you should see Uninstall rather than Disable. Click Disable/Uninstall.

    Next time you click one of those links it should give you your choice of browsers to use, if you have more than one, then use that as the default after that.

    (Based on my Galaxy Tab A 8, running Android 6.0.1)
     
    • Like Like x 3
  3. mountainbikermark

    mountainbikermark Super Moderator
    Staff Member Premium Member

    Joined:
    Sep 5, 2010
    Messages:
    7,455
    Likes Received:
    3,886
    Trophy Points:
    1,563
    Ratings:
    +4,348
    Agreed, freezing the bloatware would ensure Chrome for all.

    Support Our Troops!!!
    Beast Mode 4

    <><
     
    • Like Like x 1
  4. IIGood

    IIGood Silver Member

    Joined:
    Jul 13, 2010
    Messages:
    699
    Likes Received:
    246
    Trophy Points:
    143
    Location:
    Arnold, MD
    Ratings:
    +276
    Current Phone Model:
    Galaxy S6
    Thanks for the suggestions! I went looking for that in the Applications list and unfortunately, I did not find anything that resembled a generic browser such as "Internet", "web", or "Browser." I know my girlfriend's S3 has a generic browser like that but I didn't see it on my S6. Chrome is set as my default browser and as far as I can remember, it was the default browser that was installed on the phone when I initially received it.

    I'm thinking it's somehow baked into one of the other Google apps, possibly Google Now? I'm not sure. I think this alternate browser started showing up when the phone was updated to Marshmallow, or now that I think about it more, it could have come from an update to Google Now. Or maybe it was even a combination of the two.
     
  5. mountainbikermark

    mountainbikermark Super Moderator
    Staff Member Premium Member

    Joined:
    Sep 5, 2010
    Messages:
    7,455
    Likes Received:
    3,886
    Trophy Points:
    1,563
    Ratings:
    +4,348
    Go to Settings, Application Manager, scroll across the top to All, scroll down and you should see this
    [​IMG]
    On my Note4 it can't be frozen without root but tap it, scroll down to the bottom and tap clear defaults.
    [​IMG]
    Hope that helps.

    Support Our Troops!!!
    Beast Mode 4

    <><
     
  6. IIGood

    IIGood Silver Member

    Joined:
    Jul 13, 2010
    Messages:
    699
    Likes Received:
    246
    Trophy Points:
    143
    Location:
    Arnold, MD
    Ratings:
    +276
    Current Phone Model:
    Galaxy S6
    Thanks, but still no luck there. I even opened the options to show system apps and there isn't an "Internet" option listed:

    Screenshot_20160905-112225.png
     
  7. Miller6386

    Miller6386 Developer
    Developer

    Joined:
    Oct 22, 2011
    Messages:
    2,280
    Likes Received:
    1,588
    Trophy Points:
    1,363
    Location:
    Beer Tent Capital of The World
    Ratings:
    +1,733
    Current Phone Model:
    Note 4
    Twitter:
    CoreyFMiller
    What is the exact model and carrier of your S6?

    Sent from my SM-N930V using Tapatalk
     
  8. IIGood

    IIGood Silver Member

    Joined:
    Jul 13, 2010
    Messages:
    699
    Likes Received:
    246
    Trophy Points:
    143
    Location:
    Arnold, MD
    Ratings:
    +276
    Current Phone Model:
    Galaxy S6
    SM-G920V on Verizon Wireless.