Car dock call audio

Discussion in 'Droid 3 Accessories' started by koftheworld, Dec 7, 2011.

  1. koftheworld
    Offline

    koftheworld Member

    Joined:
    Aug 17, 2010
    Messages:
    40
    Likes Received:
    0
    Trophy Points:
    6
    I have the oem car dock with usb audio, and whenever a call comes in it defaults to speakerphone instead of car stereo. Is there anyway to change the default setting? I've tried a few different dock apps and setting up tasker, but no luck. Anyone have any ideas? Thanks!

    Sent from my DROID3 using Tapatalk
  2. Riley
    Offline

    Riley New Member

    Joined:
    Dec 15, 2009
    Messages:
    585
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Upstate NY
    I'm not sure how to change it not to do that, but I've simply just gotten into the habit of when a call comes in I hit the speaker phone button quick and it takes it off speaker and routes it all through your cars audio system again. Not ideal though. I haven't looked through all the blur settings menus to see if its simply a box checked or what.
  3. pistacio
    Offline

    pistacio New Member

    Joined:
    Aug 26, 2010
    Messages:
    442
    Likes Received:
    5
    Trophy Points:
    0
    Location:
    MA
    ... in the habit of hitting speakerphone quickly also. It seems like this issue was overlooked by Motorola.

    EDIT: I may have found something. I will report tomorrow after using the car dock.

    Sent from my DROID3 using DroidForums App
    Last edited: Dec 8, 2011
  4. pistacio
    Offline

    pistacio New Member

    Joined:
    Aug 26, 2010
    Messages:
    442
    Likes Received:
    5
    Trophy Points:
    0
    Location:
    MA
    Didn't work. I tried setting a shortcut to " dock settings" activity with launcher pro, once opened, there is no option to disable speakerphone...

    Sent from my DROID3 using DroidForums App
  5. koftheworld
    Offline

    koftheworld Member

    Joined:
    Aug 17, 2010
    Messages:
    40
    Likes Received:
    0
    Trophy Points:
    6
    I tried using an app to turn off the dock completely.that part worked, but calls still defaulted to the speaker.it's gotta be the dock service or a setting that we can't see.

    Sent from my DROID3 using Tapatalk
  6. ScottyDsntKnow
    Offline

    ScottyDsntKnow New Member

    Joined:
    Nov 2, 2010
    Messages:
    390
    Likes Received:
    5
    Trophy Points:
    0
    IMHO, it is like that on purpose. I had my DX hooked up to my aux port and when I would be cranking music and a call would come in... 1 it would scare the chit out of me and 2 it would be ear splitting depending on how loud I was playing the music. I would much rather have my music cut out and the speaker phone ring giving me time to turn down my stereo and then hit the speaker button to put it back on the stereo at a more manageable volume. I actually stopped playing my music so loud with my DX just for this reason and if the D3 cuts to speaker when a call comes in, that is yet another reason for me to get it.

    Also, plz don't lecture me about playing music loud, I work around operating jet engines for a living and I have my hearing checked every year. I'm good to go.
  7. johnnyzero
    Offline

    johnnyzero New Member

    Joined:
    Jan 31, 2012
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    0
    I found a workaround for this...

    After much frustration & a lot of searching, I finally came across a very clever workaround for this issue in a Motorola Atrix-related forum. Cheers and many thanks to ACraigL (Andrew) for his original post.

    Here's how to get around it:

    1) Go to Android Marketplace and install an app called "Setting Profiles". The free Lite version will do the job.

    2) Run Setting Profiles on your phone.

    3) Create a new profile that turns off the speakerphone; call it "Speakerphone Off" or whatever. Hint: to create a profile that does this, clear all the checkboxes and all the green stars, then enable the green star for Speakerphone and make sure that checkbox is unchecked.

    4) Create a new Rule with the following two conditions: Docking State=car dock and Active Call. Next, use Add Tweak to add a 5-second Activation Delay (this is required so the phone doesn't override the Speakerphone Off setting). Finally, choose Add Action, Activate Profile, Speakerphone Off.

    Voila! All incoming and outgoing calls will now play through your car speakers via the Car Dock's audio out.

    Note: If you have trouble on your phone, try tweaking the delay time. The 5 second delay works flawlessly on my Bionic; the original poster said he ended up using 3 seconds for his Atrix.

    I hope this is helpful to other users.

    best,
    JohnB
    Last edited: Feb 19, 2012
  8. pistacio
    Offline

    pistacio New Member

    Joined:
    Aug 26, 2010
    Messages:
    442
    Likes Received:
    5
    Trophy Points:
    0
    Location:
    MA
    Thanks for the tip. I have it set up, along with a homescreen widget, just waiting till its in the dock to try it. Is it safe to leave the profile active ALWAYS, or should it only be switched on before docking? I just don't want any other phone functions and settings changed while this profile is active.

    Sent from:

    [ ] Droid 1 A855
    [ ] Droid 3 XT862
    [x] Xoom WiFi
  9. johnnyzero
    Offline

    johnnyzero New Member

    Joined:
    Jan 31, 2012
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    0
    If you read & follow the instructions in my post exactly, there's no need to create a homescreen widget or anything else. The Speakerphone Off profile will kick in automatically whenever your phone is docked and there's an active call. Also, if you create the profile exactly as described in my post (de-select all green stars except Speakerphone, make sure the Speakerphone checkbox is unchecked), it will disable the speakerphone and leave all other settings unchanged.

    Trust me - this works.
  10. pistacio
    Offline

    pistacio New Member

    Joined:
    Aug 26, 2010
    Messages:
    442
    Likes Received:
    5
    Trophy Points:
    0
    Location:
    MA
    Thanks for clarifying.

    Sent from:

    [ ] Droid 1 A855
    [ ] Droid 3 XT862
    [x] Xoom WiFi
  11. pistacio
    Offline

    pistacio New Member

    Joined:
    Aug 26, 2010
    Messages:
    442
    Likes Received:
    5
    Trophy Points:
    0
    Location:
    MA
    Confirming, this works on the Droid 3 perfectly with the 5 second delay. Thank you johnnyzero for posting here!


    Sent from:

    [ ] Droid 1 A855
    [ ] Droid 3 XT862
    [x] Xoom WiFi
  12. johnnyzero
    Offline

    johnnyzero New Member

    Joined:
    Jan 31, 2012
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    0
    Excellent!
  13. mrrdaniels
    Offline

    mrrdaniels New Member

    Joined:
    Apr 8, 2013
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    0
    ----------------------------------------------
    I have an HTC Desire - Clockwork Mod

    1) To enable / disable Cardock go to an empty screen where you can add
    icons/shortcuts
    2) Press the bottom "Menu" key
    3) Choose + (Add to Home)
    4) Choose "shortcut"
    5) Choose "settings"
    6) Choose "car dock"
    7) Press car dock
    8) check or uncheck car dock as you please

    Cheers

    Marty
Search tags for this page

android car dock audio out

,
android car dock volume
,
audio pelo usb cardock app
,

droid 3 call car speakers

,

droid 3 car dock audio

,
droid razr defaults to speaker phone in car dock
,
galaxy nexus car dock audio out
,
how to divert call to car spaker
,

is there a android car dock music through usb

,
mororola atrix car dock audio cm7
,
my droid3 will only work on spreaker phone
,
samsung car dock music and calls usb