Can't play music after reset on Galaxy Light

Discussion in 'Android Tech Support' started by Amby23, Mar 20, 2017.

  1. Amby23

    Amby23 New Member

    Joined:
    Mar 19, 2017
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Current Phone Model:
    Samsung Galaxy Light
    I reset my Galaxy Light T399N (running Android 44.2) because when an incoming call arrived, the .m4a ring tone -- which had been playing perfectly for years -- cut off after no more than 1 second, followed by silence.

    So I tried a hard reset followed by a Google auto-restore, but now none of my audio files (a mix of .m4a and Flac and mp3 files) would play at all! But it's not a hardware problem with the speaker or DAC, because all the pre-installed ring tones will play fine.

    Then I downloaded and ran a little tool called Media Codec Info, which reported that all those codecs (and more) were present. So why whenever I try to play any audio file, whatever player I'm using reports an error to the effect that it "can't play that kind of file"?

    The next thing I tried was performing another hard reset, then I re-flashed the exactly correct firmware (for Metro PCS) using Odin. And after that finished successfully, I did NOT allow the auto-restore, thinking that perhaps the earlier restore had included a glitch that kept the audio files from playing. Alas, that didn't work either -- I still can't play any mp3, m4a, or flac audio files (though for some reason .ogg files will play).

    What can I do to fix this?