can't mount Droid to PC after 2.2 OTA

Discussion in 'Android Support' started by realmike, Sep 3, 2010.

  1. realmike

    realmike New Member

    Joined:
    Nov 11, 2009
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    ever since the 2.2 was updated to my phone OTA, I can no longer mount the phone to pc via usb cable

    1 plug usb cable in to phone
    2 phone screen says "usb connected", PC beeps as it shoudl when I plug in a usb device
    3 press the buitton on phone "turn on usb storage"
    4 phone says "usb storage in use"
    5 PC starts autoplay (in some instances teh pc immediately opens a window showing folder tree on phone, but alwasy starts teh autoplay.
    6 autoplay finishes on pc. phone screen changes back to same screen as #2, i.e. the phone loses connection to PC. SD card icon appears in notification bar at top of phone, says "preparing sd card"
    if I try to pull down the notification bar, I get a force close message, I select wait
    in the meantime PC pops up a window - removable disk, choose your action, I pick "open folder to view files".
    8 PC says - "insert disk in to drive e"
    9 if I wait until phoen finishes prepping SD card and select "turn on usb storage," the whole priocess starts over again at #5

    before the 2.2 update, this was deadsimple brainless, plug and play. The phone screens and messages when mounting are different vs 2.1 (the word "mount" never appears, for example)
    same results on two different PCs running XP

    Any help is greatly appreciated
     
  2. Snoking

    Snoking Member

    Joined:
    Apr 25, 2010
    Messages:
    714
    Likes Received:
    10
    Trophy Points:
    18
    Ratings:
    +10
    Did you try a differ USB cable? Are you using the original USB cable. I bought some aftermarket USB cables that would charge the phone, however the data connection had a problem.

    Chris
     
  3. realmike

    realmike New Member

    Joined:
    Nov 11, 2009
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Chris, thanks, but I kinda doubt that it is the cable. At home PC, I use the oem cable that came with the droid. At office, I use a cable that came with a different (LG?) phone. Both worked fine prior to 2.2 update.

    Any other ideas out here? Help!
     
  4. VertoX7

    VertoX7 New Member

    Joined:
    Aug 26, 2010
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    I am having the same problem with mine. Also I get a thing that says Verizon Drivers and it says it's a cd-rom drive when I plug my phone in. If I wait forever it will eventually show the drives other removable drives.
     
  5. Dr. Carter

    Dr. Carter New Member

    Joined:
    Oct 2, 2010
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    It seems like of a lot people have had this problem with no real solutions! It has been a problem for me with 2.1 and now 2.2. I always take from the forums so I guess it is my turn to give back especially since this situation can be very frustrating!!! I hope this helps solve your issue as it has for me.
    So here we go…
    First off ignore the Verizon stuff that you now see since the 2.2 update it has nothing to do with anything. By the way it will always show up and never go away!

    Ok, your issue could be solved as easily as….
    1. Plug the USB cord into your phone and into the computer (with the phone On)
    2. In your phone menu click Settings> Connect to PC> select the radio button “Disk drive”> then Done (I would assume that the process on the Motorola is a similiar process)
    3. Now return to the home screen and Power Off the phone (keep the phone connected to the computer)
    4. Power the phone back on
    5. Hopefully that is it

    If not…
    You could have an issue with your USB drive assignments. This is particularly an issue with Windows XP but I run Vista and had this issue for some reason. Here is a brief description of what I am talking about. Your Windows operating system has a tool called Disk Management and it does exactly what it sounds like. It manages disk drives and assigns them drive letters whether those drives are physically attached storage (e.g. C: drive) or removable storage (e.g. a thumb drive or your phone.) Your phone should have two drives: One for the internal memory and one for the SD card. What will happen sometimes is that those drives letters have been assigned to another object such as a mapped drive and your phone is trying to access the same letter and it just won’t work. My problem was that I was only able to access the internal drive on the phone the first time. I could not access either of drives after the update. The steps above fixed that, but if this sounds more like your problem then let’s investigate.

    1. Plug the USB cord into your phone and into the computer (with the phone On)
    2. Then right click on My Computer and select Manage
    3. A window should open and It should say Computer Management at the top of the page
    4. In the left hand column click on Storage and then select Disk Management
    5. In the middle pane you should now see all of the available disks
    6. In the bottom portion of the middle pane you will see Disk 0 and so on…
    7. You are only concerned with the Disks labeled Removable
    8. Right click on each one and select Properties until you find which drives are for your phone. It should say in the title (e.g. HTC Android Phone USB Device) and make sure that it says “This device is working properly” Click Close

    Now that you know which drives are for your phone let’s assign new drive letters
    1. Right Click on the appropriate drives (one at a time of course)
    2. Select Change Drive Letters and Paths
    3. In the pop up window Click Change
    4. In the new pop up window select a new letter in the drop down menu ( You can use any of the letters in the list but I highly recommend that you use letters higher than “F”)
    5. Click Ok and a Warning will pop up but go ahead and click “Yes”
    6. Now on any blank portion of the middle pane click your mouse and then push the F5 function key to refresh the window and if everything is good the disks you selected should now report that they are online and healthy primary partitions

    That is it you should now be able to access your drives through My Computer like you used too!
    Good Luck





     
Search tags for this page

how to turn on usb storage android 2.2

,
htc incredible 2 can't open folder on computer