Can't flash new boot animation with Liberty 1.5

Discussion in 'Liberty ROM DX' started by Jaxidian, Feb 3, 2011.

  1. Jaxidian
    Offline

    Jaxidian Team FreeMyMoto Premium Member Developer

    Joined:
    Jun 26, 2010
    Messages:
    554
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Indianapolis
    Ratings:
    +0
    With Liberty 1.0, I was able to flash the stock "Android" boot animation from the Fission Rom Manager, which I understand is the standard way to update the boot animation. I have tried both via FRM and manually in Clockwork Recovery to flash new boot animations and it always fails. Messages read success but it still has the Liberty animation.

    What's going on here?

    Sent from my DROIDX using DroidForums App
     
  2. Trong
    Offline

    Trong Member

    Joined:
    Jul 29, 2010
    Messages:
    89
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0
    The bootanimation.zip is located under /data/data/local/, I believe. Fission's .zips will install to /system/media/

    Just manually paste your animation to the new location.
     
  3. Jaxidian
    Offline

    Jaxidian Team FreeMyMoto Premium Member Developer

    Joined:
    Jun 26, 2010
    Messages:
    554
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Indianapolis
    Ratings:
    +0
    Well, I looked and I don't think /data/data/local/ is right. But the Liberty Toolbox has the option to flash /sdcard/bootanimation.zip so I moved it to that location. After trying to flash it, I had a blank black screen as my boot animation.

    Upon further inspection, that Android_Boot_Animation.zip file actually had another file inside it (a couple directories deep) called bootanimation.zip. After extracting that zip file out of the other zip file and placing it at the location I mentioned above, it flashed successfully!

    Odd that the update.zip format didn't work but I guess this works good enough for me!