Can't eliminate a space before @ in mail

Discussion in 'Motorola Droid MAXX' started by sussertown, May 4, 2014.

  1. sussertown

    sussertown Member

    Joined:
    Sep 13, 2012
    Messages:
    31
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0
    When I type in an email address into a form the @ sign types with a space in front of it.
     
    #1 sussertown, May 4, 2014
    Last edited by a moderator: May 4, 2014
  2. Einsteindks

    Einsteindks Member

    Joined:
    Nov 20, 2011
    Messages:
    252
    Likes Received:
    11
    Trophy Points:
    18
    Ratings:
    +12
    Could be brushing the space bar? Or, if using auto-fill, it commonly puts a space after a word.

    fat-fingered and Maxx-ed out.
     
  3. mslaceyrose

    mslaceyrose Active Member

    Joined:
    Apr 12, 2014
    Messages:
    215
    Likes Received:
    74
    Trophy Points:
    28
    Location:
    Eastern USA
    Ratings:
    +74
    Or, if you tell us which keyboard app are you using (the stock one, or one that you installed) we could find out if there are any known bugs causing the issue. I know SwiftKey had a bug one time where a space would always be inserted between the dot (.)and 'com' when typing an email address, regardless of settings.
     
  4. sussertown

    sussertown Member

    Joined:
    Sep 13, 2012
    Messages:
    31
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0
    Neither is correct. This is an ongoing problem and the reason for the post.
     
  5. sussertown

    sussertown Member

    Joined:
    Sep 13, 2012
    Messages:
    31
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0
    I'm using the on board keyboard.
     
  6. leeshor

    leeshor Gold Member

    Joined:
    Jan 30, 2012
    Messages:
    4,363
    Likes Received:
    1,437
    Trophy Points:
    358
    Location:
    Norcross, GA - USA
    Ratings:
    +1,676
    I'm going to add to your title of "@" so more people may be able to understand the problem.
     
    #6 leeshor, May 4, 2014
    Last edited: May 4, 2014
  7. mslaceyrose

    mslaceyrose Active Member

    Joined:
    Apr 12, 2014
    Messages:
    215
    Likes Received:
    74
    Trophy Points:
    28
    Location:
    Eastern USA
    Ratings:
    +74
    I didn't find anything about the problem on an initial search. Which android version are you currently on? Did this problem just start happening, or did it start after an update?
     
  8. doogald

    doogald Active Member

    Joined:
    Oct 27, 2011
    Messages:
    431
    Likes Received:
    42
    Trophy Points:
    28
    Ratings:
    +42
    I just tested this with my Droid Maxx and the stock keyboard. It did not insert a space before the "@". Is this happening to you after certain typed phrases? I know that the keyboard does some predictive replacements - maybe this particular phrase is in your on-board dictionary?

    You can check the personal dictionary. From home, settings, language and input. Tap the control icon next to "Google keyboard", it's the first entry under "TEXT CORRECTION". If you have something in there that you don't want, you can remove it. Or, if it's not that, maybe it's the auto-correction; try setting that to "none" and see if the problem goes away. Or, if it's not that, under "Advanced settings", try turning off "Suggest contact names".

    (FWIW, I use Swiftkey myself, and that stupid space after the period and before something like "com" keeps happening in almost every app. Swiftkey does sometimes sense that you are typing a URL or email address and will not do the replacement, but if I am trying to type somebody's email address in the body of a mail message, it's always period, backspace, com. It drives me crazy; I'm quite happy hitting the space myself when I want it. Too bad the stock keyboard isn't better.)
     
  9. Jeffrey

    Jeffrey Premium Member
    Premium Member

    Joined:
    Jan 30, 2012
    Messages:
    6,686
    Likes Received:
    3,548
    Trophy Points:
    1,578
    Location:
    Thailand
    Ratings:
    +4,036
    Current Phone Model:
    iPhone 7 Plus JB
    Looks like you have some options to check. Let us know if it gets resolved.
     
  10. sussertown

    sussertown Member

    Joined:
    Sep 13, 2012
    Messages:
    31
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0
    I'll check the dictionary. This does not occur in the address bar.


    QUOTE=doogald;2523987]I just tested this with my Droid Maxx and the stock keyboard. It did not insert a space before the "@". Is this happening to you after certain typed phrases? I know that the keyboard does some predictive replacements - maybe this particular phrase is in your on-board dictionary?

    You can check the personal dictionary. From home, settings, language and input. Tap the control icon next to "Google keyboard", it's the first entry under "TEXT CORRECTION". If you have something in there that you don't want, you can remove it. Or, if it's not that, maybe it's the auto-correction; try setting that to "none" and see if the problem goes away. Or, if it's not that, under "Advanced settings", try turning off "Suggest contact names".

    (FWIW, I use Swiftkey myself, and that stupid space after the period and before something like "com" keeps happening in almost every app. Swiftkey does sometimes sense that you are typing a URL or email address and will not do the replacement, but if I am trying to type somebody's email address in the body of a mail message, it's always period, backspace, com. It drives me crazy; I'm quite happy hitting the space myself when I want it. Too bad the stock keyboard isn't better.)[/QUOTE]
     
  11. doogald

    doogald Active Member

    Joined:
    Oct 27, 2011
    Messages:
    431
    Likes Received:
    42
    Trophy Points:
    28
    Ratings:
    +42
    Yes, I probably should have been more clear. I tried it in a few locations - within a note in Google Keep, typing the address in the address bar of a mail message in Gmail, and within the body of a mail message, as if you wanted to send somebody's email address within an email. It never put the space before the "@" in any of those cases on my phone.