Cannot connect new SIII to home router (linksys wrt54g)

Discussion in 'Samsung Galaxy S3' started by bar99, Jul 29, 2012.

  1. bar99
    Offline

    bar99 New Member

    Joined:
    Jul 29, 2012
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    I am new to the world of smartphones. I have a new Galaxy SIII. It is a remarkable device and I like it. I am able to connect wi-fi to other networks but at home, I cannot land a wi-fi connection my router. It is an older model linksys wrt54g. I have upgraded the firmware. No luck. Did a reset. No luck. I have tried numerous configurations and I cannot connect at home. It's kind of important in that I want to keep my 4G data usage down and I would rather not have to go out and buy a new router. I have to believe that I am not the only person out there with this issue. Has anyone else had this problem? Any tips on how I should proceed? Thanks.
  2. ittybitty
    Offline

    ittybitty New Member

    Joined:
    Aug 5, 2012
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Galaxy SIII Home Wi-Fi Connection

    I was having this same problem and found out that all I needed to do was disable the MAC address list and it connected immediately. Have you tried disabling that feature in your router?
  3. Caesars
    Offline

    Caesars Senior Member

    Joined:
    Feb 16, 2012
    Messages:
    1,218
    Likes Received:
    44
    Trophy Points:
    48
    Ratings:
    +44
    Aye if you're using a Mac filter, disable :).

    Googorola MAXX
  4. jimk75
    Offline

    jimk75 New Member

    Joined:
    Apr 22, 2011
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    wirreless trouble

    i had this problem. i also tried to use the push button WEP. It would not connect. I had to do it manually with WEP PIN. Go to your network adapter on your computer and check the box to see the characters in your key. enter it in the phone and it should be okay.
  5. reybie
    Offline

    reybie Member

    Joined:
    Jan 9, 2010
    Messages:
    269
    Likes Received:
    8
    Trophy Points:
    18
    Ratings:
    +8
    Also check wpa and wpa2, some have trouble with wpa2.
  6. Valvoline
    Offline

    Valvoline Member

    Joined:
    Jul 18, 2010
    Messages:
    173
    Likes Received:
    10
    Trophy Points:
    18
    Ratings:
    +10
    i have this old router also. my connection is fine, however the router is suck. needs a reboot every few days or so.
  7. LeonBlurry
    Offline

    LeonBlurry New Member

    Joined:
    Nov 21, 2013
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    You should disable the Media Access Control (MAC) address and see if that works. If problem persists then I suggest you contact to Linksys Router Technical Support. I had issues with opening websites with my wifi router. They helped me by telling me to reduce the MTU values in multiples of 10. That helped me. I had wasted many days to solve that issue.
Search tags for this page
configure linksys wrt54g smartphone
,
connect samsungs3 to linksys
,
connecting my galaxy s3 to my wifi verizon router
,

galaxy s iii cannot link linksys router

,
galaxy s2 wifi linksys wrt54gs
,
galaxy s3 linksys
,

linksys wrt54g android

,

linksys wrt54g samsung galaxy

,

samsung galaxy s3 linksys

,
samsung s3 wrt54g