Camera problems? SOLVED!

Discussion in 'Liberty ROM DX' started by Je11yman, Feb 16, 2011.

  1. Je11yman
    Offline

    Je11yman New Member

    Joined:
    Feb 14, 2011
    Messages:
    24
    Likes Received:
    0
    Trophy Points:
    0
    OK, I have to admit, I spent a lot of time on this trying to figure it out, and in the end it was my own stupidity. However, seeing all the people with the same issues on this forum, I don't feel so bad. And I think I know how we can stop this from being and issue again in the future!

    So I had the same thing all the other camera problem people had: frozen camera apps, no working video camera, corrupted picture data, etc. Nothing worked to fix it. No setting could be tweaked, no amount of flashing to stock and back to Liberty worked, etc.

    Until I calmed down and started checking the details again.

    I decided to check the MD5 checksums of my files again. The checksum was fine for everything, except my Liberty 1.5 rom! "Ah-ha" I thought. "It was a corrupted download!" So I looked closer.

    Stupidity.

    I had not checked the MD5 when I first downloaded, and if I had I would have caught this. I had mistakenly clicked on the D2 rom, not the DX rom, and never noticed my mistake!!! I remember at the time I had been looking for the fastest download, so I had been clicking a few links and then killing the slow ones until I had a fast download going. In my clicking madness I must have clicked a "D2" link by mistake!

    I downloaded the correct ROM file (LibertyX 1.5) and re-flashed. Camera works flawlessly.

    I propose that in the sticky link we move the DX and the D2 links farther apart. If I was the only one with this problem I would just stick my tail between my legs and go back to being a newb, but I am not. If you have this problem, I encourage you to re-download the LibertyX 1.5 ROM (even if you are sure you got the right one in the first place) and check the MD5 hash. Then, post here and let us know if your problems are solved!