Camera broken after 2.2

Discussion in 'Android Support' started by Arakaine, Aug 24, 2010.

  1. Arakaine

    Arakaine New Member

    Joined:
    Aug 21, 2010
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    NJ
    Ratings:
    +0
    The default camera app works on my Droid 1 (turns on, snaps the picture) but whenever I try to view my pictures in the Gallery, the pictures are a gray/black square amidst my other perfectly normal pre-2.2 thumbnails. If I click on it, it loads and loads, then the phone goes idle until I hit the Home button or go to a picture I took before 2.2. I tried to send the picture via Messaging but it crashed the SMS each and every time; I had to Force Close every attempt. Yet the pictures I took prior to 2.2 show up perfectly fine in the Gallery, load instantly and I can send those via texting with no problems.

    This is kind of annoying since I already did a factory reset twice and it didn't do anything but wipe all my saved games. :eek: Anyone have any suggestions?
     
  2. shocka2430

    shocka2430 Member

    Joined:
    Mar 20, 2010
    Messages:
    530
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    Having similar trouble I've formatted everything sys, data,sdcsrd,cache,boot everything and still nothing.

    Sent from my Droid using Tapatalk
     
  3. kseeholzer

    kseeholzer New Member

    Joined:
    Apr 1, 2010
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Camera forces close after 2.2

    My camera app won't even open...it forces a close as soon as I try to run it. The error I receive is "The application Camera (process com.google.android.camera) has stopped working unexpectedly. Please try again." with the the option to Force close or Report. When I try to report, my phone freezes and I have to remove the battery to reboot.
     
  4. Arakaine

    Arakaine New Member

    Joined:
    Aug 21, 2010
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    NJ
    Ratings:
    +0
    lol at least it blocks you out before giving you a false sense of hope that your pictures are being saved. lost all my birthday pics from yesterday because the pics were corrupted or whatever.
     
  5. shocka2430

    shocka2430 Member

    Joined:
    Mar 20, 2010
    Messages:
    530
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    Know how ya feel bud had my baby girl yesterday and couldn't take one freaking picture with the thing.

    Sent from my Droid using Tapatalk
     
  6. Arakaine

    Arakaine New Member

    Joined:
    Aug 21, 2010
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    NJ
    Ratings:
    +0
    Alright I did a third reset and it works now. Before I did the third reset, I unchecked the Restore & Backup stuff in the Privacy settings. I guess it kept restoring the corrupted file for my Camera but it works now. Now I'll have to reinstall all my apps from scratch but that's a small price to pay.
     
  7. shocka2430

    shocka2430 Member

    Joined:
    Mar 20, 2010
    Messages:
    530
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    Did you do the factory reset on the phone or from recovery? I tried to wipe it all from recovery after turning the backup and stuff off but it still dont work.
     
  8. Arakaine

    Arakaine New Member

    Joined:
    Aug 21, 2010
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    NJ
    Ratings:
    +0
    Well, I thought I fixed it but apparently not. The goddamn phone keeps reverting back to my old settings despite me unchecking everything. I'll uncheck everything in the Privacy settings before wiping, wipe, and uncheck everything again. At that point, the camera works and I can take pictures just fine. Then I'll install one app and suddenly all the old apps I had are back on my phone, with the settings I had previously. This is pissing me off because there's a corrupted file somewhere in my previous settings and the damn phone keeps reloading it despite me telling it not to.

    edit: I've literally done 9 wipes already and the settings keep coming back as soon as I install one app even if I uncheck everything pre- and post-wipe before I touch the market. good times.
     
  9. JimmyD

    JimmyD Member

    Joined:
    Jan 14, 2010
    Messages:
    478
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    Wiping your phone won't tell your Google account (which is tied to the Market) that you don't want those apps back!

    Go into your market on your phone, then UNINSTALL the apps you don't want.
     
  10. Arakaine

    Arakaine New Member

    Joined:
    Aug 21, 2010
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    NJ
    Ratings:
    +0
    Doesn't matter what I do, every app is restored once I start accessing the Market screen. I was told ASTRO makes a backup file on my SD card that might possibly be reloading all my settings/apps but I can't find it, I was going to cut it from my SD card and paste it onto my computer.
     
Search tags for this page

camera has stopped unexpectedly need to restart