Camera and WiFi troubles with 8/30 revnumbers build ..

Discussion in 'Cyanogenmod - D2' started by roboots21, Sep 1, 2011.

  1. roboots21
    Offline

    roboots21 Member

    Joined:
    Sep 21, 2010
    Messages:
    152
    Likes Received:
    2
    Trophy Points:
    18
    I recently updated to Revnumbers latest 8/30 build along with Jakebites mods. My Camera app opens, but freezes instantly. Viewfinder still works, but I get an option to Wait of FC after about 10 seconds. Also, my wifi seems to be having issues. I haven't been able to connect to either my home network nor my work network since yesterday when I flashed the new build. Any ideas?? Thanks in advance.
  2. havens1515
    Offline

    havens1515 Member

    Joined:
    Jan 8, 2011
    Messages:
    613
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Rochester, NY
    Here's a few things to try:

    1) If you just flashed and haven't yet rebooted, reboot.
    2) Wipe cache and dalvik cache in recovery
    3) Re-flash the ROM without wiping data
    4) and lastly, wipe data

    Try each of these separately, and if it doesn't work move on to the next one. Let us know if anything works.
  3. roboots21
    Offline

    roboots21 Member

    Joined:
    Sep 21, 2010
    Messages:
    152
    Likes Received:
    2
    Trophy Points:
    18
    1) I had rebooted, and it actually worked before I rebooted (wifi) .. camera has not worked since 8/28 build when I used camcorder.
    3) I consider the update to 8/30 without wiping data the 'reflash', no go.
    2) I will try to wipe data and dalvik again and see what that gets me.
    4) Last resort I will wipe data and fresh install ..
  4. havens1515
    Offline

    havens1515 Member

    Joined:
    Jan 8, 2011
    Messages:
    613
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Rochester, NY
    updating to 8/30 is not a reflash. I say reflash because something may have gone wrong when you flashed the new nightly. I have seen it happen to people in the past. It's worth a try, only takes a minute.
  5. roboots21
    Offline

    roboots21 Member

    Joined:
    Sep 21, 2010
    Messages:
    152
    Likes Received:
    2
    Trophy Points:
    18
    I will give it a try .. If I get to the point of wiping data i will probably just SBF using the TBH app and then come from there to CM7GB. Thanks for the help!
  6. roboots21
    Offline

    roboots21 Member

    Joined:
    Sep 21, 2010
    Messages:
    152
    Likes Received:
    2
    Trophy Points:
    18
    So, I SBF'd back to Froyo, took the OTA, camera worked fine. Installed Rev's latest build (8/30) with full cache/data/dalvik wipe, and the camera still freezes. You open the app, hear the camera do it's noises (the tick tick tick), then it just freezes. You can still use the viewfinder but nothing can be pushed and after about 10 seconds, prompt for FC or Wait. GRRRRR .. gonna try the MIUI camera..but other than that I don't know.
  7. roboots21
    Offline

    roboots21 Member

    Joined:
    Sep 21, 2010
    Messages:
    152
    Likes Received:
    2
    Trophy Points:
    18
    Update: Formatted my SD Card and camera works now .. must have been a bad block or something where the pictures are stored using the default camera. All is well now. Just wanted to update the thread in case anyone runs into similar issues :)