Broken Gallery with 2.2....

Discussion in 'Droid X Tech Support' started by _eljayel, Oct 2, 2010.

  1. _eljayel

    _eljayel New Member

    Joined:
    Oct 1, 2010
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    virginia.
    Ratings:
    +0
    I've been searching for this answer for a while now and I've given up and decided to make a new post...

    I have a DX with 2.2. My gallery is DEAD. When I open it, it closes. It wouldn't even let me LOOK at anything (I found a lot of posts saying people's galleries would close while browsing but mine won't even let me do that).

    It's been doing this since last night. I installed .nomedia into my icon folder because I didn't want the gallery clogged up..... Then the gallery died.

    I've deleted all of the .nomedia files I made (I searched the SD card and see there are .nomedia files in other folders for apps) and also deleted ALL of my photos (saved on my laptop of course)

    I took a photo with the camera to see if it would work and it still closes as soon as I open it. It doesn't say anything about force closing, it just closes.

    I've also battery pulled.

    Please send help :(
     
  2. sephtin

    sephtin Senior Member

    Joined:
    Aug 20, 2010
    Messages:
    1,807
    Likes Received:
    0
    Trophy Points:
    66
    Ratings:
    +0
    Couple suggestions/things to try:

    First, backup all your photos.

    Then, clear data/cache for Gallery app:
    Settings>applications>manage applications>menu button>filter>all>gallery>clear data and clear cache.
    I believe this removes all photos (??). Does it fix the problem?

    If it doesn't remove the photos, and the problem is still there, then I suggest you remove all photos from the gallery and see if it still crashes.

    If that fixes the problem, it could be one (or some) photos causing the problem.. you can even put them back a few at a time until it start happening again, and determine which photos are causing the problem (?)..

    GL!
     
  3. _eljayel

    _eljayel New Member

    Joined:
    Oct 1, 2010
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    virginia.
    Ratings:
    +0
    aww.. I'd already done that lol I saw that suggestion on another thread that had a similar problem.

    I ended up taking it in to Verizon and the rep reset my phone back to factory.... HE blamed it on Launcher Pro..... Something about some apps don't work with 2.2. I'd just upgraded to Plus when the gallery stopped working, I don't know if it was a coincidence or not but now I'm very wary of putting the code back in.

    Do you think it was LP?

    Thank you for your suggestion by the way :)
     
  4. sephtin

    sephtin Senior Member

    Joined:
    Aug 20, 2010
    Messages:
    1,807
    Likes Received:
    0
    Trophy Points:
    66
    Ratings:
    +0
    YVW!

    Very unlikely it was LP. Possible, but very unlikely.
    Easy way to find out... just install LP, and test, right? ;)
     
  5. _eljayel

    _eljayel New Member

    Joined:
    Oct 1, 2010
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    virginia.
    Ratings:
    +0
    LOL I'm unlocking it now.... cross your fingers!

    I've been using the basic version for on the clean X for about a day now... He was a hatin' on my eBay case too....
     
  6. sephtin

    sephtin Senior Member

    Joined:
    Aug 20, 2010
    Messages:
    1,807
    Likes Received:
    0
    Trophy Points:
    66
    Ratings:
    +0
    Really? Those crazy VZW reps...
    Should have asked him for a copy of the 2.2 .sbf file.. tell him it'd save lots of people from coming back to him for help. ;)

    GL! Let us know if it causes the problem again...
     
  7. BMWBig6

    BMWBig6 Member

    Joined:
    Aug 4, 2010
    Messages:
    71
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0
    I'm having the exact same problem, but I don't dare take my phone back to Verizon and I'm trying to avoid a factory reset if possible. My cause was exactly the same as the OP's: I added some .nomedia files to my SD card (to hide album art from showing up in Gallery), and that's when Gallery refused to open. It just immediately closes/disappears anytime I try and open Gallery.

    Here's what I tried so far:

    Nope, problem still persists. I tried to do it again, and now the Clear Data and Clear Cache buttons are both grayed out.

    I removed the files under: SD Card\Android\data\com.android.providers.media\albumthumbs

    I removed SD Card\DCIM\.thumbnails directory

    I manually deleted the DCIM folder, and snapped a couple test photos to force the recreation of the DCIM folder. I can view Camera Roll from the camera app, but Gallery still refuses to open.

    I have also booted to recovery mode and noticed the following error: "E: Can't open /cache/recovery/command"

    From recovery, I used the "Wipe cache partition" utility, rebooted, and Gallery still won't open.

    What else can I try?
     
  8. sephtin

    sephtin Senior Member

    Joined:
    Aug 20, 2010
    Messages:
    1,807
    Likes Received:
    0
    Trophy Points:
    66
    Ratings:
    +0
    Drawing a blank, I wish I knew more about exactly what files/cache/etc. are used for Gallery. :(

    My only other initial thought.. is maybe try another gallery app, and see if you can get in, and see what's showing up there to help troubleshoot.. something like 3d gallery perhaps?
    3D Gallery - Android app on AppBrain

    Maybe if that will open, you could see what's showing up, and/or maybe remove anything that might be sticking around causing the problem?

    I DO know that gallery keeps files in other places.. I've done the same thing, removing files from DCIM, removing DCIM dir, etc., ... and my phone is finding a cache directory with 71 blank images from somplace. And it won't let me delete them via gallery. :S Heck, maybe I'll try 3d gallery myself to see if it'll let me remove them .. heh.

    Either way, if I figure something out, I'll post... Please do the same if something changes! GL!
     
  9. BMWBig6

    BMWBig6 Member

    Joined:
    Aug 4, 2010
    Messages:
    71
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0
    3rd party app "3D Gallery" loads fine, but it finds 42 blank images in an unnamed directory (there is no label so I assume it's unnamed). When I browse that collection, I see dates going back to August. Maybe that is a clue?
     
  10. BMWBig6

    BMWBig6 Member

    Joined:
    Aug 4, 2010
    Messages:
    71
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0
    OMG, that fixed it! I installed 3D Gallery, opened and deleted those 42 mystery files, and on a whim went back to the stock Android Gallery app and it magically resumed working again! THANK YOU SEPHTIN!
     
  11. sephtin

    sephtin Senior Member

    Joined:
    Aug 20, 2010
    Messages:
    1,807
    Likes Received:
    0
    Trophy Points:
    66
    Ratings:
    +0
    awesome!

    On a side note: the 71 pics that were listed in a "cache" folder, but didn't actually pull up pictures.. couldn't do anything with them from Gallery, but 3D gallery let me delete them.. all cleaned up now. :p

    Glad it helped! :)
     
Search tags for this page

andriod broken photo links gallery

,

android broken images

,

android broken picture icon

,

android phones broken images wont delete

,

broken images on droid

,

droid dock broken gallery

,

how to delete broken image icons in photo gallery

,

how to delete broken photos android

,

pictures is black with cracked white image android forums

,

what is a broken picture symbol on my android