Bluetooth Issue

Discussion in 'ChevyNo1' started by cjlawson, Mar 21, 2010.

  1. cjlawson
    Offline

    cjlawson New Member

    Joined:
    Mar 2, 2010
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    0
    First of all Chevy you are the man. I have tried almost all of the roms out there from Black Droid to Smoke Glass. Yours is certainly my favorite.

    I have just one issue. My bluetooth headphones disconnect from the phone quite often. It is quick and easy to fix. However it is a little annoying.

    Questions:
    Is any one else experiencing this?
    If so what bluetooth device are you using?
  2. myz06vette
    Offline

    myz06vette New Member

    Joined:
    Feb 3, 2010
    Messages:
    90
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Wichita, KS
    First all, welcome (officially) to Droid Forums. I saw this was your first post.. which tells me you were a lurker.. just like me before I finally decided to start posting. I think a lot of people are that way though. But, welcome. Hope you'll join us more.

    I've had a couple issues that I've related to bluetooth, but can't single it out as the only culprit. My problem is mostly when I'm in the car.. I have the phone plugged in charging and I'm streaming my music (or gps instructions or phone calls) to my Motorola T505.. I don't have problems with it disconnecting really at all, but the phone has been restarting a lot lately in those conditions. It's not getting any hotter than usual... but the music will pause for half a second, then play again for another second, then the phone freezes and 10 seconds later it reboots. I tried slowing the phone down to 1.0ghz (from 1.25ghz) and no changes. It has always worked before... just started doing this within the last few days. And it only seems to happen when I've got bluetooth turned on and active.
  3. BayouFlyFisher
    Offline

    BayouFlyFisher Rescue Squad Rescue Squad

    Joined:
    Dec 10, 2009
    Messages:
    4,966
    Likes Received:
    17
    Trophy Points:
    38
    Location:
    Baton Rouge, LA
    Just adding a data point: I used my bluetooth earbuds (Sony DR-BT100CX) for a couple of hours yesterday with no disconnects.
  4. lores35
    Offline

    lores35 New Member

    Joined:
    Dec 26, 2009
    Messages:
    125
    Likes Received:
    0
    Trophy Points:
    0
    I am experiencing the same issue. Music stops, comes back on, stops again and the phone reboots. I am using the Motorola blue tooth headset. Also noticed the headset turns off when all this happens.
  5. ChevyNo1
    Offline

    ChevyNo1 Premium Member Premium Member Developer

    Joined:
    Dec 28, 2009
    Messages:
    5,354
    Likes Received:
    5
    Trophy Points:
    0
    Everyone, if you are having issues with BT and Music - does this happen with other ROMs? With any of my older ROMs?
  6. lores35
    Offline

    lores35 New Member

    Joined:
    Dec 26, 2009
    Messages:
    125
    Likes Received:
    0
    Trophy Points:
    0
    Just started happening with latest SS. Have not tried other ROMs.
  7. BayouFlyFisher
    Offline

    BayouFlyFisher Rescue Squad Rescue Squad

    Joined:
    Dec 10, 2009
    Messages:
    4,966
    Likes Received:
    17
    Trophy Points:
    38
    Location:
    Baton Rouge, LA
    Just a data point: I've did not have it with 2.02 and I've not had it with 2.03. I use a Sony Bluetooth earbud set and I use MixZing for my music player.
  8. myz06vette
    Offline

    myz06vette New Member

    Joined:
    Feb 3, 2010
    Messages:
    90
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Wichita, KS
    Didn't see it happening back when I was using Sholes Mod.. haven't used any other ROMs though since your SS v1.0.3. And, for that matter, haven't seen it happen in any previous versions. Just started happening. At first I thought I had it isolated to when the phone was charging. But it has done it a few times without being plugged in.

    Also, my Gallery is useless - get a force close loop every time I open it.. com.cooliris.media. Tried searching that and found a thread on google forums about it. No real solution given. Tried deleting SD card/android/data/cooliris.media (i think thats the right path). No success. Tried removing/replacing sd card.. battery pull restart.. another sd card.. can't get it to stay open for anything. Grabbed a screen shot of this attached below.

    And in my Messaging inbox... after each person's name for a thread, it shows how many messages have been sent/received.. like "John Smith (157)" - mine maxes out now at 200 messages. I think its actually saving more messages than that in the thread, but the message counter isn't going past 200. And occasionally, when I open a new text message to reply, when I click on the text field to enter text, it doesn't bring up the keyboard.. have to go back to home and relaunch Messaging, then try again. Works 99% of the time after that.

    And lastly, occasionally I'm also getting a half keyboard in portrait mode. Got a screen shot posted. Tried rotating to landscape - I can see full keyboard then.. back to portrait, goes back to half the keyboard visible. Only happening a few times.. each time had to do battery pull to fix.

    Weird thing is, all these things just started happening within the last week. Like they came out of nowhere. I've been running v2.0.3 since the day you released it and it worked great for several days (doing the same things). Was trying to isolate problem down to any newly installed apps... but just can't eliminate any of these issues.
  9. cjlawson
    Offline

    cjlawson New Member

    Joined:
    Mar 2, 2010
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    0
    Other Roms

    I had extensive use with DroidMod with out the issue.
  10. cjlawson
    Offline

    cjlawson New Member

    Joined:
    Mar 2, 2010
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    0
    Update!!!

    Just an update for anyone who cares. I tried several other roms bases on the latest builds. Black Droid, and Adam's.

    I had the same problem with my bluetooth headphones.

    I have now switched back to Droid Mod and all my problems have gone away.
  11. pullmehome
    Offline

    pullmehome New Member

    Joined:
    Mar 13, 2010
    Messages:
    60
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    cincinnati, oh
    Using blutooth now at work listening to pandora no /issues thus far ill be tedting for the next few hours or until bt dies ill post my redults when I get home
  12. trowa
    Offline

    trowa New Member

    Joined:
    Feb 10, 2010
    Messages:
    152
    Likes Received:
    0
    Trophy Points:
    0
    I just wanted to note I had a bluetooth issue today. I am running simply stunning 2.0.3. I had my phone mounted to my computer copying files. I got a phone call but missed it. Since I was still copying data I just turned on bluetooth to use my headset. Well I changed my mind and used my work phone to make the call. I turned off bluetooth and screen instantly went black. After a few seconds it stopped copying data and the phone rebooted. Other then this time I have had no issues with bluetooth. I normally turn on my moto bt stereo headphones and listen to mp3s all day long at work. It never disconnects or crashes.
  13. trowa
    Offline

    trowa New Member

    Joined:
    Feb 10, 2010
    Messages:
    152
    Likes Received:
    0
    Trophy Points:
    0
    I never had this happen before I upgraded to SS 2.2

    Another update which I could not reproduce. FYI I am using Motorola HT820 bluetooth headphones. I was listening to mp3s with the stock music player not connected to my phone dock and I am able to pause and play my music by pressing the right button. When I put my phone on the multimedia dock it loads clock. I am unable then to use the right button to play and pause music. I take phone off the dock and I can use the button again.

    So I rebooted phone. Now when I put my phone into my dock after everything loaded Clock gave me a force close. But the play and pause button works in the phone dock. And after going to the home screen and back to the clock everything functions normally.

    Weird issues but I still love the rom. ChevyNo1 thanks for all the hard work. I will be donating you some beer money this weekend. 12 pack on me this time :icon_ banana:
  14. ChevyNo1
    Offline

    ChevyNo1 Premium Member Premium Member Developer

    Joined:
    Dec 28, 2009
    Messages:
    5,354
    Likes Received:
    5
    Trophy Points:
    0
    So just rebooting caused different behavior? Have you rebooted again to see if it's the same?

    Thanks!! :)
  15. trowa
    Offline

    trowa New Member

    Joined:
    Feb 10, 2010
    Messages:
    152
    Likes Received:
    0
    Trophy Points:
    0
    Yes it seems a reboot seems to fix so far. I can't reproduce anything other then the music display in notifications. But using another music program like mort player music are fine with display in notifications.

    Oh and check your paypal account. :)
  16. hughesjr
    Offline

    hughesjr New Member

    Joined:
    Dec 11, 2009
    Messages:
    277
    Likes Received:
    0
    Trophy Points:
    0
    I have a motorola S305 headset. I have noticed that when using bluetooth on wifi, I do not get the same download speed I get with bluetooth off. This is not only on this ROM, but any kernel combo I try.
    Last edited: Mar 29, 2010
  17. cjlawson
    Offline

    cjlawson New Member

    Joined:
    Mar 2, 2010
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    0
    Update

    Chevy,

    I tried your newest rom yesterday. I still experience the bluetooth issues with it.

    I will try and clarify some things for you. I can listen to music through the bluetooth no problem it won't disconnect at all. It seems that once it is connected it stays connected.
    The issue comes up when I make a call. If I then hang up and try to make another call right away the bluetooth doesn't connect. Once this happens I have to disconnect and then reconnect. I also experience the issue if there hasn't been any bluetooth activity for a while. The phone will ring but the bluetooth acts as if its disconnected.

    I do not have any issues at all using droidmod. I would prefer to use your roms as my phone runs super smooth and less FC than using droidmod.

    P.S. I did experience a random reboot using the latest rom yesterday.
Search tags for this page
fix for galaxy s4 bluetooth disconnect
,

how to pair sony dr bt100cx to my rezound

,
mbluetooth issues with msg and chubbz rom