Battery

Discussion in 'Samsung Galaxy Nexus' started by lagos777, Jan 19, 2012.

  1. lagos777

    lagos777 New Member

    Joined:
    May 29, 2010
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    I'm experiencing major battery issues with this phone. The Bettery runs our in 2-3 hours and when i checked usage it's like 40% exchange services. emial reads 5%. I can't find the specific program doing it .
     
  2. dezymond

    dezymond Tech Support Mod
    Staff Member Premium Member

    Joined:
    Nov 11, 2009
    Messages:
    12,077
    Likes Received:
    1,503
    Trophy Points:
    573
    Location:
    Bay Area, California
    Ratings:
    +1,667
    Current Phone Model:
    Google Pixel
    Turn off anything automatic. Make sure to use wifi when in the area. I also recommend you check out apps such as Tasker.

    Also are you in a strong 4g signal area? If not, the phone constantly searching for a signal will definitely take a toll on your battery. There's also the "Android OS" awake time bug. Check your awake time and make sure it isn't too long. The bug is even though you see the screen turn off, it's not really running like it's off/in standby mode.
     
  3. whatuseekisfire

    Joined:
    Nov 21, 2011
    Messages:
    203
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    What do you mean that the awake time is too long?

    Sent from my Galaxy Nexus using DroidForums
     
  4. dezymond

    dezymond Tech Support Mod
    Staff Member Premium Member

    Joined:
    Nov 11, 2009
    Messages:
    12,077
    Likes Received:
    1,503
    Trophy Points:
    573
    Location:
    Bay Area, California
    Ratings:
    +1,667
    Current Phone Model:
    Google Pixel
    Your "keep awake" time.

    Settings --> Battery --> Android OS --> check "keep awake" time
     
  5. whatuseekisfire

    Joined:
    Nov 21, 2011
    Messages:
    203
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0

    Yeah I know but what's to long to you? Cuz mines is at 17%..should it be lower than that?
    Sent from my Galaxy Nexus using DroidForums
     
  6. awsolot

    awsolot Member

    Joined:
    Dec 31, 2009
    Messages:
    150
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    yes can u explain the keep awake time bug a bit more. thank you
     
  7. BayouFlyFisher

    BayouFlyFisher Rescue Squad
    Rescue Squad

    Joined:
    Dec 10, 2009
    Messages:
    4,958
    Likes Received:
    17
    Trophy Points:
    168
    Location:
    Baton Rouge, LA
    Ratings:
    +17
    As noted in a lot threads on a lot of forums, there are some phones that have a problem with the Android OS and the "Keep Awake" time. There seems to be an issue with some phones not truly going to sleep when the power button is used to turn off the screen as opposed to letting the screen turn off automatically when the screen times out. This results in a very high time in the Settings/Battery/Android OS/Keep Awake menu.

    In stock form and with every rom that I have installed, my "Keep Awake" time was always about 50-60% of my total battery time. If the phone had been off charger for 8 hours, I'd have 4-6 hours of Andorid OS "Keep Awake" time. This was true even if the phone had been in my pocket unused and seems to be exacerbated by my habit of turning the screen off manually with the power button every single time. I used to never let the screen timeout.

    There seems to be two "fixes" according to Franco (of kernel fame). One concerns the camera. Seems the camera is started and then turned off during startup. But in so doing, it leaves a sensor active and this prevents the phone from actually going to sleep. So he recommends starting and using the back button to go back to the home screen. The other is DRM Protected Content. He recommends this be disabled or frozen. A third, that I don't believe I recall seeing him recommend but that I have seen on his thread at XDA (down for blackout right now) is to disable Maps.

    I have done all three of those and my Keep Awake time has gone from 40-50% of my total battery time down to a few percentage points. I mean if I don't use my phone it will now show less than a minute of Keep Awake time per hour.

    Good luck
     
  8. BayouFlyFisher

    BayouFlyFisher Rescue Squad
    Rescue Squad

    Joined:
    Dec 10, 2009
    Messages:
    4,958
    Likes Received:
    17
    Trophy Points:
    168
    Location:
    Baton Rouge, LA
    Ratings:
    +17
    Here's some more tips. They were written for the Bionic, but most should apply to your phone too:

    If you are having short battery life here’s a list of things that can help. Just read through the list and select the items that fit with the way you want to use your phone. Not all items will work for everyone and this list was written for the Droid Bionic but should work for your phone too:


    - Don't use an automatic task killer--not even the one that comes with the phone. Reboot your phone and look at what's running. If anything that you've installed is running and there's no reason for it, then uninstall it and find an alternative that behaves. Ignore any stock apps that run on boot as I've found them to be more or less benign.

    - Weather widgets, live wallpapers, news/social feeds, any app or service that you use that runs--do without it if you can. If you can’t do without it, lengthen it’s refresh time.

    - Don't use antivirus

    - Set your WIFI sleep policy to never. The default is "turn off when screen turns off". This will cause the wifi to reconnect every time you open the phone. From any Home Screen select Menu/Settings/Wireless & Networks/ and then use the Menu button to see some new options - select Advanced. Then select Wifi Sleep Policy and set it to Never. Home key to return to Home Screen.

    - If you have access to wifi, leave it toggled on as it is more efficient than 3G. Wifi consumes less battery power than 3G.

    - I leave GPS toggled on too by the way. Apps use it as needed. When I'm done with Maps or an app that uses it, I'm sure to return to the home screen so GPS can stop. Under wireless settings turn on "Google location services" so that an app is able to use network resources to get your location instead of GPS. I have "VZW location services" turned off--don't know why that option is even there. By the way, I increase the speed of voice output > text to speech > speech rate because I like the directions to get spit out faster. That saves a bit of battery. Turning off the display and just listening for directions help. Also, often I just get the directions and then exit back to the home screen: GPS uses so much battery I try to get it over with ASAP.

    - When you get a 1) new battery, 2) do a factory reset, or 3) an OS upgrade - run your battery all the way down until the phone shuts off and then charge the battery all the way up. This will calibrate the phone's understanding of the battery's capacity. Do this once every month or two also, but don't do it too often if you can help it.

    - I have my battery set to "Performance Mode" and data is on all the time because I am on call 24x7. If you don't mind, try out a more conservative battery profile to save more gobs of energy.

    - Set screen brightness to "Automatic"

    - Under Accounts, click on any account listed and turn off sync for any items that you're not interested in syncing. For example, Google Books if you don't use it. Don't use Backup Assistant--I prefer syncing my contacts with Google. You don't need both. Also go into your contacts > menu > display options > backup assistant > UNCHECK. Also do contacts > menu > more > settings > contact storage > and select your Google account and "remember this choice"

    - Turn on Bluetooth only when you are going to use it.

    - Consider turning off voice privacy. This may not be a big deal but it will save some processing (and therefore battery). It may also improve call quality.

    -Turn off haptic feedback, animations, and any un-needed sounds in Android settings and in your apps

    - Set your screen timeout to as low a time as you can stand (I use 1 minute) and manually turn the screen off when you’ve finished using the phone.

    - Turn off in-pocket detection. In-Pocket Detection has been the source of many issues already.

    - Keyboard: turn off vibrate on key press and sounds for any keyboards you use

    - Use a red or black screen background. On the original Droid screen--not sure about this Bionic screen--red was the most efficient color that could be displayed.

    - Camera app: I like keeping location on and flash on auto. Consider turning location off or at least returning to the home screen ASAP when using camera if location for camera is on.

    - In stock browser the default home page is Google and it uses your location. This is a bad idea as it can waste your battery for no reason. Make something else your home page and make sure to close any web page that uses your location when you're done viewing it.

    - Charge your phone via the wall charger instead of computer USB as it is faster. Also, don't use long USB cords--use regular power extension cords instead. I stick with the charger that came with the phone. Put the phone on charger when you go to bed every night.

    - Consider install the Home Replacement app Zeam. It is basic app that uses very few resources and will help with battery power.

    - Emails: I don't know what email app you use, but try this. It saves battery power and in some cases emails arrive quicker. This scheme will have you using only the Gmail app on the phone for all email accounts whether they are pop3 accounts or Gmail.

    - If you are using Live Wall Papers, stop!
    ------------------------------------------------------------------------------------------------------------------
    This is a link to some very good videos about saving battery power on the Bionic (there are 4 parts and the other parts will show up as available videos when part 1 finishes):

    Battery Saving Video

    Part 1:


    If battery life is still bad: Consider doing a factory reset(Galaxy Nexus users beware!! A Factory Reset will wipe your sdcard of everything – backup accordingly): These have gotten pretty painless lately by following these simple steps: 1. Make sure Backup and Restore are checked in the Privacy setting. 2. When going through the setup after the reset, turn on wifi as soon as you can (assuming it is available). 3. After you have entered your Gmail account info, you will be presented with a screen that has two check boxes. Basically they are "Do you want Google to backup and restore this phone”. Make sure you check both of those. Your apps will then automatically reinstall (paid and free). Set the phone aside for a minute or two and let the apps download and install. 4. If rooted, use an app such as titanium backup to restore data only to select apps such as Tapatalk and you will not have to re-enter all your login information. I do this for 3-4 apps (Tapatalk, SPB Shell, etc.).

    I've been flashing new roms/updates about once per day lately and I can be up and running with all my apps and settings back in place in less than 20 minutes. It's pretty painless now.
     
  9. dezymond

    dezymond Tech Support Mod
    Staff Member Premium Member

    Joined:
    Nov 11, 2009
    Messages:
    12,077
    Likes Received:
    1,503
    Trophy Points:
    573
    Location:
    Bay Area, California
    Ratings:
    +1,667
    Current Phone Model:
    Google Pixel
    I think this should be a sticky:hail:
     
  10. nleksan

    nleksan Member

    Joined:
    Nov 29, 2011
    Messages:
    180
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Cincinnati, OH
    Ratings:
    +1
    I don't get it... I have done all of the above, and more (I have like 12 disabled apps, at least), reboot once every ~36hrs or so, the only Widgets I have are FancyWidgets (4x3, updates every 3hrs), APW Calander (Scrolling calander), and the ICS Powerbar Widget (Wifi/GPS/etc); I have location turned off, I use WiFi 90% of the time, I have disabled DRM as well as background data on almost everything, first thing I do when I turn on the phone (reboot) is open the camera then click back then swipe it away from open apps, I ALWAYS swipe away any app I'm not using, I "Force Close" any apps running or cached that I don't need, I keep my call log and SMS/MMS logs virtually clear (I backup every 3 days via SMSBackup+), have a screen time-out of 30sec, never manually shut off screen unless I have to, keep GPS/Bluetooth/etc off at all times, have Maps disabled, clear app caches every few days, AND I let the phone get down to at least 14% battery (first warning) before plugging it in, and at least once a week I will let it fully die. Oh, and I keep the brightness set at 25-30% manually (auto-brightness off), and Voice Privacy is off as is NFC, Google Locate, etc.

    NOTHING HAS HELPED!!! I have MAYBE 15-2-% better battery life, MAYBE. The "Stay Awake" time is still >2x that of the screen time, and Verizon is giving me the run around despite my persistence in them fixing it, and now they've gotten me 10 days past the 15th (which was the end of the 30day no hassle return/exchange) so I am feeling pretty scr**ed.

    Don't get me wrong, I LOVE THIS PHONE TO DEATH, but the battery is just not up to task!

    What am I doing wrong here? I have not rooted it yet because I am hoping VZW will at least give me a new battery, or SOMETHING, but I REFUSE to take a refurb phone just a little over a month after I forked out full price for this! Not to mention having been a VZW customer for 8 years, with 5 lines (2 "dumb" phones w unlimited talk/text, 3 smart phones with unltd talk/SMS/MMS/data) resulting in, as you can imagine, significant monthly bills, which in 8 years have ALWAYS been paid before-due, not a single one has ever been late. I got scr**ed with my "Grandfathered-in" New-Every-Two, but I got to keep unltd data going from 3G to 4G.

    Since so many people are having this issue, I don't think the odds are in my favor of getting a new GNex that doesn't have this issue, and I REALLY want to Root the phone in order to see a potential increase in battery life (no custom ROMs, just TiBu/SetCPU/etc), but am afraid VZW will get on their high-horse about it.

    Any advice?
     
  11. dezymond

    dezymond Tech Support Mod
    Staff Member Premium Member

    Joined:
    Nov 11, 2009
    Messages:
    12,077
    Likes Received:
    1,503
    Trophy Points:
    573
    Location:
    Bay Area, California
    Ratings:
    +1,667
    Current Phone Model:
    Google Pixel
    You can always unroot and revert back to 100% stock if want to try the root methods out.
     
  12. BayouFlyFisher

    BayouFlyFisher Rescue Squad
    Rescue Squad

    Joined:
    Dec 10, 2009
    Messages:
    4,958
    Likes Received:
    17
    Trophy Points:
    168
    Location:
    Baton Rouge, LA
    Ratings:
    +17
    Try setting your screen sleep time to about 30 seconds and then don't shut the phone off with the on-off switch. Let it time our and turn itself off.

    Good luck.
     
Search tags for this page

background detection service facebook

,

can't locate in pocket detection button droid 2

,

droid rom for battery keep awake problems

,

exchange services battery s3

,

exchange services battery usage

,

exchange services draining battery s4

,

exchange services using a lot of battery on android

,

galaxy note 2 exchange services draining battery

,

galaxy s4 exchange services battery usage

,

s4 stay awake exchange services battery 4.2.2