battery life fix

Discussion in 'HTC Droid Eris' started by ironslave, Nov 16, 2009.

  1. Gary

    Gary New Member

    Joined:
    Nov 21, 2009
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    download the 'Kill selected apps' application. This is the best battery life extender I have tried. Apps running in the background use a lot of energy from the tiny battery.
     
  2. jsmmao

    jsmmao New Member

    Joined:
    Nov 21, 2009
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0

    Im interested in the same thing. I bought the eris a couple days ago and it is by far the best phone Ive ever owned (been a blackberry guy for awhile). The only problem is, that I take it off the charger at 6 a.m. and I am lucky if I make it to 9 pm at night. Although there is the option of charging it during the day while i am at work, but I am more interested if there will be a fix for this or if the passion will be a better phone. If thats the case, then i will return this and wait for the the htc passion to come out. If anyone has any ideas, please let me know. thanks
     
  3. falltime

    falltime New Member

    Joined:
    Nov 13, 2009
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Bizzarly I tried every battery fixed that is out there and none seemed to do all that much. Then a few days ago they all seemed to be working great. I realised that it isn't the fixes....the battery is just getting much better. I know it sounds insane but I think the stock battery takes more than a couple of cycles to really work right. Now I keep location settings and background data sync on...and I easily get a full day with lots of use...wired but true.
     
    #15 falltime, Nov 22, 2009
    Last edited: Nov 22, 2009
  4. xfeathersx

    xfeathersx Member

    Joined:
    Nov 15, 2009
    Messages:
    86
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Pennsylvania
    Ratings:
    +0
    falltime...I thought the same thing, but didn't want to post in for ppl thinking I was nuts...lol...But my battery is certainly lasting way longer...:biggrin:
     
  5. goathog02

    goathog02 Member

    Joined:
    Nov 5, 2009
    Messages:
    61
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0
    How long does it take? I have had mine for a week and it doesn't seem to be getting any better. I don't want a Droid, but I am losing faith that the Dragon will be any better.
     
  6. xfeathersx

    xfeathersx Member

    Joined:
    Nov 15, 2009
    Messages:
    86
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Pennsylvania
    Ratings:
    +0
    I have mine for 2 1/2 weeks, use it constantly. I didn't do anything special, just shut off the bluetooth, and the nav4all... I had similar problems with my blackberry last year and one of the reps told me to run the battery all the way down before charging, so thats basically all ive been doing with the eris...Just full cycling really...
     
  7. alfmoonspace

    alfmoonspace New Member

    Joined:
    Nov 16, 2009
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    SLC
    Ratings:
    +0
    I do remember my iPhone having a similar issue when it was first released (especially my 3G) but was fixed with a firmware update. Hopefully the December 11th update will address this or even the February update. I actually just traded my Droid for the Eris and I don't care if I only have 3 minutes of battery life, this phone is the best phone I have had since my iPhone. Not saying the Droid is a slouch but for me the Eris suits my life better. I do not think HTC/Verizon/Google will let battery life that is substantially bad slip without an update. Today I used my phone heavily since 10am and it just died about an hour ago (5pm), that is pretty good in my eyes.
     
  8. B_CRINE!

    B_CRINE! New Member

    Joined:
    Nov 23, 2009
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    re:Settings > Wireless Controls > Mobile Network Settings > Enable always-on mobile

    I turned this setting off and it did wonders for my battery life. Before I wouldn't even make it a day but now I can go a day and a half to 2 without recharging. Awesome!
     
  9. RinTinTigger

    RinTinTigger Premium Member
    Premium Member

    Joined:
    Nov 4, 2009
    Messages:
    2,901
    Likes Received:
    2
    Trophy Points:
    103
    Location:
    Germany, Near Frankfurt/Main
    Ratings:
    +2
    So then what didi this option do? Does it turn off the 3G Module and only turning it on for sync/surfing??

    Did you still receive mails IN TIME?
     
  10. B_CRINE!

    B_CRINE! New Member

    Joined:
    Nov 23, 2009
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    I'm not exactly sure what this option does. I've looked over the manual and I can't get any specific information. My 3G is still on all the time. I don't see any Facebook notifications on the top status bar anymore. Maybe it stops social network notifications?
    Gmail still syncs up. Mine is set to refresh every 15 minutes and it still does this with "always on mobile" disabled.
     
  11. alfmoonspace

    alfmoonspace New Member

    Joined:
    Nov 16, 2009
    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    SLC
    Ratings:
    +0
    Canceled that feature and still the same battery life...Do you guys think this will be addressed with the update in December?
     
  12. sgoldwa

    sgoldwa New Member

    Joined:
    Nov 6, 2009
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Battery problem solved

    Alfmoonspace & others,
    Like you, I have had a love/hate relationship with my Eris. LOVE the phone, hated the battery life. In fact, I was seriously considering returning it to Verizon.

    After exchanging the original for a new battery and following other tips in these forums, I now have battery life far BETTER than expected. So here's what to check for --

    1 - Are you running the 3rd party app YouMail? If you are, get rid of it. Same goes for Verizon's Visual Voicemail (in that case, just don't use it -- I am not sure you can delete an app preinstalled on the phone). YouMail KILLED my battery life.

    2 - Check your awake time. If it running at or near 100%, some app or another is not letting the phone sleep. Once I got to the bottom of this (in my case, YouMail), battery life markedly improved.

    3 - Let your phone discharge fully 3 nights in a row. then charge it up. That last 8- to 10% seems to take forever to drain. Call some number (i.e. your home) and just keep the line open till it drains. For good measure, make sure GPS, Wifi and Bluetooth are all ON so that it drains faster!

    4 - Keep the screen brightness at about 25%. It's still plenty bright and it'll save battery life.

    In the past, I would hardly use the phone in the morning, and by 10 or 11am, I would have gone down from 100 to 79% -- it was ridiculous! Today, I did use the phone moderately, did some surfing, had Exchange Server syncing mail every 30 minutes, and by 11am, I was at 89%. I even had over 60% by the end of the business day!

    I even turned on GPS and it did not have a noticeable impact on my battery life nor my awake times.

    Be patient, because once you get past your battery issue, you will find this to be one of the best phones EVER. I am so happy that I stuck with it! And I can't wait till Android 2.0 comes out. That will be nirvana!!!
     
Search tags for this page
94 percent battery 30 days to understanding the christian li
,
battery fix for htc driod inc
,

droid eris battery fix

,
droid eris battery life
,
droid incredible battery life fix
,
how to fix a droid battery
,
how to fix battery on droid x
,
htc droid battery fix
,
htc incredible battery dc10083120s14
,
motorola droid battery life issue