Bad Audio Using Belkin Miracast Video Adapter

Discussion in 'Samsung Galaxy S5 Discussions' started by mlsanger, Feb 3, 2016.

  1. mlsanger

    mlsanger Member

    Joined:
    Mar 17, 2015
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    Hi, using screen mirroring with a Belkin Miracast Video Adapter on TV, the video is perfect, but audio is garbled. I've updated adapter firmware, rebooted, factory reset. Seems this started after last Samsung OS update. Some apps (Netflix) works fine, but Google Music and vids from S5 camera have this problem. Please help.

    Sent from my SM-G900V using Tapatalk
     
  2. mlsanger

    mlsanger Member

    Joined:
    Mar 17, 2015
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    Figured it out. Google search! Highly recommend it.

    Sent from my SM-G900V using Tapatalk
     
  3. cr6

    cr6 Super Moderator
    Staff Member

    Joined:
    Apr 1, 2011
    Messages:
    8,354
    Likes Received:
    5,877
    Trophy Points:
    1,778
    Location:
    NW Rocky Mtn region
    Ratings:
    +6,707
    Current Phone Model:
    Galaxy S7 Edge
    Twitter:
    @dronewolfmedia
    Welcome to the forum @mlsanger ! Sorry I missed your question but am glad to hear you resolved the problem!

    S5 tap'n
     
  4. dorlisa

    dorlisa Member

    Joined:
    Apr 11, 2010
    Messages:
    173
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Alabama
    Ratings:
    +0
    How did you fix it? Mine has been doing this for about two months. I can watch a movie and it is perfect, a week later I try to watch it again and it sounds demonic.
     
  5. mlsanger

    mlsanger Member

    Joined:
    Mar 17, 2015
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    Well, I boasted too soon. Mine's hosed again. What I did was update the firmware in the adapter and Samsung TV. It worked fine for a few days. Netflix, YouTube, my recorded vids all work fine. It's just my Google Music app they has the problem with the audio breaking up. Sorry I can't help. BTW, my wife's Galaxy Tab 2 and my son's S6 play fine using Google Music.

    Sent from my SM-G900V using Tapatalk
     
  6. mlsanger

    mlsanger Member

    Joined:
    Mar 17, 2015
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    Also, I shoukd say, the audio is much better than it was. Before I couldn't even recognize it. Now it just hiccups a little every now and then.

    Sent from my SM-G900V using Tapatalk
     
  7. Juangerson

    Juangerson New Member

    Joined:
    Apr 11, 2016
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Current Phone Model:
    Galaxy S5
    Most recommendable is try cache partition wipe , could be corrupted cache or too large of cache file especially after update android OS.

    1. Turn off your phone. (My phone is a Galaxy S5)

    2. (For Galaxy S5 and several android phones) Press and hold the Power, Volume Up and Home buttons simultaneously.

    3. You can release them when you see the Samsung logo with Recovery booting written in blue at the very top of the screen.

    4. You will be brought to the Android System Recovery screen (or a custom recovery if you have one installed – if so, your steps will be slightly different, but basically the same as described here).

    5. Use the volume buttons to scroll down the list to highlight Wipe Cache Partition and use the Powerbutton to confirm your selection.

    7. You'll see a notification at the bottom of the screen in yellow to show that the system cache has been wiped.

    8. If Reboot System Now is not already highlighted, use the volume keys to highlight Reboot System Now and press the Power button to confirm.

    9. Your Galaxy S5 will reboot with a fresh system.

    More options for screen mirroring issues:

    1.restart your router, then Check the wifi download speed on your phone and then again near the tv.

    2.processing can cause lag too, check available ram on your phone ie. Force quit all otherapps.

    3. Some apps broadcast high bandwidth better than others. Try another broadcast app like allcast to see if the problem still happens.

    4. Try just casting audio, see if it still lags

    5. Could be corrupted cache or too large of cache file. Try cache partition wipe.

    6. If you haven't already, restart tv and phone

    7. Some routers limit traffic for various reasons. Check the router settings for streaming performance. (There are many settings that can effect throughput.)

    8. Some miscast devices and some routers have lag when broadcasting from a device on 5ghz wifi network to a tv on 2.4ghz wifi and vice versa. You could try to put both on the 2.4 and see if that resolved it.

    9. Interference can also cause lag. Large speakers have magnets, fish tanks block wifi, concrete walls, solid wood etc between routers and devices.

    10. After OS update connect the miracast to a device using a PIN, tap and hold the device name to enter the PIN on the screen mirroring options.

    I hope you can solve the problem.
     
    #7 Juangerson, Apr 11, 2016
    Last edited: Apr 12, 2016
Search tags for this page
belki screen mirroring sounds bad
,
belkin miracast adapter voice issue on s6
,
belkin miracast makes voices sound bad
,
miracast bad audio
,
miracast bad sound
,

miracast sound distorted

,
poor sound whem miracast
,
problems with galaxy s6 and my belkin miracast
,
samsung tablet belkin miracast auddio problem
,
sound is distorted on belkin miracast adapter model f7d7501v1