Apps not all restoring with new ROM

Discussion in 'Android Roms' started by flyinion, Jan 27, 2011.

  1. flyinion

    flyinion Member

    Joined:
    Jul 18, 2010
    Messages:
    288
    Likes Received:
    1
    Trophy Points:
    18
    Ratings:
    +1
    Not sure how to fix this, but randomly when I flash a ROM not all of my apps will show in the Market and restore. I can find them if I search, but that doesn't fix the problem. I've had this happen on Sourcery and now CM7 build 15. The other day on Sapphire which I've been running for a while I noticed for some reason a lot of apps I have on the SD card via standard Froyo "move to SD card" were the ones missing. Large apps like Angry Birds. Deleting the Market data in Settings/Applications fixed that though. On new ROM installs (wipe data/cache) I've been turning on wi-fi right after logging in and the sync icon goes away (so it's re-downloaded my wireless info) to speed up restoring apps, but I'm wondering if that could be the cause?

    edit: I've also noticed that after it happens and I restore my nandroid, I need to go delete market data again for everything to show up even in the restored backup.
     
    Last edited: Jan 27, 2011
  2. flyinion

    flyinion Member

    Joined:
    Jul 18, 2010
    Messages:
    288
    Likes Received:
    1
    Trophy Points:
    18
    Ratings:
    +1
    Ok now I'm really confused, I just realized the market is losing those 20ish apps installed to SD card every time I reboot and only clearing market data fixes it, but that doesn't work when loading a new ROM. I've only noticed this to this level since flashing Sapphire 2.0.2 which has the new style market in it.
     
  3. Stelv

    Stelv Silver Member

    Joined:
    Oct 12, 2010
    Messages:
    2,656
    Likes Received:
    8
    Trophy Points:
    103
    Location:
    Western NY
    Ratings:
    +8
  4. flyinion

    flyinion Member

    Joined:
    Jul 18, 2010
    Messages:
    288
    Likes Received:
    1
    Trophy Points:
    18
    Ratings:
    +1
    Thanks for the link. Well, at least I understand what the different text colors mean in TB now lol. I don't see anything in there about fixing missing apps from the market. Although, I think TB paid is supposed to be able to fix that so I guess maybe I need to break down and buy TB.

    This problem is so strange. I finally had it working after a reboot by deleting data, then checking to make sure everything was showing, letting the phone sit for 5-10 minutes. Then after a full power off and back on, the market associations all stayed after a couple reboots and a backup via CW. Installed the CM7 build 15, it found and downloaded everything this time (took like 2 hours because I'm at work near a downtown tower so slow 3G). Flashed the backup of Sapphire and the problem is back and persisting through clears, cold boots, and restarts again. /sigh

    It's like something isn't syncing right or something. I'm not sure how it works, but I'm assuming the Market saves something to Google otherwise I wouldn't get any apps restoring after a data/cache wipe when installing a ROM.
     
  5. Stelv

    Stelv Silver Member

    Joined:
    Oct 12, 2010
    Messages:
    2,656
    Likes Received:
    8
    Trophy Points:
    103
    Location:
    Western NY
    Ratings:
    +8
    I am not really sure how it works either but I believe google syncs and backsup your market data every once in a while via the cloud. Some roms auto download all my previous apps even though i wiped/formatted everything, some roms don't. I think it is because roms are coded differently but again i am not sure. Wish i could help more.

    sent from my rooted nook color
     
  6. flyinion

    flyinion Member

    Joined:
    Jul 18, 2010
    Messages:
    288
    Likes Received:
    1
    Trophy Points:
    18
    Ratings:
    +1
    Well it seems to be clearing up. Maybe Google was having a server issue and I just happened to be playing with stuff at the same time. Flashed a new ROM last night and everything downloaded (eventually, some stuff failed and had to restart but could have been the ROM). Afterwords 3 large games installed to SD Card didn't show in the downloads list but if I search for them they showed installed, and later showed in the list.

    Edit: Ack it's back. I'm starting to wonder if it's latency/connection related to the tower you're talking to. Unfortunately this time I'm running a GB based ROM and Market has a clear cache but Data is grayed out. Might be a CM7 thing though.
     
    Last edited: Jan 28, 2011
  7. Stelv

    Stelv Silver Member

    Joined:
    Oct 12, 2010
    Messages:
    2,656
    Likes Received:
    8
    Trophy Points:
    103
    Location:
    Western NY
    Ratings:
    +8
    Yea I think cloud backup through Googles servers can be spotty. It could take a while for Googles servers to talk to your device. Wish I knew more about this stuff though. On a side note, make sure your camera works on CM7 because mine didn't with release #15.
     
  8. flyinion

    flyinion Member

    Joined:
    Jul 18, 2010
    Messages:
    288
    Likes Received:
    1
    Trophy Points:
    18
    Ratings:
    +1
    Yep I think you're right, everything is showing now lol. As far as camera thanks, I keep forgetting to check that. Camera works fine on build 17 other than a nutso haptic feedback when using the camera button to launch it. Video still FC's it though.
     
  9. Stelv

    Stelv Silver Member

    Joined:
    Oct 12, 2010
    Messages:
    2,656
    Likes Received:
    8
    Trophy Points:
    103
    Location:
    Western NY
    Ratings:
    +8
    I m glad everything is working now. Ill have to try cm7 again once cvpcs has all the bugs worked out.

    sent from my rooted nook color
     
  10. flyinion

    flyinion Member

    Joined:
    Jul 18, 2010
    Messages:
    288
    Likes Received:
    1
    Trophy Points:
    18
    Ratings:
    +1
    Yeah, I just flashed my Sapphire backup back (market working right still too woohoo). CM7 build 17 was nice but still a few too many quirks for me to keep it as a daily use.
     
Search tags for this page

android apps don't show up when flash new rom

,

if i flash a new rom will it fix my apps

,

install all apps from my apps in goole play store

,

rom apps in finder but not on phone