Anyone have the Huawei Smartwatch 2?

Discussion in 'Watches (Android Wear, Tizen/Samsung, etc)' started by matepro, Jul 28, 2018.

  1. matepro

    matepro New Member

    Joined:
    Jul 28, 2018
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Houston, TX
    Ratings:
    +0
    Current Phone Model:
    Huawei Mate 10 Pro/iPhone 10
    I just picked this Smartwatch up and realized or I can't seem to answer a call through the watch. Does anyone know if this is a feature that is not on this watch?

    Sent from my BLA-A09 using mobile forums
     
  2. Sajo

    Sajo Diamond Member

    Top Poster Of Month

    Joined:
    Jan 25, 2013
    Messages:
    14,064
    Likes Received:
    9,470
    Trophy Points:
    1,863
    Location:
    Tennessee
    Ratings:
    +10,009
    Current Phone Model:
    Moto Z2 Force
    Welcome to the Forum. Hopefully someone can give you a definite answer. I think we have a few members here that own the original Huawei watch.

    Sent from my XT1650 using Tapatalk
     
  3. kodiak799

    kodiak799 Gold Member

    Joined:
    Feb 20, 2010
    Messages:
    6,115
    Likes Received:
    813
    Trophy Points:
    258
    Ratings:
    +985
    To be honest, I've never tried answering a call on my watch. First, make sure your software is up-to-date on the watch.

    If you're talking about the LTE version and making calls, you need to add it to your cell plan at your carrier and insert a sim. ONLY the sport versions has LTE. The classic version does not.

    Otherwise, I THINK you can answer a call from your PAIRED phone. So make sure your watch is paired and connected via bluetooth. Then, check the settings on your Wear OS app on your phone - I think you need to grant your watch access to phone and contacts. And/or tap the "phone" app on your watch, and enable to play voice calls on the watch.
     
    • Like Like x 1
  4. CTownDroid

    CTownDroid Gold Member

    Joined:
    Mar 6, 2010
    Messages:
    589
    Likes Received:
    382
    Trophy Points:
    203
    Location:
    Cleveland, Oh
    Ratings:
    +390
    Current Phone Model:
    Nexus 6P
    Like Kodiak said, in Bluetooth device settings be sure phone calls are turned on. [​IMG]

    Sent from my Pixel XL using Tapatalk
     
    • Like Like x 1