Any way to disable the music player from starting up whenever I plug in audio cord?

Discussion in 'Android Hacks and Help' started by bloodstains, Jul 13, 2010.

  1. bloodstains

    bloodstains Member

    Joined:
    Feb 9, 2010
    Messages:
    109
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    I use "3" as my music player (love the widget and everything else about it). Often when I'm in the car, my audio out cable which runs to my auxiliary input gets jostled, causing my Droid to think I'm unplugging/plugging the cord in.

    Whenever this happens, it starts up the stock music player and starts playing music. Now I have two songs going at the same time (one playing on 3, the other playing on stock). It's annoying, and kind of a pain in the butt to switch into the music player and stop it while I'm driving. I'd like to be more focused on the road and not have to worry about this!

    Any suggestions are appreciated, let me know if I can clarify anything for you.


    (fyi - running Bugless Beast 0.4 on a Motorola Droid).
     
  2. 48hughey

    48hughey New Member

    Joined:
    Feb 4, 2010
    Messages:
    23
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Eugene, OR
    Ratings:
    +0
    I have the same problem when I connect to my Bluetooth car kit (to stream music via it's FM transmitter). I am usually starting up Pandora, but the default music app kicks on too...:mad:

    Also on BB 0.4
     
  3. chudilo

    chudilo Member

    Joined:
    Nov 18, 2009
    Messages:
    72
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0
    My car supports Bluetooth directly. (mazda3) and I have the same problem. I would've though that Froyo would address this ... but that did not happen.
    Is this something Pandora should reserve?
     
  4. bloodstains

    bloodstains Member

    Joined:
    Feb 9, 2010
    Messages:
    109
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    I think I might have found a way to solve this? Not completely sure, but ever since I downloaded the "Block Headset" widget from the market (free widget) and turned that on I've had no problems. Small chance it could be coincidental but I've been using it for a couple weeks now without it happening, which is much better than before!! I wish there was some other way rather than having a widget taking up a spot for an icon, but this seems to work and it's free/easy.
     
  5. Martin030908

    Martin030908 DF Super Moderator

    Joined:
    Nov 1, 2009
    Messages:
    8,773
    Likes Received:
    0
    Trophy Points:
    151
    Ratings:
    +0
    Odd... I've never encountered this issue.

    Glad you found a resolution.
     
  6. HamDog

    HamDog Member

    Joined:
    Aug 3, 2010
    Messages:
    190
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    I use MortPlayer as my music player. In it's settings--->Preferences, there is an option under "Headset" to discontinue it from playing automatically when headsets get plugged in.

    I also have bluetooth in my car stereo and it automatically starts up the music when I start the car. But I actually like this feature! But it doesn't do it all the time. I think if your music player is open and paused, it automatically restarts, but if the music player is not open, it will not automatically play. I'm still trying to figure this one out.

    I made a video on this:

     
  7. rtb

    rtb Member

    Joined:
    Nov 22, 2009
    Messages:
    124
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    Any word on this? I connect my Droid Eris to my car via bluetooth and every time I start it up it plays what is in my music folder. I only use Pandora so I don't want it to play my music folder - annoying!
     
  8. cellu1

    cellu1 Member

    Joined:
    Nov 17, 2009
    Messages:
    32
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0
    I am using PowerAmp Full Version and I am able to disable the headphone jack option. Problem is like the OP stated, that the stock music player starts playing. I have found no option on turning this off for the stock player. Also my stock music player is constantly running in the back ground, lurking, just waiting for me to plug in my headset.
     
  9. UNC

    UNC Active Member

    Joined:
    Jan 12, 2010
    Messages:
    1,358
    Likes Received:
    1
    Trophy Points:
    38
    Location:
    Fayettenam,NC
    Ratings:
    +1
    Message me and I can help you guys with this!!!!!

    You must be ROOTED!!!!!!
     
  10. Axium

    Axium Member

    Joined:
    May 30, 2010
    Messages:
    206
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    just delete the stock music apk. it sucks anyways has too many bugs for me :) mixzing is my media player and i love it.
     
  11. Darkit

    Darkit New Member

    Joined:
    Nov 24, 2009
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    I think I used to have the same problem. I like the winamp player better than the default player but everytime I unplugged my headphones after using winamp the default player kicked it.

    To solve this was rather easy. I just went into the app tabs and into the default player settings. Then I just cleared the cache of the default player and suddenly no more problems. Hope this fixes your problems.
     
Search tags for this page

android disable bluetooth autoplay

,
android stop music player
,

disable android music player

,
disable autoplay bluetooth android
,
disable bluetooth autoplay android
,
how to take autoplay off music player from androids
,
stop android music player from starting automatically
,
stop pandora from autoplaying
,
turn off pandora autoplay
,
why is pandora automatically coming on when i plug in my phone in the car