1. DroidForums.net is currently undergoing a major software upgrade. If you are experiencing any problems logging in please: Contact Us

Another battery llife issue..

Discussion in 'Motorola Droid 3' started by Manderson31395, Sep 21, 2011.

  1. Manderson31395
    Offline

    Manderson31395 New Member

    Joined:
    Mar 14, 2010
    Messages:
    17
    Likes Received:
    1
    Trophy Points:
    0
    I know this has been beaten to death but my battery life just sucks

    I mean its kinda ridiculous that I cant get anything over 8 hours of battery after having two phone conversations and less than 10 texts.
    I've done all the standard stuff (task killers, display, timeout, wifi, bluetooth) but im still getting terrible battery life

    When looking at the battery manager the big percentages are:
    phone idle 36
    cell standby 24
    android system 18

    I've looked into this and it seems to be whether I'm in bad cell areas, so my question is short of airplane mode, is there any way to make my droid 3 use less battery when in areas of bad service.

    Another problem is when on the battery management when the phone is said to be awake and charging the phone loses battery when plugged in.
    I'm pretty sure it has to do with a texting thing but if there is any advice please i'm open to it.

    Im waiting for the update but I dont think it'll solve all my problems
  2. pistacio
    Offline

    pistacio New Member

    Joined:
    Aug 26, 2010
    Messages:
    442
    Likes Received:
    5
    Trophy Points:
    0
    Location:
    MA
    Try out the different battery modes which will allow you to turn off data at certain times of day. Might help when your in a bad area.

    Settings> battery and data manager> battery mode ( or any of the others in there).

    Sent from my DROID3 using DroidForums App
  3. akhi216
    Offline

    akhi216 Member

    Joined:
    Jan 12, 2011
    Messages:
    526
    Likes Received:
    1
    Trophy Points:
    18
    For the bad signal areas you can try "Signal Booster" from the market.

    Sent from my DROID3 using DroidForums
  4. jonamurphy
    Offline

    jonamurphy New Member

    Joined:
    Sep 8, 2011
    Messages:
    32
    Likes Received:
    0
    Trophy Points:
    0
    I've read a number of posts here stating that task killers may actually cause the phone to work harder rebooting killed apps instead of just letting them idle in memory.

    It may be worth it to disable the task killer for a day and see if you notice a difference.
  5. Manderson31395
    Offline

    Manderson31395 New Member

    Joined:
    Mar 14, 2010
    Messages:
    17
    Likes Received:
    1
    Trophy Points:
    0
    Sorry i didnt mention but all I do is the maximum battery mode in the battery modes thing, i messed around with custom but I went with maximum when I couldnt stand it anymore and it helped a little and I know of the endless start-kills of task managers and i started using task manager after the problem was noticed and the problem is definitely not within one app, its more likely to do with the signal.

    And in reference to the signal booster do you mean this one
    https://market.android.com/details?id=com.s4bb.signalbooster&feature=search_result

    or others because there are a lot
  6. NoBloatware
    Offline

    NoBloatware New Member

    Joined:
    Jun 23, 2011
    Messages:
    746
    Likes Received:
    11
    Trophy Points:
    0
    Get rid of the task killer, take everything off the auto-end list. Uninstall antivirus, security apps.

    Have you switched to CDMA only? Leave roaming on.
  7. Manderson31395
    Offline

    Manderson31395 New Member

    Joined:
    Mar 14, 2010
    Messages:
    17
    Likes Received:
    1
    Trophy Points:
    0
    all already done, I only had one item in auto-end list but i will remove it
  8. NoBloatware
    Offline

    NoBloatware New Member

    Joined:
    Jun 23, 2011
    Messages:
    746
    Likes Received:
    11
    Trophy Points:
    0
    In addition to setting to CDMA only and turning on roaming:

  9. Manderson31395
    Offline

    Manderson31395 New Member

    Joined:
    Mar 14, 2010
    Messages:
    17
    Likes Received:
    1
    Trophy Points:
    0
    That all makes sense and not to shoot it down but I had a droid 1 and since I've gotten a droid 3 I've been doing most of that stuff and I'll try the little things but the real problem is when I have bad to mediocre service, i guess searching for signal just drains my battery. I really want to know if theres any way to make the phone not search for better service when Im pretty much staying put in the same area of bad service.

    Ill do a system restore before the update comes out so I can start from a clean slate and maybe get an extended battery.

    At the end of the day, just because my school is in an area of bad service does that mean my phone lasts for 8 hours, thats just wrong.

    Thanks for the great feedback though, ill be sure to keep it in mind
  10. NoBloatware
    Offline

    NoBloatware New Member

    Joined:
    Jun 23, 2011
    Messages:
    746
    Likes Received:
    11
    Trophy Points:
    0
    Other than updating PRLs (dial *22899) and being sure that roaming is on I'm not sure what else you could do to stop battery drain in a low signal area.

    Well, one other idea is to use software that will recognize the low signal area and shut off the radio for certain periods of time. For example, if it sees that you have 1G signal and barely 1 bar of service the software can turn off data for whatever time you specify...say 10 minutes. Unfortunately, I don't know the name of this software but I've seen people discuss it. (try Juice Defender, NoBars Battery Saver)

    Hm, do you have good WIFI availability in that low signal area? If so, you could set your WIFI sleep policy to never while you're there so that your phone isn't burning up battery trying to stay connected to Verizon. You could use location-based software (perhaps llama, free from market) to do this automatically.
    Last edited: Sep 22, 2011
  11. Fr33dom
    Offline

    Fr33dom New Member

    Joined:
    Mar 27, 2011
    Messages:
    547
    Likes Received:
    6
    Trophy Points:
    0
    What I do is to set the custom battery saver to turn off data after 15min during times I'm in a low signal situation. For me that's at work so my off peak hours are set from 8 to 5. The rest of the time I set it to always on. If you're around useable WIFI, you'll do better on WiFi. I tested setting-up an adhoc WiFi on my work laptop and letting my d3 connect to it and that helped lots.

    Here are settings I've tested: http://www.droidforums.net/forum/droid-3/169739-helping-battery-life-without-rooting.html
  12. schrearsch
    Offline

    schrearsch New Member

    Joined:
    Sep 25, 2011
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    battery

    I've had no problems with my battery and my phones only 2 weeks old. I have it set on nighttime battery saver mode and today alone have sent 6 emails did some web browsing played a few games 5 text messages and 2 10 minute phone calls and im at about 20 hours with 50 percent battery left. I also found charging the battery back up at arounaround5 percent really helps it last longer. Your bad cell service could play a factor though.
  13. horr1blek1tten
    Offline

    horr1blek1tten New Member

    Joined:
    Sep 16, 2011
    Messages:
    160
    Likes Received:
    0
    Trophy Points:
    0
    Get juice defender from the market I was getting 5 hours max on my EXTENDED battery. Installed this. App and now getting 8+ hours like an extended battery should. P.s. I was getting 3 hours max on the standard battery. Don't know if this i s normal.

    Sent from my DROID3 using Tapatalk