Am I asking for the impossible? Need your expertise.

Discussion in 'Android Watches' started by Jim 777, Feb 16, 2017.

  1. Jim 777

    Jim 777 Silver Member

    Joined:
    Dec 26, 2009
    Messages:
    2,307
    Likes Received:
    33
    Trophy Points:
    113
    Ratings:
    +34
    Little long I know, I just want to make sure I give as much accurate info.

    I just got my first smart watch, a little treat I got myself with a little tax return. It's a Asus Zenwatch 3 and so far I'm really liking it. After looking at, trying on, reading about, and determining what I want from a SW, I think I made the right choice. WIth really liking different styles of watches, it's no wonder I'm changing up the face everyday.

    I have the new Pixel XL and I've been getting it the way I like things as I put the Droid Turbo to pasture, but the watch has been disrupting things and I have spent more than a few days trying different settings, permissions, etc to get it, but I'm finally ready to ask for your help.

    Here's the little details: I don't want to talk to my watch, no SIM card, but more of a BT extension of my phone. Notifications at a glance are huge for me at work, instead of reaching down, digging phone out of holster, waking it up, unlocking, and so forth. This part works great. I'm not writing texts or emails at this point so I'm not interested in that. Where most of my frustration lies, is the audio and BT relation.... I think.

    Example:
    First, "The Threesome" - I listen almost exclusively to Pandora in the car, as the Alpine deck has a Pandora "app" on it. Usually when I get in the deck pairs with the phone (there are 3 icons that show: battery level, signal, and BT) and if on Pandora, it starts the app on the phone automatically and begins to play. Phone call comes in and the music pauses, rings through the speakers and I can speak normally as the little mic was installed with the deck near the rear view mirror.

    Now that the watch is in play, only one of the icons shows and it doesn't connect, at least not enough hto do anything. When I look under the BT settings on the phone it says both are connected. But I have to tap disconnect on the watch, usually a few times, to try and get a full connection to the deck. Once it does, 3 icons and music plays.

    Second, "You Make the Call" - When a call comes in, and I don't get a lot but still, I answer the call and it seems that there is no one there. What has been happening is that the audio would be connected to the watch and I'd have to manually go and change the listening preference to "phone". PITA! I believe I may have figured this one out through permissions (I've only tested it twice) but I throw it out because someone may understand the fix much better and tell me if I"m creating a problem else where. I went to the Android Wear app in settings on the phone, then permissions, and turned off permission to "phone." Also in the BT settings, the little gear icon next to Zenwatch 3, in there I unchecked the option for sharing phone.

    Lastly, "The Fat Lady Sings" - a couple little things, not really issues but tenacity being what it is and all. I'm not really "into" fitness but when something is there available to use, I may want to use it. The watch came with Zen Fit and I turned on Google Fit so they are connected. Is there a way to "teach" the app what is walking and what is not? Like when I woke up this morning, it said I'd walked 80 steps. Now I haven't confirmed this, but I'm pretty sure I don't walk in my sleep and it said I slept for the same hours I really did. Or are this devices not specifically made for fitness tracking, not very accurate?

    BT? Wifi? Neither? - Do I have to manually click on the wifi settings in the watch to connect? I noticed while looking for something as I was writing this post, that the BT was not connected and WOULD NOT connect. So I'm wondering if that's because of a wifi connection? In the Zen Manager app and the Android Wear app, they both say connected even when the BT doesn't appear to be,

    Thanks for help with these.
     
  2. Sajo

    Sajo Diamond Member

    Joined:
    Jan 25, 2013
    Messages:
    10,934
    Likes Received:
    6,871
    Trophy Points:
    1,863
    Location:
    Tennessee
    Ratings:
    +7,379
    Current Phone Model:
    Moto Droid Z Force
    All I can say for tonight is that I have never had any of those issues with my LG G Watch or Moto 360 Sport. Hopefully someone more familiar with a Zen Watch can offer some tips and help.

    Sent from my XT1650 using Tapatalk
     
  3. Jonny Kansas

    Jonny Kansas Administrator
    Staff Member Rescue Squad

    Joined:
    Jan 21, 2010
    Messages:
    16,485
    Likes Received:
    7,064
    Trophy Points:
    1,278
    Location:
    Michigan's Upper Peninsula
    Ratings:
    +8,406
    Current Phone Model:
    Pixel XL
    Twitter:
    jonny_ks
    Howdy! I've got an LG Watch Urbane, so I can't speak a whole lot on the Zen exclusive features/apps, but I'll do my best to try and help here. I do have a Pixel XL, so at least the phone part will be the same for us.
    Check the individual settings on each device. In your BT settings, you should be able to tap the gear icon to the right of the name of each BT device you've got remembered. There will be options depending on what the device is capable of. This may or may not help this situation. You may also want to "forget" the car and try re-adding it.

    This is where I'd definitely check those BT settings I mentioned above. Specifically, after tapping the gear icon, devices that are capable of routing audio will have options like "Phone audio", "Media audio", etc. I would make sure that at least phone audio is not checked on the watch. Maybe even media audio, since you're streaming the music to your car and not the watch.

    In my experience with health apps on the phone and/or watch, they're more of a guide. As you could imagine, it's hard to differentiate different types of movement. If you wore the watch while sleeping, which I'm guessing you did because it tracked your sleep, chances are that you tossed and turned or rolled over and that was enough movement that the watch assumed you were doing more than you were.

    Where I like Google Fit as opposed to what S Health used to do when I used Samsung devices is that it goes by time of activity rather than actual steps. Now, some activities may not be as "healthy" as others or as much movement overall, but time of moving, to me, is a better measure since the step counters (even on a fitbit or other "dedicated" health device) are an estimate and prone to being a bit off.

    I'm not into fitness either, but I do have a goal for amount of activity set in Google Fit and I do feel good when it tells me that I've met my goal, even if it's not very much. I work in IT, so unless there are major problems with the network, I don't do a lot of walking around. I make excuses to get out of my office and make a lap around the building from time to time.

    It's been a while since I played with this, but when wifi first became a real option for staying connected to the phone, I did test it out. If I remember right, you do have to manually click the wifi settings to connect to a network for the first time. The watch will get info (passwords/etc) from your phone to connect to a specific network.

    Once that's done though, I do believe all you have to do is get the watch out of BT range of the phone or otherwise disconnect BT between the two and the watch should jump over to wifi.

    Again, it's been quite a while since I played with this, but we have an open network here at work and I connected my watch to it and then left my phone in my office and went for a walk to the other side of our very large complex. I was able to text my wife by voice with the watch while my phone was definitely out of BT range. Worked pretty well.

    I've also left my watch powered on and at home, where it knew the wifi info and taken my phone with me around town. I've come back to find the watch telling me that wifi has been turned off to conserve power.

    Wifi takes more battery power to use, so the watch will always default to being connected to the phone by BT when they're in range of each other. I'm not sure if you were in wifi range all day and actively using the watch while your phone wasn't handy, if it would turn wifi off to conserve power, or assume you're using it so it should keep it connected.

    BT on the watch is another animal altogether. You won't find your phone in there. That's for pairing other BT devices directly to the watch. Headphones are the best example of this. If you have BT headphones and something like Google Play Music that will allow you to load songs onto your watch, you could pair the headphones to the watch and stream music to them from the watch without your phone. It's slightly odd that the watch will show up in the phone's BT settings, but the phone doesn't show up in the watch's, but that's how that works.

    So, long story short on this topic, the watch is going to do what it can to stay connected to the phone while still doing what it can to save battery. For the most part, this all happens on its own.

    Now, I've just added my work wifi back to my watch (it's been reset many times since I first tested the connection) and go for a walk to test it out a bit again...
     
    • Like Like x 2
  4. Jonny Kansas

    Jonny Kansas Administrator
    Staff Member Rescue Squad

    Joined:
    Jan 21, 2010
    Messages:
    16,485
    Likes Received:
    7,064
    Trophy Points:
    1,278
    Location:
    Michigan's Upper Peninsula
    Ratings:
    +8,406
    Current Phone Model:
    Pixel XL
    Twitter:
    jonny_ks
    There may be a post like this one in another thread somewhere, because I'm pretty sure I shared my findings on this last time I tested it, but here's my experience just now using wifi on the watch.

    I left my phone in my office and went for a stroll. Initially, I did pull up my settings and tap on wifi, so I did manually connect to it. However, we don't provide wifi back in the breakroom area (we're a nursing home, so this wifi network is for residents and their guests, not the staff). I wanted to get a pop from the machine, so I went back there.

    Once I was out of range of the nearest wifi access point, the watch showed the disconnected symbol.

    When I went back into range of wifi, I resisted the urge to open the settings again. It took it a little while (less than a minute, but longer than as soon as I was in range) to realize there was wifi available and connect, but it did end up connecting on its own.

    Wifi is set to "Automatic" on my watch when I first open those settings, so if yours is set the same, it should eventually connect to wifi when out of BT range of the phone.

    I'm guessing that it's setup to not poll to frequently for a connection in order to conserve battery life, which would explain why mine took a little while to reconnect after I was well within range.

    Hope that helps answer that question a little better.
     
    • Like Like x 2
  5. Jim 777

    Jim 777 Silver Member

    Joined:
    Dec 26, 2009
    Messages:
    2,307
    Likes Received:
    33
    Trophy Points:
    113
    Ratings:
    +34
    Thanks for those! Let's see there was a couple things you mentioned....

    Permissions: after reading your details, it seemed not so confusing. The device with permission settings, is to determine what OTHER device can or can not access on that device...? So i do like being able to control my music via the watch so access to audio should be "allow" on the phone. I don't want to answer/talk on a call via the watch, so access to phone should be DENY on watch, and so forth?
    I think I'll have to scroll through both devices, write down what's what, and make sure I haven't goobered it all up with trying different things.

    Health apps: Yeah, should remember "guideline" and yes, monitor sleeping. Have apnea and major mental stress now so I'm curious.

    Wi-fi: No automatic settings that I've found but that would make sense to be an option. I'm not around Wifi all day so only my wifi at home is the one I've put in the passphrase for, but "it looks like" I have to go in to settings > wifi > networks and then I see mine pop up, then connect. Now, I'm not concerned about battery (I turned off the ambient option and about doubled my life) but just created confusion since the BT symbol on the phone wouldn't show connected, but the apps did and I could change faces on the phone, changing on the watch.

    I'm hoping that AW 2.0 is right around the corner.

    Might be more, but I got to get to work. Wanted to do IT but didn't work out with schooling and paying bills at the same time. Sometimes I think I a level of tenacity that a job like that would kill my and/or and relationship I'd be in. :p
     
  6. Jonny Kansas

    Jonny Kansas Administrator
    Staff Member Rescue Squad

    Joined:
    Jan 21, 2010
    Messages:
    16,485
    Likes Received:
    7,064
    Trophy Points:
    1,278
    Location:
    Michigan's Upper Peninsula
    Ratings:
    +8,406
    Current Phone Model:
    Pixel XL
    Twitter:
    jonny_ks
    I don't know that Media AUDIO needs to be on for the watch in your phone's BT settings for you to be able to control the music. I believe that just means that it will try to play the sound on the watch.

    My LG Watch Urbane doesn't have those audio options in my phone's BT settings, but based on what you were saying was happening, that's what the issue sounds like to me.

    Also, on my phone, my BT does say "disconnected" as well, even though the watch is connected. I'm thinking it has something to do with the AW app being what really connects the two, even though they use BT to communicate. These aren't really your standard BT connections.

    As for wifi, mine says Automatic when I first tap on wifi, but then it connects to the network and the network name is shown, followed by Add network, but if I scroll down, it then says Wi-Fi Automatic next to the wifi symbol with an A in it. When I tapped on that just now, it asked me if I wanted to turn wifi off. I went back and forth turning it off and on again before it would change back to Automatic. It would just either say On or Off where it have previously said Automatic.

    Still not sure how I got it back to automatic...Haha!

    I also did find options under Advanced for how long it should stay connected before going into Power Save mode, which I either didn't know was there or had forgotten.
     
    • Like Like x 1
  7. Jim 777

    Jim 777 Silver Member

    Joined:
    Dec 26, 2009
    Messages:
    2,307
    Likes Received:
    33
    Trophy Points:
    113
    Ratings:
    +34
    I paid more attention to what it says here and there and it shares more of what you explain than i thought. Once clicked on wifi, it does say automatic. Also as you just said, the AW does say connected and will push some things over. But the BT icon on the phone not showing connnected it turns out.... well.... wasn't connected because (wait for it)..... the phone BT wasn't on. I don't remember even considering turning it off.

    BAck to wifi, I was at work and I had yet to connect to the wifi there (had not entered the passphrase) but when I just went in to see available networks, it went right in to the wifi. I'm thinking it's getting the saved credentials from the phone. That;s kind of cool.
     
    • Like Like x 2
  8. Jonny Kansas

    Jonny Kansas Administrator
    Staff Member Rescue Squad

    Joined:
    Jan 21, 2010
    Messages:
    16,485
    Likes Received:
    7,064
    Trophy Points:
    1,278
    Location:
    Michigan's Upper Peninsula
    Ratings:
    +8,406
    Current Phone Model:
    Pixel XL
    Twitter:
    jonny_ks
    Yup. It totally takes the credentials from the phone.

    Sent from my Pixel XL
     
    • Like Like x 1
  9. Jim 777

    Jim 777 Silver Member

    Joined:
    Dec 26, 2009
    Messages:
    2,307
    Likes Received:
    33
    Trophy Points:
    113
    Ratings:
    +34
    Update:
    Thought I had it, received two calls yesterday and picked up the phone and connection was there. Then on the third, was going through the watch again. Weird. Found another permission and flipped it so we'll see.

    In my crawling around in the settings, I think I remember seeing something about after a certain amount of time of no activity, then the watch does something (like eco mode or something). I must have changed something because this morning after waking, I pushed a change to the watch and it didn't go. BT wasn't connected and it wouldn't connect as usual. Went in to settings on watch > BT > Devices and it asked if I wanted to turn on BT.

    Am I remembering that right? Is there something that is set to turn it off after no activity?
     
  10. Jonny Kansas

    Jonny Kansas Administrator
    Staff Member Rescue Squad

    Joined:
    Jan 21, 2010
    Messages:
    16,485
    Likes Received:
    7,064
    Trophy Points:
    1,278
    Location:
    Michigan's Upper Peninsula
    Ratings:
    +8,406
    Current Phone Model:
    Pixel XL
    Twitter:
    jonny_ks
    Depending on the Android version, it'll go into Doze mode to conserve power, but it should remain connected.

    However, you don't want to use the BT menu on the watch. Toggle BT off & back on on the phone & it'll usually reconnect.

    Sometimes it's as simple as opening the AW app on your phone.

    Did you give AW permission to stay connected on the phone when it asked?

    Sent from my Pixel XL
     
    • Like Like x 1
  11. Jim 777

    Jim 777 Silver Member

    Joined:
    Dec 26, 2009
    Messages:
    2,307
    Likes Received:
    33
    Trophy Points:
    113
    Ratings:
    +34
    The watch in doze mode? I'm guessing I flipped some setting trying to get what I want, but not sure which. And, it did it while I was sleeping.

    No, you're right, I don't want to have to navigate the watch menu. Usually I would just go in to the quick settings of the phone swiping down the notification bar and choose the watch in BT and it would connect, if needed to at all. This morning however, when I clicked the watch, it didn't even act like it was trying to connect, just a subtle screen change while my finger was touching it. I tried it three times (yes, because I am partially insane). Then noticed the Asus ZenWatch Manager app said "Disconnected" at the bottom of screen (that's rare) and AW wouldn't push changes. Only then did I go in and discover it had turned off.

    As for the permissions, I'm guessing that since it works everywhere when connected, I'm not denying anything. Well, somewhere I need to deny it trying to send a phone call to the watch ;-)
     
  12. Jonny Kansas

    Jonny Kansas Administrator
    Staff Member Rescue Squad

    Joined:
    Jan 21, 2010
    Messages:
    16,485
    Likes Received:
    7,064
    Trophy Points:
    1,278
    Location:
    Michigan's Upper Peninsula
    Ratings:
    +8,406
    Current Phone Model:
    Pixel XL
    Twitter:
    jonny_ks
    You can't change Doze settings, so it's unlikely that that is the cause.

    I'm not familiar with the ZenWatch manager app. Is it required? Out just offers extra functionality? Can you connect to the watch through that app alone, or do you have to have AW installed on the phone too?

    I'm just wondering if maybe the 2 apps are conflicting somehow...

    Sent from my Pixel XL
     
    • Like Like x 1