After deleting a number from a contact list, it re-appears

Discussion in 'General Discussions' started by DaveTheRave, Oct 13, 2019.

  1. DaveTheRave

    DaveTheRave Member

    Joined:
    Jul 8, 2012
    Messages:
    42
    Likes Received:
    4
    Trophy Points:
    8
    Location:
    Maryland, USA
    Ratings:
    +4
    I have a Samsung Galaxy S8. When I delete a phone number from a contact, it seems to take effect, but when I check the contact again, the number is still there.

    Details as follows:
    • Select Contacts.
    • Select an entry (in this case, my Dad). There are two "Home" numbers listed; the old and the new (entered about a week ago).
    • Press Edit.
    • Under "Phone", press the "-" symbol next to the desired number. It is removed from the list.
    • Press Save.
    • When the contact details are displayed again, the deleted number is still there.
    I've googled and several response say to either clear the specific Samsung app (don't know which one) or to clear system cache. I have not cleared the system cache yet - waiting to see if there's another solution.
     
  2. bkdodger

    bkdodger Administrator
    Staff Member

    Joined:
    Dec 13, 2011
    Messages:
    9,456
    Likes Received:
    6,210
    Trophy Points:
    1,563
    Location:
    Staten Island, New York
    Ratings:
    +6,522
    Current Phone Model:
    Nexus 6
    Hmmm .. are you contacts maybe syncing with another source ? Are they strictly on Samsung contacts ?

    Note10+
     
  3. DaveTheRave

    DaveTheRave Member

    Joined:
    Jul 8, 2012
    Messages:
    42
    Likes Received:
    4
    Trophy Points:
    8
    Location:
    Maryland, USA
    Ratings:
    +4
    Not sure. How would I go about checking? Maybe under gmail app? Also, I don't see a Samsung "Contacts" app.
     
  4. bkdodger

    bkdodger Administrator
    Staff Member

    Joined:
    Dec 13, 2011
    Messages:
    9,456
    Likes Received:
    6,210
    Trophy Points:
    1,563
    Location:
    Staten Island, New York
    Ratings:
    +6,522
    Current Phone Model:
    Nexus 6
    Yeah I was thinking maybe you have your contacts sync up to Google contacts.. If so check contacts from sign in to Google

    Note10+
     
  5. Miklb58

    Miklb58 Silver Member

    Joined:
    Aug 3, 2012
    Messages:
    800
    Likes Received:
    212
    Trophy Points:
    163
    Ratings:
    +237
    I for one hate the entire setup. I don't use VZW cloud, or any other backup other than Google, yet my contacts can show a home address 3 times. It takes them from Facebook (which I have an account but never use) also. Sorry for the rant, and I know it's not helping, but the whole setup is dumb if you ask me.

    Sent from my SM-N950U using Tapatalk
     
  6. DaveTheRave

    DaveTheRave Member

    Joined:
    Jul 8, 2012
    Messages:
    42
    Likes Received:
    4
    Trophy Points:
    8
    Location:
    Maryland, USA
    Ratings:
    +4
    I don't think I have Google Contacts. Because 1) Selecting it in Gmail sent me to Google Play. 2) Didn't see it in the Google group icon on the phone.

    Also, checked in Gmail under Settings > General Settings, and could not find anything that references syncing.

    Any other thoughts on where to look? Or to what else my phone might be syncing to?
     
  7. Sajo

    Sajo Diamond Member

    Top Poster Of Month

    Joined:
    Jan 25, 2013
    Messages:
    14,588
    Likes Received:
    11,953
    Trophy Points:
    2,463
    Location:
    Tennessee
    Ratings:
    +12,510
    Current Phone Model:
    Moto Z4
    Contacts app > overflow menu / hamburger menu / three dot menu - depending on phone model > what "Account" are Contacts synced with? This tells you whether they are synced with your Google account, Samsung account, local only, etc.

    Sent from my moto z4 using Tapatalk