Adb shell works on one phone but not on another?

Discussion in 'Android Hacks and Help' started by gnome_sayin, Mar 7, 2010.

  1. gnome_sayin
    Offline

    gnome_sayin New Member

    Joined:
    Jan 15, 2010
    Messages:
    35
    Likes Received:
    0
    Trophy Points:
    0
    On my Droid, I've fully rooted/ROM'd and been having a painless experience so far...

    So, I am trying to help a friend ROOT and update the ROM on his Droid as well.

    When I connect MY phone to the USB cable, I have no problem opening up a CMD prompt and executing "adb shell" and connecting.

    Trying to connect his phone to the same USB cable gets an "error: device not found" message. Any idea what the problem could be?

    So far, I have been able to successfully ROOT the phone, but after trying to install SPRecovery by following the directions below using the Android Terminal Emulator. When reboot the phone, I do NOT get the new SPRecovery console.

    su
    mount -o remount,rw -t yaffs2 /dev/block/mtdblock4 /system
    dd if=/sdcard/flash_image of=/system/bin/flash_image
    chmod 755 /system/bin/flash_image
    /system/bin/flash_image recovery /sdcard/recovery-0.99.3.img
    mv /system/recovery-from-boot.p /system/recovery-from-boot.old
    sync

    Any help would be greatly appreciated!!

    Jamie
  2. mikes
    Offline

    mikes New Member

    Joined:
    Jan 10, 2010
    Messages:
    305
    Likes Received:
    0
    Trophy Points:
    0
    Did you turn USB debugging on?
Search tags for this page

adb detects one phone but not another