1. You want that $100.00 in your pocket or an Amazon Fire TV don't you? Well here's the deal. With our new updated look we are in desperate need of an updated logo. The 'old' one has certainly served us well, but it's time. Find all the details here: bit.ly/1q0k6Wa
  2. DroidForums.net is currently undergoing a major software upgrade. If you are experiencing any problems logging in please: Contact Us

? about Google Checkout...HELP??

Discussion in 'Android Applications' started by GingerSpice, Aug 17, 2010.

  1. GingerSpice
    Offline

    GingerSpice New Member

    Joined:
    Aug 17, 2010
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    The Jersey Shore
    Ok, I've searched thru some of the help topics here and am just so frustrated I'm gonna go ahead and post the question/problem. If it's been addressed previously I apologize. I recently purchased a DroidX thru Verizon. Downloaded some free apps with no problem. But when I go thru the Marketplace and try to buy an app, I am running into a problem with Google Checkout. I set up an account via my PC, entered CC info, etc and clicked SAVE. I go to my phone, find an app I want to purchase, I get the "buy" area and it asks me to enter all CC info again. Should this be happening? If I created an account @ Google, and saved it, shouldn't my account automatically be pulled up when I go to purchase? The screen is asking me to select payment method, I go ahead and re-enter all the credit card info AGAIN, click "SAVE" at the bottom and get this error message "A server error has occurred. Retry, or cancel and return to the previous screen". So, what am I doing wrong here? Thanks in advance for your help oh great and mightly Droid Experts!!:wacko:
  2. wricks
    Offline

    wricks Premium Member Premium Member

    Joined:
    May 5, 2010
    Messages:
    374
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Burlington, NC
    First off, welcome to the fourm.

    Do you have auto-sync turned on? It syncs your Google account with your phone. Try this:

    Menu>Settings>Accounts & sync. Make sure the boxes for Background Data and Auto-sync are checked. Then click on your gmail account and check all that you want to sync. You can force them to sync by unchecking then rechecking the boxes.

    See if that helps.

    On the other hand, it could just be a market issue with trying to process so many new accounts.