802.1x connectivity

Discussion in 'Liberty ROM DX' started by Strikeir13, Feb 11, 2011.

  1. Strikeir13

    Strikeir13 Member

    Joined:
    Nov 3, 2010
    Messages:
    53
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0
    Has anyone on Liberty been able to connect to an 802.1x secured wireless network? The wireless at my university has that protection and it would new super nice to connect to their super fast connection. I have tried many things but so far I've been unsuccessful... Anyone?

    Sent from my DROIDX
     
  2. teakwood

    teakwood New Member

    Joined:
    Feb 9, 2011
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    I would assume you need the cert and you would have to add it in the wireless settings.
     
  3. Strikeir13

    Strikeir13 Member

    Joined:
    Nov 3, 2010
    Messages:
    53
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0
    I'll be a little more specific with my info. Here are the general configuration guidelines for my university:

    "To connect to the "[my university] Secure" SSID, you will need a device that supports 802.1X authentication and WPA2 Enterprise.


    [myuniversity] supports following EAP methods:
    EAP-PEAP with MSCHAPv2 (preferred)
    EAP-TTLS
    Encryption:
    AES

    Key Management:
    CCMP

    Certificate Details:
    Our X.509 certificate used for 802.1X authentication has a common name (CN) of "wireless.netaccess.umn.edu."

    The signing certificate authority (CA) is "Thawte Premium Server CA" and "AddTrust External CA Root"

    The wifi.supplicant.conf file that is generated when I try to connect to the network is the following:

    network={
    ssid="[myuniversity] Secure"
    key_mgmt=IEEE8021X
    group=WEP104
    eap=PEAP
    identity="[my username]"
    password="[my password]"
    phase2="auth=MSCHAPV2"
    priority=40
    }

    Any further insight would be greatly appreciated.
     
  4. teakwood

    teakwood New Member

    Joined:
    Feb 9, 2011
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Without having a 802.1X network to test with, you can enable wireless, head to settings then wireless and networks wifi settings.. Scroll to the bottom add wifi network... under security there is a drop down select 802.1X EAP setup from there... I hope this helps.
     
  5. Strikeir13

    Strikeir13 Member

    Joined:
    Nov 3, 2010
    Messages:
    53
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0
    I have done this and my wireless configuration settings above show that.
     
  6. Stevo592

    Stevo592 New Member

    Joined:
    Oct 17, 2010
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Does your school use some sort of NAC? In order to get my droid on my network at school I had to tell them my mac address because cisco doesn't make a nac agent for the droid....or for any other operating system besides windows which pissed me off. I would go talk to the IT department incharge of the network and ask them what they think.
     
  7. jestyr

    jestyr New Member

    Joined:
    Jul 27, 2010
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    At my university I had to actually go an MANUALLY set up the wireless connection. Our wireless is secured similar to yours...802.1 EAP bla bla bla. Every time I tried to go to my wireless setting I would see the wireless network listed, I would click that entry and fill out the rest of the relevant information (username and password). But then when it would try to connect and pull an IP it would just fail. Finally I just told the phone to forget the network and then created it by hand. Same SSID, same settings...everything the same, just entered it in manually. Boom, it worked that time. And this wasnt just for me on my phone. All the people in my office that ran the older Droids had the same problem but entering it in by hand fixed them up.
     
  8. teakwood

    teakwood New Member

    Joined:
    Feb 9, 2011
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Sorry I misunderstood what you were asking.. I didnt realize you HAD the certificate already I thought you sent the config from the uni website.

    I would try above as it does not sound like the cert installed correctly.
     
  9. droidxchat

    droidxchat Member

    Joined:
    Oct 15, 2010
    Messages:
    466
    Likes Received:
    0
    Trophy Points:
    16
    Ratings:
    +0
    Im currently connected to 802.1x EAP on liberty 1.5

    Sent from my DROIDX using DroidForums App
     
  10. Strikeir13

    Strikeir13 Member

    Joined:
    Nov 3, 2010
    Messages:
    53
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0
    What are your settings? And did you manually enter the settings or not?

    Sent from my DROIDX
     
  11. Strikeir13

    Strikeir13 Member

    Joined:
    Nov 3, 2010
    Messages:
    53
    Likes Received:
    0
    Trophy Points:
    6
    Ratings:
    +0
    What do you mean entered the settings by hand? As in manually edited the wifi.supplicant file? If so, what was your method for doing that?

    Sent from my DROIDX
     
  12. droible

    droible New Member

    Joined:
    Aug 3, 2010
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Did you ever figure this out? I have been having the same problems with my DX, and it appears we're at the same university. I'd love to be able to connect to wifi again. When I contacted tech support they just told me android wasn't supported :icon_evil:
     
Search tags for this page
802.1eap manually add ip
,
motorola razr 802.1x
,
peap connection android rom s4
,
razr 802.1x
,
razr m wifi connection problem with 802.1x
,

secured with 802.1x

,
secured with 802.1x motorola
,
umn wireless android
,
wifi 802.1x eap rarz i
,
wifi secured with 802.1x droid dna