1. You want that $100.00 in your pocket or an Amazon Fire TV don't you? Well here's the deal. With our new updated look we are in desperate need of an updated logo. The 'old' one has certainly served us well, but it's time. Find all the details here: bit.ly/1q0k6Wa
  2. DroidForums.net is currently undergoing a major software upgrade. If you are experiencing any problems logging in please: Contact Us

4.2 - "system read-only error" when running scripts

Discussion in 'Project Elite' started by dpaine88, Mar 30, 2011.

  1. dpaine88
    Offline

    dpaine88 New Member

    Joined:
    Jul 18, 2010
    Messages:
    811
    Likes Received:
    1
    Trophy Points:
    0
    For those of you unfamiliar with prime's awesome kernel here is the link to what I am talking about http://www.droidforums.net/forum/cyanogenmod/127262-kernel-deprimed_test-break-if-you-can.html

    His kernel allows the user to change from SV to LV by running a terminal command that creates a file specifying the voltage/speeds called "20overclock" and creates this file in /system/etc/init.d

    However, when me and other users runnign 4.2 PE try this, we get an error stating the system is read-only.

    SU is performed and given, and the system has been mounted as RW, but still does not work.

    Anyone have any ideas?
  2. tomsyco
    Offline

    tomsyco New Member

    Joined:
    Oct 29, 2010
    Messages:
    98
    Likes Received:
    0
    Trophy Points:
    0
    I second this! I'm having the exact same problem. I even went into elite settings and set the system as Read/Write.
  3. tomsyco
    Offline

    tomsyco New Member

    Joined:
    Oct 29, 2010
    Messages:
    98
    Likes Received:
    0
    Trophy Points:
    0
    @ dpaine

    Are you having any other issues with this kernel? The only issue I have is when I delete an email, it doesn't really move it to the trash.
  4. mrkelly88
    Offline

    mrkelly88 New Member

    Joined:
    Sep 7, 2010
    Messages:
    110
    Likes Received:
    1
    Trophy Points:
    0
    Location:
    Milwaukee, WI
    I had this same issue with PE 5.2 ... try going into root explorer and mount the sys as R/W in there.. that seemed to work for me (i really didn't think it was going to at first, but it did)... its worth a shot
  5. dpaine88
    Offline

    dpaine88 New Member

    Joined:
    Jul 18, 2010
    Messages:
    811
    Likes Received:
    1
    Trophy Points:
    0
    Nope, running great so far.
  6. tomsyco
    Offline

    tomsyco New Member

    Joined:
    Oct 29, 2010
    Messages:
    98
    Likes Received:
    0
    Trophy Points:
    0
    Mine is fine too now.
  7. dpaine88
    Offline

    dpaine88 New Member

    Joined:
    Jul 18, 2010
    Messages:
    811
    Likes Received:
    1
    Trophy Points:
    0
    Awesome man, this worked for me. Thanks for the help.
Search tags for this page

android 4.2.1 read only file system

,

htc mount -o remount,ro /system /system

,

metamorph system could not be mounted as rw