1. DroidForums.net is currently undergoing a major software upgrade. If you are experiencing any problems logging in please: Contact Us

2.0.2 install issues

Discussion in 'cvpcs' started by ekarber1, Feb 23, 2011.

  1. ekarber1
    Offline

    ekarber1 New Member

    Joined:
    Sep 12, 2010
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Indiana
    I have been trying to install the new Sapphire 2.0.2 for the last 4 hours, I keep getting the same run around. I have followed all the instructions, and yet it doesn't seem to be working. I selected the ROM to update, clear cache and wipe date, backup current update, chose the kernel to use and hit ok. It will restart my phone and take me back to the very beginning changing nothing. :confused:
    Any ideas on how to get it to update? I would greatly appreciate the help. :)
  2. adsfa34
    Offline

    adsfa34 New Member

    Joined:
    Aug 11, 2010
    Messages:
    417
    Likes Received:
    0
    Trophy Points:
    0
    a few things...

    1) are you using ROM Manager?
    2) what "instructions" are you following? (post a link so we can see what you're seeing)
    3) where did you download the ROM? if you got it from ROM Manager, try another download, directly from the ccroms website. make sure to download both the update.zip file AND the gapps (google apps pkg). here and move both files to your sdcard using your computer
    4) by "take me back to the very beginning changing nothing" what do you mean? what's "the beginning"? the recovery screen? if so, what does it look like exactly? or do you mean the activation screen, where you need to tap the droid to begin?

    a couple of things to get you started:

    1) don't flash a custom kernel until you have both had a successful and stable boot and made a backup of your stable state
    2) charge your phone so that you don't run out of battery -- it's dangerous to be in recovery at low levels of battery

    once we get a little more info from you, we'll know how to help :D
  3. ekarber1
    Offline

    ekarber1 New Member

    Joined:
    Sep 12, 2010
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Indiana
    Thank you for the help. I actually fixed the problem at like 3 am. I felt stupid, it was because my phone wasn't fully charged.

    Sent from my Droid using DroidForums App
  4. adsfa34
    Offline

    adsfa34 New Member

    Joined:
    Aug 11, 2010
    Messages:
    417
    Likes Received:
    0
    Trophy Points:
    0
    lol happens to everyone sooner or later
  5. ekarber1
    Offline

    ekarber1 New Member

    Joined:
    Sep 12, 2010
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Indiana
    Now I have another question. My phone seems to be EATING all my battery life. I charged it this morning 'til 8 and it was already dead by 4. Normally it'll last 'til almost the end of the day, but today after I installed to new ROM it lasted all of 8 hours.
    Do you have any suggestions on how to conserve battery power? I have the display set on the lowest, I also have it set to where it times out after 15 seconds. I'm not sure what other things I can do.
  6. adsfa34
    Offline

    adsfa34 New Member

    Joined:
    Aug 11, 2010
    Messages:
    417
    Likes Received:
    0
    Trophy Points:
    0
    i would suggest charging your battery to 100%, booting into recovery, and wiping battery stats (under advanced menu)

    then return your phone to 100% charge, unplug it and let it die all the way (it may sit at 5% for a looooong time)

    this can happen if you wipe and install a ROM on less than 100% battery

    if that doesn't help the issue, then there are other things to try, e.g. alternate kernels with lower voltages (raidzero's 125-800MHz LV kernel is CRAZY fast set on interactive governor...hint hint ;))
  7. Wraith
    Offline

    Wraith New Member

    Joined:
    Jan 8, 2010
    Messages:
    129
    Likes Received:
    0
    Trophy Points:
    0
    Tagging onto this thread...

    I'm actually having a problem updating my Droid to Sapphire 2.0.2 from Sapphire 1.1.0, so tagging on here.

    FIRST, I tried to use RM to install the update. That seemed to be going well, all the way to the install. I get the batwings, then after a minute or 2 the batwings again, then the Gem animation, then I am back to Sapphire 1.1.0.

    THEN, I tried to manually get to SP recovery to apply the update.zip. It does not let me into SPrecovery.

    THEN, I tried to install SP Recovery with RSDlite, and I get this error;
    "Failed Flashing Process. Unable to retreive initialization values from INI file..." It sees my device (after drivers installed), but keeps giving me this error.

    Anyways...if someone has a min to respond, thanks in advance. I DID NOT have a problem with the last update I did about a year ago, but I don't do this often....so must be forgetting something.
  8. adsfa34
    Offline

    adsfa34 New Member

    Joined:
    Aug 11, 2010
    Messages:
    417
    Likes Received:
    0
    Trophy Points:
    0
    that error msg is usually displayed when the wrong sbf file is attempted. first, you can try using sbf_flash for linux instead of rsdlite. it's supposed to be more reliable, and it's not proprietary software. you can learn more about sbf_flash here (thanks to maderschramm)

    my first recommendation would be to try an updated recovery image -- raidzero has done an *EXCELLENT* job at building a near-perfect recovery. he also provides an sbf so that you can flash it directly.

    try flashing the raidzero recovery sbf and hopefully that will fix your problem :)

    let us know how it goes.
  9. Wraith
    Offline

    Wraith New Member

    Joined:
    Jan 8, 2010
    Messages:
    129
    Likes Received:
    0
    Trophy Points:
    0
    Got the recovery and tried to flash it. Same thing. It could be the computer I am using, I did not get an "admin" option in RSDlite shortcut or properties, but I did set user to full permissions. It stops really quickly.

    Anyways, if that's what I need to do, I will try that at home on my puter.
  10. Wraith
    Offline

    Wraith New Member

    Joined:
    Jan 8, 2010
    Messages:
    129
    Likes Received:
    0
    Trophy Points:
    0
    :r_c:Ok, so both my work and home computer (XP) have my "user" settings as "administrator". Both computers have the same error when trying to flash. Still not sure if it's the "admin" setting, as trying to start RSDlite as "administrator" appears to be differrent , and I don't have the passwords for that. Could this still be the problem? Last time I did this it went quick, but also don't know why phone won't go into recovery, especially since I even have that option on power-down.

    Still stuck trying to flash, with that error previously stated...
  11. Wraith
    Offline

    Wraith New Member

    Joined:
    Jan 8, 2010
    Messages:
    129
    Likes Received:
    0
    Trophy Points:
    0
    Got it!

    What worked for my Droid was to use Rom Manager and install Clockwork recovery (at least 3 times), until it immediately said it was installed. Then it successfully rebooted into recovery.

    I already had update.zip ready for install, that worked fine. Went to Sapphire 2.0.2 ! Wheee!

    Then installed google apps update same way, but phone locked up on opening screen "Press Droid to Continue". So I went back to recovery and did factory wipe, rebooted and everything back to normal!

    Then, just for fun, installed GO Launcher EX (as I was unsing LP), and wow...what a difference. Much more snappy with all the features I loved about LP.

    Anyways, in case this helps anyone else...that's what I did to get back on board.
Search tags for this page

sapphire rom 2.0.2 droid working link