So im rooted and on 4.1.1 I want to flash a cm rom and I have before on an older phone but its been about a year and im nervous.

Does the rom I flash have to be a 4.1.1 rom? Do I need to update to a higher version? If so how? (I though i heard of 4.2.2 or something)
How do I know what gapps I need and where do I get them? Anything else I need to know?

Sent from my GT-P5113 using Tapatalk 2