DroidForums.net is the original Verizon Android Forum! Registered Users do not see these ads. Please Register - It's Free!
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11

Thread: Really need help with this - Wifi at Work

  1. Senior Droid
    Canefan's Avatar
    Member #
    19956
    Join Date
    Dec 2009
    Posts
    125
    Phone
    Motorola Droid
    #1

    Really need help with this - Wifi at Work

    When I connect to the Wi-Fi at work, my browser won't connect and says, "Web page not available". I talked with the IT department about it, and they said the phone is not allowing me to accept the wireless certificate, so even though I am connected to the wireless, I can't access the internet. My co-worker has an iPhone, and when he accesses the Wi-Fi for the first time each morning, his browser shows a pop-up that says "Accept Website Certificate - The certificate for this website is invalid. Tap accept to connect to this website anyway" and then he can select either "accept" or "cancel". When he hits "accept", the browser takes him to a page that says, "Welcome to the Cisco Wireless Network. Cisco is pleased to provide the Wireless LAN infrastructure for your network. Please login and put your air space to work." There is an "accept" button for him to hit, and then his browser has access to the Wi-Fi. My problem is that my browser is not showing the initial pop-up or taking me to the browser login page, it just says "Web page not available". The IT guys say there must be a preference or setting in my phone that will allow me to get these initial messages, but I can't find them anywhere. Any ideas would be greatly appreciated!
  2. Master Droid
    bamfsig45's Avatar
    Member #
    465
    Join Date
    Nov 2009
    Location
    ICT
    Posts
    895
    Liked
    1 times
    Phone
    Thunderbolt & Xoom
    #2
    Have you tried Dolphin or Steel browser?

    Sometimes a "smartphone" is only as smart as its user.




  3. Senior Droid
    Canefan's Avatar
    Member #
    19956
    Join Date
    Dec 2009
    Posts
    125
    Phone
    Motorola Droid
    #3
    Quote Originally Posted by bamfsig45 View Post
    Have you tried Dolphin or Steel browser?
    Tried Dolphin. No Luck there. Had high hopes because you can change the identifier to either Desktop or iPhone. Same response. Not familiar with Steel Browser. I'll look at it.
  4. Senior Droid
    Canefan's Avatar
    Member #
    19956
    Join Date
    Dec 2009
    Posts
    125
    Phone
    Motorola Droid
    #4
    Same thing with Steel browser (nice btw). There are no settings that affect how the phone handles invalid certificates. The request fails on the redirect to the Cisco login page. This is a huge problem for me because my 3G reception is poor in the part of the building where I spend most of my time and the open Wifi network is readily available and superfast. It kills me that my iPhone and Blackberry colleagues can get on it no problem.
  5. Master Droid
    MM1 Payne (US Navy)'s Avatar
    Member #
    25616
    Join Date
    Jan 2010
    Location
    Florida.
    Posts
    270
    Phone
    Moto Droid Rooted: BB 950Mhz
    #5
    1. Open Wifi Settings
    2. Click "Add a Wifi Network"
    3. Enter the SSID and click the security Drop down.
    4. Select your security Method. (I selected 802.1x Enterprise. This is probably the only security option that presents you with the additional inputs needed.)
    5. After selecting that option the dialog will change and will include the following options:

    EAP Method
    Phase 2 Authentication
    CA Certificate
    Client Certificate
    Identity (i.e. network username)
    Anonymous Identity
    Wireless Password (i.e. your network password)

    For my network, I had to select PEAP, then MSCHAP for the Phase2 Auth. I left the certificates blank, since our Wifi does not require them. I then entered my domain username for the "Identity" field. I left "Anonymous Identity" blank and entered my network password under "Wireless Password". I was then able to connect successfully.

    Hope this helps!
    HPF Turbo Stage II Kit:17,000$
    Blue Candy Paint Finish: 3,000$
    DrOiD Kickin' it on the dashboard:600$

    Watching your ex and her new boyfriend stare at your bimmer as they crash into a tree.....
    PRICELESS
  6. Junior Droid
    mzman's Avatar
    Member #
    26377
    Join Date
    Jan 2010
    Posts
    14
    Phone
    Moto Droid
    #6
    I believe I am having the same problem at my work and Uni wifi. iPod touch connects then I open safari to input my credentials, sometimes I get the certificate notice. But with the Droid it sees the network, then says it is out of range and will not ever display the login page on the browser.

    I will try out the above and report back.
    Last edited by mzman; 01-11-2010 at 03:03 PM.
  7. Senior Droid
    Guurzak's Avatar
    Member #
    22606
    Join Date
    Jan 2010
    Posts
    125
    Phone
    Motorola Droid
    #7
    Quote Originally Posted by Canefan View Post
    When I connect to the Wi-Fi at work, my browser won't connect and says, "Web page not available". I talked with the IT department about it, and they said the phone is not allowing me to accept the wireless certificate, so even though I am connected to the wireless, I can't access the internet. My co-worker has an iPhone, and when he accesses the Wi-Fi for the first time each morning, his browser shows a pop-up that says "Accept Website Certificate - The certificate for this website is invalid. Tap accept to connect to this website anyway" and then he can select either "accept" or "cancel". When he hits "accept", the browser takes him to a page that says, "Welcome to the Cisco Wireless Network. Cisco is pleased to provide the Wireless LAN infrastructure for your network. Please login and put your air space to work." There is an "accept" button for him to hit, and then his browser has access to the Wi-Fi. My problem is that my browser is not showing the initial pop-up or taking me to the browser login page, it just says "Web page not available". The IT guys say there must be a preference or setting in my phone that will allow me to get these initial messages, but I can't find them anywhere. Any ideas would be greatly appreciated!
    Your company is using a Cisco WLC wireless system. This system comes preinstalled with a self-signed certificate, but this certificate should never be used in a production environment. If the network needs secure https logins it should replace the built-in cert with either a commercial cert or one they issue from their own CA. But there's no reason to use any cert at all if they're just going to have you press "accept". Tell your IT staff that if they allow http access to the webauth page, they will lose nothing and make things easier for clients which reject self-signed certs. (The Droid is far from the only device which does this.)
  8. Senior Droid
    Canefan's Avatar
    Member #
    19956
    Join Date
    Dec 2009
    Posts
    125
    Phone
    Motorola Droid
    #8
    Quote Originally Posted by Guurzak View Post
    Your company is using a Cisco WLC wireless system. This system comes preinstalled with a self-signed certificate, but this certificate should never be used in a production environment. If the network needs secure https logins it should replace the built-in cert with either a commercial cert or one they issue from their own CA. But there's no reason to use any cert at all if they're just going to have you press "accept". Tell your IT staff that if they allow http access to the webauth page, they will lose nothing and make things easier for clients which reject self-signed certs. (The Droid is far from the only device which does this.)
    My workplace is a large metropolitan hospital. There is no way that they are going to change their setup because my phone can't connect. Is there no way around this? My old WinMo phone worked just fine, I can't believe the cutting edge Droid can't create an exception for an invalid cert.
  9. Senior Droid
    Canefan's Avatar
    Member #
    19956
    Join Date
    Dec 2009
    Posts
    125
    Phone
    Motorola Droid
    #9
    Quote Originally Posted by MM1 Payne (US Navy) View Post
    1. Open Wifi Settings
    2. Click "Add a Wifi Network"
    3. Enter the SSID and click the security Drop down.
    4. Select your security Method. (I selected 802.1x Enterprise. This is probably the only security option that presents you with the additional inputs needed.)
    5. After selecting that option the dialog will change and will include the following options:

    EAP Method
    Phase 2 Authentication
    CA Certificate
    Client Certificate
    Identity (i.e. network username)
    Anonymous Identity
    Wireless Password (i.e. your network password)

    For my network, I had to select PEAP, then MSCHAP for the Phase2 Auth. I left the certificates blank, since our Wifi does not require them. I then entered my domain username for the "Identity" field. I left "Anonymous Identity" blank and entered my network password under "Wireless Password". I was then able to connect successfully.

    Hope this helps!
    Thanks for the suggestion. Unfortunately the only way to get the phone to recognize the wifi router is to specify None for security. With the Enterprise selection, it says Out of Range.
  10. Droid Newbie
    XJBluto's Avatar
    Member #
    34465
    Join Date
    Feb 2010
    Posts
    4
    Phone
    Motorola Droid
    #10

    WI Fi

    If we installed a commercial certificate on the Cisco Wireless Lan Controllers would issue be resovled ?

    Would the Droid accept the commercial cert with no problem?
Page 1 of 2 1 2 LastLast

Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. WiFi connects fine, but doesn't work
    By Swollfin in forum Android General Discussions
    Replies: 18
    Last Post: 08-10-2011, 10:28 AM
  2. wifi issue with Optimum Wifi
    By brucin in forum Android Tech Support
    Replies: 10
    Last Post: 02-24-2010, 01:53 PM
  3. How does WiFI tracker work?
    By rjsurfer in forum Android Applications
    Replies: 0
    Last Post: 01-09-2010, 02:32 PM
  4. does any IM app actually work well??
    By bluemsw in forum Android Applications
    Replies: 26
    Last Post: 12-15-2009, 11:05 PM
  5. Can't get wifi to work at home
    By loboblanco in forum Android General Discussions
    Replies: 8
    Last Post: 12-05-2009, 01:00 PM

Search tags for this page

accept website certificate ipad

,

android wifi anonymous identity

,

anonymous identity wifi

,
anonymous identity wifi android
,
cisco is pleased to provide the wireless
,
cisco is pleased to provide the wireless lan infrastructure
,

welcome to the cisco wireless network

,

what is anonymous identity in wifi

,
what is anonymous identity wifi
,

wifi anonymous identity

Click on a term to search our site for related topics.
Find us on Google+