DroidForums.net is the original Verizon Android Forum! Registered Users do not see these ads. Please Register - It's Free!
Results 1 to 4 of 4

Thread: botched ROM, failing recovery, long error message in text

  1. Junior Droid
    soccer_doc's Avatar
    Member #
    Join Date
    Feb 2011
    Droid 1

    botched ROM, failing recovery, long error message in text

    Apologies in advance for long post. Trying to be concise, but complete. Have tried a long time to resolve this myself on this forum, CM forums, Wiki, et al.

    In spite of (what I thought was) careful planning and extensive reading, I still managed to FUBAR my first attempt at running a mod.

    For now, just trying to get back to stock.

    Current Status:
    Mod version CM 6.1.2-Droid

    How I got here:
    - Successfully rooted following excellent directions from MotoCache1 in this forum.
    - Successfully installed ROM manager (free) and purchased full version.
    - Downloaded Titanium Backup (free) in market and purchased Pro.
    - ran Titanium Backup
    - Downloaded CyanogenMod 6.1.2
    - Backed up in ROM manager, creating custom backup name
    - Installed CM ROM via ROM manager, selecting Wipe Data and Backup ROM (had to do this 3 times. first 2 times it said 'Need to Run Clockwork', even though I already had. 3rd time it ran). My reading led me expect that I would be given an option to retain Google Apps. This didn't happen.

    The problem:
    - CM runs fine.
    - No Google apps.
    - I have attempted to find, download, install a "gapps.apk", which I think will install the basic Google apps I'm missing? I really only care about Market, for now. Some threads link to Google sites that allow me to run as Web Apps, but not on phone as before.
    - NONE of my back-ups are on my SD card. Other data and files are there. I actually copied my entire SD card to my external drive at home. When I get back there in a few days, I may be able to fix this myself.
    -I deleted and reinstalled the CM, no change.
    -I re-downloaded the FROYO update.zip in an effort to get back where I started. This is where I fail.

    Boot Screen says:

    assert failed: file...getprop("/system/build.prop", "ro.build.fingerprint") == "verizon/voles/sholes/sholes:2.2/FRg01B/45394:user/release-keys"
    E:Eror in /sdcard/update.zip

    I am not in dire straits. Phone works, texting works, email works. CAN get my contacts (exported file to my SD). Just want to get Market back, access to previous downloads, and a few other things.

    Thanks in advance for any advice or re-direction..........

  2. Junior Droid
    soccer_doc's Avatar
    Member #
    Join Date
    Feb 2011
    Droid 1

    found working gapps link here

  3. Droid Sensei
    BayouFlyFisher's Avatar
    Member #
    Join Date
    Dec 2009
    Baton Rouge, LA
    86 times
    Galaxy Note 2
    JB, excellent "issues" post. It provided a clear description of the issues and, as should always be done, a clear description of events leading up to the problem. Very good!

    I used Clockwork for a very long time and learned it's little idiosyncrasies. Here are my notes (btw, I did not use Rom Manager to install roms/kernels/themes):

    Clockwork Notes:

    The first thing about Clockwork is trying to get Rom Manager to flash a good copy onto your phone. Here is a fool proof method to determine whether you have a good copy before trying to reboot into it. Begin by scrolling down and flashing the alternative recovery – SpRecovery. After it successfully loads, scroll up and flash Clockwork. If it takes longer than 3-5 seconds to get the popup telling you the install was successful, reflash it over and over until you do get that popup in 3-5 seconds. Once that happens, you have a good install.

    Once you have rebooted into Clockwork and are navigating through its menu, if at any time it hesitates that means it is about to reboot automatically. When Clockwork does reboot and the screen goes dark, immediately press and hold the X key until the phone reboots back into Clockwork. Clockwork will now be totally stable until you finish.

    If the first thing you do with Clockwork, during any particular session, is to try and make a Nandroid backup and you get an error message (without regard to what it says), you should just wait a few seconds and not do anything. That is because Clockwork is about to reboot the phone. As stated above, as soon as the screen goes dark, press and hold the X key until the phone reboots back into Clockwork. Then start over and Clockwork will work as it was intended for the rest of the session.

    Also, you should know that there is a new recovery available now - RZR. It is based on SPR. I have been using it for some time now and it is terrific. It is stable and more fully functioned than either SpRecovery or Clockwork. Here’s a link to the thread ([Recovery] RZR SPR-based *update.zips-battery charging-more*). You download the zip, put it on the root of the sdcard and then install it with Clockwork or SPR.
    Baton Rouge, LA
  4. Junior Droid
    soccer_doc's Avatar
    Member #
    Join Date
    Feb 2011
    Droid 1

    Problem (mostly) solved

    As you suggest above, maybe my problems were related to Clockwork?

    Before receiving your post, I "played around" a bit more as follows:

    - I did locate and download the gapps addon from the CM Wiki site above
    - this successfully loaded all Google Apps, but Market would not function properly
    - at this point, I realized I had downloaded the wrong gapps file ("tiny", rather than "hdpi")
    - I intended to delete the "tiny" gapps.zip from my sd, reboot the CM6 mod from ROM manager, then load the "hdpi" gapps.zip to the sd, then reboot with gapps.

    When I deleted the gapps.zip file and rebooted from ROM Manager (again wiping and backing up), I booted into CM6 with all Google Apps installed and functioning normally.

    I logged into my Google account, reinstalled my Contacts by importing from the *.vcf file I'd backed up to my sd card, and reinstalled previously purchased apps from the Market.

    Everything works.

    Some day when I have the time, patience, and cojones, I will probably take your advice and install RZR.

    I'm also not sure how to get back to the Stock ROM, if I ever have a reason to. Right now I'm just enjoying being fully functional.

    Thanks for the advice. I hope the detailed account saves someone else some trouble somewhere.



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Similar Threads

  1. Text message error
    By ssimon03 in forum Motorola Droid 2 Global
    Replies: 4
    Last Post: 02-24-2011, 11:12 PM
  2. Error message in ROM Manager/ Cannot boot in Recovery
    By Keller86 in forum Droid X Hacks
    Replies: 12
    Last Post: 11-24-2010, 06:41 PM
  3. Why does it take so long for text message apps to open?
    By DroidPDX in forum Droid X Tech Support
    Replies: 4
    Last Post: 08-23-2010, 12:35 AM
  4. Error Message trying to flash SP recovery.
    By Biggage7j in forum Android Tech Support
    Replies: 1
    Last Post: 07-07-2010, 12:57 PM
  5. can't install Recovery - error message
    By MaxPower in forum Android Hacks and Help
    Replies: 8
    Last Post: 04-29-2010, 06:47 AM

Search tags for this page

cyanogen assert failed

cyanogen galaxy s2 assert failed

droid 1 assert failed

droid 2 global assert failed

failed to install rom

long error message

recovering failed rom instalation android
remove cyanogen assert failed file getprop
rom manager troubleshooting failed to backup bionic

titanium backup pro apk

Click on a term to search our site for related topics.
Find us on Google+